Bug 436520 - [RFE] No support for font-stretch above the vcl level
[RFE] No support for font-stretch above the vcl level
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: openoffice.org (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: David Tardon
Fedora Extras Quality Assurance
: FutureFeature
: 681930 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-03-07 12:59 EST by Nicolas Mailhot
Modified: 2016-11-10 09:44 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-11-10 09:44:22 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
OpenOffice.org 79878 None None None Never

  None (edit)
Description Nicolas Mailhot 2008-03-07 12:59:28 EST
Description of problem:

Following the ongoing discussion on proper complex font support
http://qa.openoffice.org/issues/show_bug.cgi?id=79878 I retested the fedora OO.o

Unfortunately it seems that while the face list in the new font selector has
indeed been fixed, it's still not really working

When you select a DejaVu Sans Condensed face, and compare it to its not
condensed sibling, you realise the same face is being used. Selecting DejaVu
Sans Condensed Oblique gives the same results as DejaVu Sans Oblique, for
example. The GTK2 font selector OTOH gets this part right.

So the Fedora patch needs to be revisited


Version-Release number of selected component (if applicable):

openoffice.org-core-1:2.4.0-9.1.fc9.x86_64
Comment 1 Caolan McNamara 2008-03-07 14:44:53 EST
absolutely no way am I taking this as a F-9 blocker
Comment 2 Nicolas Mailhot 2008-03-09 17:54:54 EDT
(In reply to comment #1)
> absolutely no way am I taking this as a F-9 blocker

Sure, that's why it was proposed as target, not blocker

I'm not as wholly insane as it may seem sometimes
Comment 3 Caolan McNamara 2008-03-10 13:31:33 EDT
We don't carry any patches for the font dialog any more, the original missing
names was a little bug in vcl that wiped them out, and that got applied upstream
as well. Now that they get as far as the dialog we can see that we have some
more tricky issues.

Added my own comments to that issue along the lines of how I think we'd have to
add this support, Assuming that I'm right, I think it's going to be a bit of a
pain to get this in place. I suspect we need to store the condensed etc. values
in our file format like svg in a font-stretch/font-width attribute, and there
*may* be a difficulty in not having a specified -asian/-complex variants of that
as we do for font-width, font-pitch. 
Comment 4 Caolan McNamara 2008-04-18 08:40:49 EDT
I need to check with the xml guys as to how we should describe this in the file
format
Comment 5 Jon Stanley 2008-04-23 16:29:39 EDT
Adding FutureFeature keyword to RFE's.
Comment 6 Caolan McNamara 2011-03-04 04:07:51 EST
*** Bug 681930 has been marked as a duplicate of this bug. ***
Comment 7 Caolan McNamara 2016-11-10 09:44:22 EST
its clear we're not going to implement this downstream

Note You need to log in before you can comment on or make changes to this bug.