Bug 436527 - Logout from kde with Kernel 2.6.24.3-12.fc8 crashes X
Logout from kde with Kernel 2.6.24.3-12.fc8 crashes X
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
8
i686 Linux
low Severity high
: ---
: ---
Assigned To: Dave Airlie
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-03-07 13:47 EST by Mike C
Modified: 2008-03-23 17:20 EDT (History)
4 users (show)

See Also:
Fixed In Version: 2.6.24.3-34.fc8
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-03-23 14:55:50 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Xorg.0.log immediately following the problem (40.14 KB, text/plain)
2008-03-07 13:51 EST, Mike C
no flags Details
Xorg.conf (802 bytes, text/plain)
2008-03-07 13:54 EST, Mike C
no flags Details
Xorg.0.log immediately following the problem described for the previous kernel (39.65 KB, text/plain)
2008-03-07 14:12 EST, Mike C
no flags Details
Oops on KDE logout (5.18 KB, text/plain)
2008-03-09 17:23 EDT, Oron Peled
no flags Details

  None (edit)
Description Mike C 2008-03-07 13:47:33 EST
Description of problem:Logging out from kde when running the kernel
2.6.24.3-12.fc8 causes X to crash. This did not occur with the previous kernel.


Version-Release number of selected component (if applicable):kernel-2.6.24.3-12.fc8


How reproducible:Every time


Steps to Reproduce:
1. Boot machine, and login to kde
2. logout as normal user from kde
3.
  
Actual results:
X crashes and will not restart unless machine is rebooted. ssh is still possible
into machine and switching to other VTs is still working after X crashes.

Expected results:X should not crash


Additional info:
The relevant final part of /var/log/messages immediately after the crash is:
Mar  7 18:31:44 samsung1 dhclient: bound to 10.0.0.61 -- renewal in 12247 seconds.
Mar  7 18:31:47 samsung1 acpid: client connected from 2616[0:0]
Mar  7 18:31:49 samsung1 kernel: [drm] Initialized drm 1.1.0 20060810
Mar  7 18:31:49 samsung1 kernel: [drm] Initialized i915 1.11.0 20071122 on minor 0
Mar  7 18:32:20 samsung1 gconfd (debbie-2854): starting (version 2.20.1), pid
2854 user 'debbie'
Mar  7 18:32:20 samsung1 gconfd (debbie-2852): starting (version 2.20.1), pid
2852 user 'debbie'
Mar  7 18:32:20 samsung1 gconfd (debbie-2854): Failed to get lock for daemon,
exiting: Failed to lock '/tmp/gconfd-debbie/lock/ior': probably another process
has the lock, or your operating system has NFS file locking misconfigured
(Resource temporarily unavailable)
Mar  7 18:32:20 samsung1 gconfd (debbie-2852): Resolved address
"xml:readonly:/etc/gconf/gconf.xml.mandatory" to a read-only configuration
source at position 0
Mar  7 18:32:20 samsung1 gconfd (debbie-2852): Resolved address
"xml:readwrite:/home/debbie/.gconf" to a writable configuration source at position 1
Mar  7 18:32:20 samsung1 gconfd (debbie-2852): Resolved address
"xml:readonly:/etc/gconf/gconf.xml.defaults" to a read-only configuration source
at position 2
Mar  7 18:35:24 samsung1 gconfd (debbie-2852): Received signal 15, shutting down
cleanly
Mar  7 18:35:24 samsung1 gconfd (debbie-2852): Exiting
Mar  7 18:35:25 samsung1 acpid: client connected from 2616[0:0]
Mar  7 18:35:25 samsung1 kdm[2575]: X server for display :0 terminated unexpectedly
Mar  7 18:35:25 samsung1 kdm[2575]: Unable to fire up local display :0; disabling.

This did not happen with the previous kernel kernel-2.6.23.15-137.fc8

Smolt profile is
http://www.smolts.org/show?UUID=pub_caca8f33-edb9-4398-95d6-5e6be67ebb46

The same problem occurs for the machine with hardware at:
http://www.smolts.org/client/show?uuid=pub_8cb4b211-d13c-441d-ab8a-5bd25f5c3401
Comment 1 Mike C 2008-03-07 13:51:13 EST
Created attachment 297236 [details]
Xorg.0.log immediately following the problem
Comment 2 Mike C 2008-03-07 13:54:28 EST
Created attachment 297238 [details]
Xorg.conf
Comment 3 Mike C 2008-03-07 14:09:58 EST
I have just a couple more tests and I am now unsure that this is a kernel issue.
I booted to the previous kernel 2.6.23.15-137.fc8 and logged in to kde. This was
fine. I logged out - and this was fine and then logged back in.

I then asked the machine to reboot from the logged in session and this was fine
BUT next I logged out of kde, and then from the kdm login screen selected to
restart the machine. The machine did not restart but instead went to one of the
alternative consoles - with a login prompt!  Ctrl-Alt F7 would no longer work,
and I presume that X had crashed... ssh into the machine was still possible. At
this point a reboot is necessary to get X to come alive again!

So is this an xorg problem rather than a kernel problem?
Comment 4 Mike C 2008-03-07 14:12:17 EST
Created attachment 297240 [details]
Xorg.0.log immediately following the problem described for the previous kernel
Comment 5 Mike C 2008-03-07 14:13:44 EST
This time there are no lines in /var/log/messages, the last few lines of which are:

Mar  7 19:03:03 samsung1 dhclient: bound to 10.0.0.61 -- renewal in 13725 seconds.
Mar  7 19:03:07 samsung1 acpid: client connected from 2595[0:0]
Mar  7 19:03:08 samsung1 kernel: [drm] Initialized drm 1.1.0 20060810
Mar  7 19:03:08 samsung1 kernel: [drm] Initialized i915 1.6.0 20060119 on minor 0
Comment 6 Dave Jones 2008-03-07 14:55:59 EST
my guess is this is something 3d related.  Perhaps Dave Airlie has some idea
what might have changed recently.  There have been a number of people reporting
problems with Intel 3d in various forms.
Comment 7 Mike C 2008-03-07 17:00:21 EST
I have tried kernel-2.6.24.3-22.fc8 and this behaves the same as 2.6.23.15-137.fc8
Comment 8 Mike C 2008-03-07 17:10:44 EST
Comment #17 from https://bugzilla.redhat.com/show_bug.cgi?id=433728 applies in
this case also.
Comment 9 Jon Stanley 2008-03-08 00:58:14 EST
Can you try the kernel from there?  It can be found at
http://koji.fedoraproject.org/koji/buildinfo?buildID=42024
Comment 10 Mike C 2008-03-08 08:04:59 EST
See comment #7 above - I tried that kernel and it doesn't fix this problem -
i.e. kernel-2.6.24.3-22.fc8
Comment 11 Oron Peled 2008-03-09 17:23:16 EDT
Created attachment 297380 [details]
Oops on KDE logout

1. Caused on logout from KDE.
2. Fully updated Fedora.
3. Changed my default boot to previous kernel -- 2.6.23.15-137.fc8
Comment 12 Oron Peled 2008-03-10 14:27:42 EDT
Probably a duplicate of 436723
Comment 13 Gianluca Varisco 2008-03-23 07:47:37 EDT
Hi Mike,

Do you still have the problem? Which kernel are you using right now? Do you
tried 2.6.24.3-50 available in f8-updates-testing?

# yum update --enablerepo=updates-testing kernel
Comment 14 Mike C 2008-03-23 14:47:27 EDT
The problem no longer occurs with 2.6.24.3-34.fc8
I will close this bug if that is OK?
Comment 15 Gianluca Varisco 2008-03-23 14:55:50 EDT
I'm closing it ;-)

Thanks for your prompt reply.

Note You need to log in before you can comment on or make changes to this bug.