Bug 436583 - network interface fails with 2.6.24.3-12.fc8
network interface fails with 2.6.24.3-12.fc8
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
8
i686 Linux
low Severity medium
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
: 437698 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-03-07 20:42 EST by mark ziemer
Modified: 2008-08-02 19:40 EDT (History)
4 users (show)

See Also:
Fixed In Version: 2.6.24.3-50.fc8
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-03-26 13:15:15 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
lspci and ifconfig of configuration under working kernel 2.6.23.15-137.fc8 (3.41 KB, text/plain)
2008-03-08 11:50 EST, Michael Wiktowy
no flags Details
dmesg of kernel 2.6.24.3-22.fc8 (25.37 KB, text/plain)
2008-03-08 12:17 EST, Michael Wiktowy
no flags Details
dmesg of working kernel 2.6.23.15-137.fc8 (24.49 KB, text/plain)
2008-03-08 12:22 EST, Michael Wiktowy
no flags Details
dmesg_mziemer-22 (23.82 KB, application/octet-stream)
2008-03-08 14:29 EST, mark ziemer
no flags Details
dmesg of kernel 2.6.24.3-22.fc8 after 2nd network card enable and cruft removal (26.05 KB, text/plain)
2008-03-12 09:47 EDT, Michael Wiktowy
no flags Details
Screenshot of network device cruft (75.62 KB, image/png)
2008-03-12 09:48 EDT, Michael Wiktowy
no flags Details
Screenshot of network hardware cruft (48.87 KB, image/png)
2008-03-12 09:49 EDT, Michael Wiktowy
no flags Details
dmesg output for failing kernel (24.88 KB, application/octet-stream)
2008-03-27 16:49 EDT, Jón Fairbairn
no flags Details
Network Config showing continually incrementing device name on unused card (78.46 KB, image/png)
2008-04-05 17:31 EDT, Michael Wiktowy
no flags Details
A screenshot of a strange duplicate NIC showing up in my hardware list (43.83 KB, image/png)
2008-04-05 17:33 EDT, Michael Wiktowy
no flags Details

  None (edit)
Description mark ziemer 2008-03-07 20:42:48 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.1.12) Gecko/20080208 Fedora/2.0.0.12-1.fc8 Firefox/2.0.0.12

Description of problem:
Motherboard has two network interfaces on board.  Both will NOT enable with this kernel.  Not able to manually turn on either.

Version-Release number of selected component (if applicable):
kernel 2.6.24.3-12.fc8

How reproducible:
Always


Steps to Reproduce:
1.boot to latest kernel
2.network interface cards are turned off
3.

Actual Results:
Not able to get to the internet or my own network.  Interface cards are disabled.
Not able to turn on via network setup.

Expected Results:
Should have been able to get to internet and internal network.

Additional info:
Error message - Network not accessible.
Hardware:
processor       : 0
vendor_id       : AuthenticAMD
cpu family      : 6
model           : 8
model name      : AMD Athlon(tm) XP 2600+
stepping        : 1
cpu MHz         : 2079.583
cache size      : 256 KB
fdiv_bug        : no
hlt_bug         : no
f00f_bug        : no
coma_bug        : no
fpu             : yes
fpu_exception   : yes
cpuid level     : 1
wp              : yes
flags           : fpu vme de pse tsc msr pae mce cx8 apic mtrr pge mca cmov pat pse36 mmx fxsr sse syscall mmxext 3dnowext 3dnow up ts
bogomips        : 4161.06
clflush size    : 32

class: NETWORK
bus: PCI
detached: 0
device: eth0
driver: 3c59x
desc: "3Com Corporation 3C920B-EMB Integrated Fast Ethernet Controller [Tornado]"
network.hwaddr: 00:26:54:0c:51:a1
vendorId: 10b7
deviceId: 9201
subVendorId: 1043
subDeviceId: 80ab
pciType: 1
pcidom:    0
pcibus:  2
pcidev:  1
pcifn:  0
-

class: NETWORK
bus: PCI
detached: 0
device: eth1
driver: forcedeth
desc: "nVidia Corporation nForce2 Ethernet Controller"
network.hwaddr: 00:0c:6e:32:68:4e
vendorId: 10de
deviceId: 0066
subVendorId: 1043
subDeviceId: 80a7
pciType: 1
pcidom:    0
pcibus:  0
pcidev:  4
pcifn:  0
-
Comment 1 Jon Stanley 2008-03-07 20:54:42 EST
There were a ton of network changes done in the build after yours.  Could you
try the kernel from http://koji.fedoraproject.org/koji/buildinfo?buildID=42024
and see how that goes?
Comment 2 Dave Jones 2008-03-07 20:56:16 EST
if it still fails, can you attach the dmesg from the failing kernel please.
Comment 3 Michael Wiktowy 2008-03-08 11:47:09 EST
Same problem here with same hardware by the looks of it. I will attach some
details and give referenced kernel a try.
Comment 4 Michael Wiktowy 2008-03-08 11:50:22 EST
Created attachment 297309 [details]
lspci and ifconfig of configuration under working kernel 2.6.23.15-137.fc8
Comment 5 Michael Wiktowy 2008-03-08 12:17:41 EST
Created attachment 297310 [details]
dmesg of kernel 2.6.24.3-22.fc8

Kernel 2.6.24.3-22.fc8.i686 from link in Comment #1 does not help. Attached is
dmesg output while booting that kernel.
Comment 6 Michael Wiktowy 2008-03-08 12:22:04 EST
Created attachment 297311 [details]
dmesg of working kernel 2.6.23.15-137.fc8

Attached is the dmesg of the working kernel 2.6.23.15-137.fc8 for reference.
Comment 7 mark ziemer 2008-03-08 14:29:35 EST
Created attachment 297318 [details]
dmesg_mziemer-22

From kernel 2.6.24-22.fc8.i686
Comment 8 Chuck Ebbert 2008-03-10 17:08:16 EDT
Do the addresses in the original /etc/sysconfig/network/devices/* match the ones
in /etc/udev/rules.d/70-persistent-net.rules?
Comment 9 Chuck Ebbert 2008-03-10 18:30:51 EDT
From the working kernel boot messages;

net eth1: device_rename: sysfs_create_symlink failed (-17)
udev: renamed network interface eth0 to eth1

It looks like the rename of the 3com 3c920 device wasn't working in 2.6.23 and
now it is.
Comment 10 Michael Wiktowy 2008-03-11 02:18:25 EDT
A few months ago the other network card on this board started forgetting int MAC
and that was causing the ethx device to just start incrementing on every reboot
so I caught it at eth50-ish and disabled it and used the one that appeared to be
working. I thought (with some queries to the mailing list) that it was a
hardware failure at the time. I will re-enable it and go back and try to start
from square one with my network set up to see if everything is back to normal as
this might be related. I'll let you know what progress I have.
Comment 11 Michael Wiktowy 2008-03-12 09:43:33 EDT
Cleared out the ethx.bak cruft in system-config-network and I reenabled the
other ethernet card in my bios so that it shows up. Now things seem to be
working fine. There still appears to be some persistent cruft showing up in
system-config-network eventhough I delete it and save after. I will have to go
into the /etc/ directory with a weed-wacker. See attached dmesg and screenshots
of s-c-n.
Comment 12 Michael Wiktowy 2008-03-12 09:47:20 EDT
Created attachment 297760 [details]
dmesg of kernel 2.6.24.3-22.fc8 after 2nd network card enable and cruft removal
Comment 13 Michael Wiktowy 2008-03-12 09:48:21 EDT
Created attachment 297761 [details]
Screenshot of network device cruft
Comment 14 Michael Wiktowy 2008-03-12 09:49:02 EDT
Created attachment 297763 [details]
Screenshot of network hardware cruft
Comment 15 Chuck Ebbert 2008-03-18 14:59:08 EDT
*** Bug 437698 has been marked as a duplicate of this bug. ***
Comment 16 Fedora Update System 2008-03-20 23:15:19 EDT
kernel-2.6.24.3-50.fc8 has been submitted as an update for Fedora 8
Comment 17 Fedora Update System 2008-03-21 18:16:37 EDT
kernel-2.6.24.3-50.fc8 has been pushed to the Fedora 8 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update kernel'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F8/FEDORA-2008-2630
Comment 18 mark ziemer 2008-03-21 23:11:07 EDT
The new kernel -50 did not fix the problem.
Comment 19 Fedora Update System 2008-03-26 13:14:48 EDT
kernel-2.6.24.3-50.fc8 has been pushed to the Fedora 8 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 20 Jón Fairbairn 2008-03-27 16:46:57 EDT
With an IBM thinkpad X30 (which works with kernel 2.6.23.15-137.fc8 but no
2.6.24 version yet) kernel 2.6.24.3-50.fc8 still prevents the e100 ethernet card
(and the soundcard) from working.  I'll attach a dmesg output with debug on the
command line
Comment 21 Jón Fairbairn 2008-03-27 16:49:44 EDT
Created attachment 299389 [details]
dmesg output for failing kernel

I don't think the IRQ 5 traceback in this dmesg is relevant -- I sometimes get
the "nobody cared" message for IRQ 5 even with 2.6.23.15-137.fc8
Comment 22 Michael Wiktowy 2008-04-05 17:31:20 EDT
Created attachment 301393 [details]
Network Config showing continually incrementing device name on unused card

While networking is working for me now after manually clearing all my old
network devices out and letting Fedora reestablish them, clearly there is
something still going on. I believe that this latest fix may correct one bug
but there are more issues with this network driver on this mobo. The problems
for me started about a week or two before 2007-11-19 so I turned one NIC off in
the BIOS and ignored the issue. I reenabled it recently to see if things were
better. They are not as seen by the continual marching up of the device name
every reboot.
Comment 23 Michael Wiktowy 2008-04-05 17:33:46 EDT
Created attachment 301394 [details]
A screenshot of a strange duplicate NIC showing up in my hardware list

Note You need to log in before you can comment on or make changes to this bug.