This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 436603 - Wireless pcmcia card Asus WL-107g (rt2500) doesn't work at all
Wireless pcmcia card Asus WL-107g (rt2500) doesn't work at all
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
8
i686 Linux
low Severity medium
: ---
: ---
Assigned To: John W. Linville
Fedora Extras Quality Assurance
:
: 437392 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-03-08 03:30 EST by Bostjan
Modified: 2008-03-14 15:56 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-03-13 14:48:43 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Bostjan 2008-03-08 03:30:23 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9b5pre) Gecko/2008030513 Remi/3.0b5pre-0.beta4.20080305.fc8.remi Minefield/3.0b5pre

Description of problem:
I get the following when I insert the card:
pccard: CardBus cardpccard: CardBus card inserted into slot 1
ACPI: PCI Interrupt 0000:07:00.0[A] -> Link [LNKD] -> GSI 11 (level, low) -> IRQ 11
PCI: Setting latency timer of device 0000:07:00.0 to 64
rt2x00pci -> rt2x00pci_alloc_reg: Error - Failed to allocate registers.
ACPI: PCI interrupt for device 0000:07:00.0 disabled
rt2500pci: probe of 0000:07:00.0 failed with error -12
 inserted into slot 1
ACPI: PCI Interrupt 0000:07:00.0[A] -> Link [LNKD] -> GSI 11 (level, low) -> IRQ 11

This is from lspci -vvv:
07:00.0 Ethernet controller: RaLink RT2500 802.11g Cardbus/mini-PCI (rev 01)
        Subsystem: ASUSTeK Computer Inc. Unknown device 107f
        Control: I/O- Mem- BusMaster- SpecCycle- MemWINV+ VGASnoop- ParErr- Stepping- SERR- FastB2B- DisINTx-
        Status: Cap+ 66MHz- UDF- FastB2B- ParErr- DEVSEL=slow >TAbort- <TAbort- <MAbort- >SERR- <PERR+ INTx-
        Interrupt: pin A routed to IRQ 11
        Region 0: Memory at <ignored> (32-bit, non-prefetchable) [disabled]
        Capabilities: [40] Power Management version 2
                Flags: PMEClk- DSI- D1- D2- AuxCurrent=0mA PME(D0-,D1-,D2-,D3hot-,D3cold-)
                Status: D0 PME-Enable- DSel=0 DScale=0 PME-
        Kernel modules: rt2500pci

PCI: Setting latency timer of device 0000:07:00.0 to 64
rt2x00pci -> rt2x00pci_alloc_reg: Error - Failed to allocate registers.
ACPI: PCI interrupt for device 0000:07:00.0 disabled
rt2500pci: probe of 0000:07:00.0 failed with error -12


Version-Release number of selected component (if applicable):
kernel-2.6.24.3-22.fc8

How reproducible:
Always


Steps to Reproduce:
1. Boot up the laptop
2. Insert the card
3.

Actual Results:
Card does not work

Expected Results:
Working wireless networking

Additional info:
This happens also happens on released kernel-2.6.24.3-12.fc8
Comment 1 John W. Linville 2008-03-10 10:55:37 EDT
There are some recently posted patches which I think may help here.  I'll let 
you know when I get them into a Fedora kernel build.
Comment 2 John W. Linville 2008-03-13 11:11:04 EDT
The kernels here contain an update to rt2x00 version 2.1.4:

   http://koji.fedoraproject.org/koji/buildinfo?buildID=42735

Could you give those kernels a try to see if they resolve this issue for you?
Comment 3 Bostjan 2008-03-13 12:09:46 EDT
No luck, I'm afraid. I get a very similar message with the new kernel
(2.6.24.3-34) as well:
pccard: CardBus card inserted into slot 1
ACPI: PCI Interrupt 0000:07:00.0[A] -> Link [LNKD] -> GSI 11 (level, low) -> IRQ 11
PCI: Setting latency timer of device 0000:07:00.0 to 64
rt2x00pci -> rt2x00pci_alloc_reg: Error - Failed to allocate registers.
ACPI: PCI interrupt for device 0000:07:00.0 disabled
rt2500pci: probe of 0000:07:00.0 failed with error -12
Comment 4 John W. Linville 2008-03-13 12:58:19 EDT
Hmmm...looking at where the message originates, it would seem to indicate a 
fundamental problem.

I think this problem is indicated by this line in the lspci output above:

        Region 0: Memory at <ignored> (32-bit, non-prefetchable) [disabled]

It looks as if you have this device disabled in your BIOS settings.  Please 
reboot and go into your BIOS setup routines and enable the wireless device.  
Afterwards, can you replicate this issue?
Comment 5 Bostjan 2008-03-13 13:19:25 EDT
This is actually a pcmcia card, I could find no settings for it in the BIOS. I
should also mention I have tried it with two different laptops (an old Dell
Inspiron 8200 and an HP 8510w) - both give the same error.

 
Comment 6 John W. Linville 2008-03-13 13:28:26 EDT
Cardbus perhaps, but not pcmcia -- if it were pcmcia then it wouldn't show-up 
in lspci.  (This is perhaps a technicality.)

Anyway, the point remains that the device is disabled.  I suspect that this 
either still originates with a BIOS setting or the card itself is broken.  It 
might be worthwhile for you to post the entire 'dmesg' output or contents 
of /var/log/messages in case there are messages from the PCI subsystem that 
shed some light on the situation.
Comment 7 Bostjan 2008-03-13 14:04:11 EDT
You're right of course (meant to say Cardbus).
I have gotten a hold of a win laptop now and this card actually seems to be
broken - there it causes a blue screen with NMI: parity check/memory parity error.
I'll take it back and get a replacement, sorry to have wasted your time...
Comment 8 John W. Linville 2008-03-13 14:53:29 EDT
No need to apologize!  Let me know if you have problems once you get good 
hardware! :-)
Comment 9 John W. Linville 2008-03-14 15:56:12 EDT
*** Bug 437392 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.