Bug 437392 - RT2500 from kernel-2.6.23.15-137.fc8 - error loading card
RT2500 from kernel-2.6.23.15-137.fc8 - error loading card
Status: CLOSED DUPLICATE of bug 436603
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
8
i386 Linux
low Severity low
: ---
: ---
Assigned To: John W. Linville
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-03-13 16:08 EDT by Ivan Virgili
Modified: 2008-03-14 15:56 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-03-14 15:56:11 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ivan Virgili 2008-03-13 16:08:54 EDT
When starting my computer or when inserting the card I get the following errors:

Mar 13 19:47:02 localhost kernel: ACPI: PCI Interrupt 0000:02:00.0[A] -> Link
[LNK5] -> GSI 11 (level, low) -> IRQ 11
Mar 13 19:47:02 localhost kernel: rt2x00pci -> rt2x00pci_alloc_reg: Error -
Failed to allocate registers.
Mar 13 19:47:02 localhost kernel: ACPI: PCI interrupt for device 0000:02:00.0
disabled
Mar 13 19:47:02 localhost kernel: rt2500pci: probe of 0000:02:00.0 failed with
error -12
Mar 13 19:47:10 localhost kernel: pccard: card ejected from slot 0
Mar 13 19:47:14 localhost kernel: pccard: CardBus card inserted into slot 0
Mar 13 19:47:14 localhost kernel: ACPI: PCI Interrupt 0000:02:00.0[A] -> Link
[LNK5] -> GSI 11 (level, low) -> IRQ 11
Mar 13 19:47:14 localhost kernel: rt2x00pci -> rt2x00pci_alloc_reg: Error -
Failed to allocate registers.
Mar 13 19:47:14 localhost kernel: ACPI: PCI interrupt for device 0000:02:00.0
disabled
Mar 13 19:47:14 localhost kernel: rt2500pci: probe of 0000:02:00.0 failed with
error -12
Mar 13 19:47:17 localhost kernel: pccard: card ejected from slot 0

After trying a few times, the card gets finally loaded
Comment 1 John W. Linville 2008-03-14 09:27:05 EDT
Please attach the output of 'lspci -v' after getting the errors above.  FWIW, 
I just saw an issue like this yesterday which turned-out to be a bad card.
Comment 2 John W. Linville 2008-03-14 09:33:51 EDT
Bug 436603
Comment 3 Ivan Virgili 2008-03-14 14:38:39 EDT
This is what lspci -v shows when the card DOES load fine.

02:00.0 Network controller: RaLink RT2500 802.11g Cardbus/mini-PCI (rev 01)
        Subsystem: Giga-byte Technology Unknown device e831
        Flags: bus master, slow devsel, latency 64, IRQ 11
        Memory at 54000000 (32-bit, non-prefetchable) [size=8K]
        Capabilities: [40] Power Management version 2
        Kernel driver in use: rt2500pci
        Kernel modules: rt2500pci

This is what lspci -v shows when the card DOES NOT loads fine.

02:00.0 Network controller: RaLink RT2500 802.11g Cardbus/mini-PCI (rev 01)
        Subsystem: Giga-byte Technology Unknown device 6831
        Flags: slow devsel, IRQ 11
        Memory at <ignored> (32-bit, non-prefetchable) [disabled]
        Capabilities: [40] Power Management version 2
        Kernel modules: rt2500pci

Let me know if you need more info.
Comment 4 Ivan Virgili 2008-03-14 14:48:14 EDT
Sometimes I get the error message with kernel 2.6.23.14-115.fc8, but if the card
loads fine, then it works fine as well (it does not stop working after a minute
or so). I am using it right now. Unfortunately I do not have another card with
that chipset to do other tests.
Comment 5 John W. Linville 2008-03-14 15:56:11 EDT
I have to say, that is exactly the same issue as bug 436603.  I think your 
card is dying -- I'm sorry!

*** This bug has been marked as a duplicate of 436603 ***

Note You need to log in before you can comment on or make changes to this bug.