Bug 436636 - killing/switching the intel X server blacks out LCD
killing/switching the intel X server blacks out LCD
Status: CLOSED DUPLICATE of bug 436556
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-i810 (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Adam Jackson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-03-08 13:51 EST by Axel Thimm
Modified: 2008-03-20 14:50 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-03-20 14:50:07 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
xorg.conf for which the backlight stays dark in virtual consoles (1.05 KB, text/plain)
2008-03-10 17:50 EDT, Axel Thimm
no flags Details
Xorg.0.log for the black virtual consoles (23.15 KB, text/plain)
2008-03-10 17:53 EDT, Axel Thimm
no flags Details
"# XXX rebase me plz" (746 bytes, patch)
2008-03-20 14:33 EDT, Axel Thimm
no flags Details | Diff
Patch tp specfile to apply the rebased patch (1.13 KB, text/x-patch)
2008-03-20 14:34 EDT, Axel Thimm
no flags Details

  None (edit)
Description Axel Thimm 2008-03-08 13:51:17 EST
Description of problem:
When the X server starts switching back to the virtual consoles does not work -
one gets a view of the virtual console for a split second and then a blank
screen. Switching back to X works.

Also killing the server with init 3 doesn't restore the consoles either.

Version-Release number of selected component (if applicable):
xorg-x11-server-Xorg-1.4.99.900-0.28.20080304.fc9.x86_64
xorg-x11-drv-i810-2.2.1-4.fc9.x86_64

How reproducible:
always

Steps to Reproduce:
1.simply boot into X
2.try to switch to a virtual console or init 3
3.
  
Actual results:
see above

Expected results:
access to visible virtual consoles

Additional info:
00:02.0 VGA compatible controller: Intel Corporation Mobile GM965/GL960
Integrated Graphics Controller (rev 03)
00:02.1 Display controller: Intel Corporation Mobile GM965/GL960 Integrated
Graphics Controller (rev 03)
Comment 1 Axel Thimm 2008-03-08 13:53:46 EST
Forgot to add that this is a recent regression, it worked until a couple of days
ago.
Comment 2 Matěj Cepl 2008-03-10 14:23:50 EDT
Thanks for the bug report.  We have reviewed the information you have provided
above, and there is some additional information we require that will be helpful
in our diagnosis of this issue.

Please attach your X server config file (/etc/X11/xorg.conf) and X server log
file (/var/log/Xorg.*.log) to the bug report as individual uncompressed file
attachments using the bugzilla file attachment link below.

We will review this issue again once you've had a chance to attach this information.

Thanks in advance.
Comment 3 Axel Thimm 2008-03-10 17:50:40 EDT
Created attachment 297521 [details]
xorg.conf for which the backlight stays dark in virtual consoles

It also happens w/o any xorg.conf, e.g. letting the X server using the built in
config.
Comment 4 Axel Thimm 2008-03-10 17:53:59 EDT
Created attachment 297524 [details]
Xorg.0.log for the black virtual consoles

starting gdm (through init 5) and then Ctrl-Alt-F1. The latter switch causes
the following output in the log:

--- before-switching/Xorg.0.log 2008-03-10 23:46:23.000000000 +0200
+++ after-switching/Xorg.0.log	      2008-03-10 23:49:48.000000000 +0200
@@ -492,3 +492,6 @@
 (**) AT Translated Set 2 keyboard: XkbModel: "evdev"
 (**) Option "XkbLayout" "us"
 (**) AT Translated Set 2 keyboard: XkbLayout: "us"
+(II) AIGLX: Suspending AIGLX clients for VT switch
+(II) intel(0): xf86UnbindGARTMemory: unbind key 0
+(II) intel(0): xf86UnbindGARTMemory: unbind key 1
Comment 5 Axel Thimm 2008-03-16 06:05:28 EDT
Unfortunately the latest updates have made things worse. Now if the backlight is
turned off (killing/switching of the X server, be it by logging out, init 3,
swicthing to virtual consoles etc.) it never turns on again, not even when
restarting X or trying to switch back to the X console.

When rebooting via kexec the backlight is turned on *after* the kernel is booted.

Is there a way to manually turn the backlight back on?
Comment 6 Axel Thimm 2008-03-20 14:33:38 EDT
Created attachment 298726 [details]
"# XXX rebase me plz"
Comment 7 Axel Thimm 2008-03-20 14:34:06 EDT
Created attachment 298727 [details]
Patch tp specfile to apply the rebased patch
Comment 8 Axel Thimm 2008-03-20 14:40:28 EDT
While poking around to find a fix I read in the specfile about the
intel-2.1.1-fix-vt-switch.patch that needed a rebase to current sources. Hoping
that this would fix my issue I did the rebase (hopefully correct), but it didn't
solve the issues I described.

Anyway it may be of use so I added them to this report.

Furthermore it looks like this bug may be related to the bug on
http://bugs.freedesktop.org/show_bug.cgi?id=13743

There the issues are with X starting into a blank screen, while I only see it
after X is switched to vts or trying to switch back to X/restart X.

Also I verified that at least when the screen *appears* blank in X or vts in
reality it is just the backlight that is turned off (one can see the consoles or
the gdm login screen with a flashlight).
Comment 9 Axel Thimm 2008-03-20 14:50:07 EDT
OK, I found bug #436556 and tested the workaround with modprobing video and this
saved my day. Closing as duplicate, although you may want to take a look at the
rebased patch in the attachments.

*** This bug has been marked as a duplicate of 436556 ***

Note You need to log in before you can comment on or make changes to this bug.