This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 436556 - i810 driver darkened as of version 2.2.1
i810 driver darkened as of version 2.2.1
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-i810 (Show other bugs)
rawhide
All Linux
medium Severity high
: ---
: ---
Assigned To: Dave Airlie
Fedora Extras Quality Assurance
http://bugs.freedesktop.org/show_bug....
:
: 436636 437518 437600 439063 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-03-07 16:38 EST by Linus Walleij
Modified: 2008-03-26 23:40 EDT (History)
7 users (show)

See Also:
Fixed In Version: xorg-x11-drv-i810-2.2.1-15.fc9
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-03-26 10:10:06 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
xorg.conf (807 bytes, text/plain)
2008-03-09 13:52 EDT, Charles R. Anderson
no flags Details
Xorg.0.log (23.14 KB, text/plain)
2008-03-09 13:53 EDT, Charles R. Anderson
no flags Details
Xorg.0.log without config file (6.40 KB, application/x-gzip)
2008-03-11 08:53 EDT, Linus Walleij
no flags Details

  None (edit)
Description Linus Walleij 2008-03-07 16:38:53 EST
Description of problem:
Since version 2.2.1-1 the i810 drives constantly gives me a blacked out screen,
with no or very very little backlight. It still works though, I can reboot if I
can find the cursor in the blackness (GDM greeter is barely visible) or switch
to a console and type in the blind. I tried later versions of 2.2.1-X all have
the same problem.

Version-Release number of selected component (if applicable):
2.2.1-X

How reproducible:
Always.

Steps to Reproduce:
1. Boot.
  
Actual results:
GDM is very dark, no backlight. Driver unusable.

Expected results:
Backlight.

Additional info:
Switching back to 2.2.0-4 works flawlessly. Anything backlight-related or DDC
thing got messed up in 2.2.1? Perhaps I need to take this upstream :-/

This is a HP Compaq nc2400

lspci gives
00:02.0 VGA compatible controller: Intel Corporation Mobile 945GM/GMS,
943/940GML Express Integrated Graphics Controller (rev 03)
00:02.1 Display controller: Intel Corporation Mobile 945GM/GMS, 943/940GML
Express Integrated Graphics Controller (rev 03)

Some lspci -n -v figures:
00:02.0 8086:27a2 (rev 03)
   Subsystem: 103c:30a1
00:02.1 8086:27a2 (rev 03)
   Subsystem: 103c:30a1
Comment 1 Matěj Cepl 2008-03-08 04:04:18 EST
Thanks for the bug report.  We have reviewed the information you have provided
above, and there is some additional information we require that will be helpful
in our diagnosis of this issue.

Please attach your X server config file (/etc/X11/xorg.conf) and X server log
file (/var/log/Xorg.*.log) to the bug report as individual uncompressed file
attachments using the bugzilla file attachment link below.

Could you please also try to run without any /etc/X11/xorg.conf whatsoever and
let X11 autodetect your display and video card? Attach to this bug
/var/log/Xorg.0.log from this attempt as well, please.

We will review this issue again once you've had a chance to attach this information.

Thanks in advance.
Comment 2 Jeremy Katz 2008-03-08 10:01:12 EST
If you can manage to log in, can you try to do a `xrandr -o inverted ; xrandr -o
normal` and see if it helps?  If so, you're probably hitting
http://bugs.freedesktop.org/show_bug.cgi?id=14721
Comment 3 Charles R. Anderson 2008-03-09 13:52:21 EDT
Created attachment 297369 [details]
xorg.conf

Same problem here with a Thinkpad T61.	Backlight stays off after gdm loads. 
Typing "xbacklight -set 100" blind into a gnome-terminal after logging in works
around it.
Comment 4 Charles R. Anderson 2008-03-09 13:53:48 EDT
Created attachment 297370 [details]
Xorg.0.log

Here is the Xorg.0.log when using the standard kernel (i.e. not the new
i915.modeset=1 stuff).	Interestingly, this problem doesn't happen with
i915.modeset=1 turned on.
Comment 5 Linus Walleij 2008-03-11 08:53:27 EDT
Created attachment 297604 [details]
Xorg.0.log without config file

This is a log taken without any xorg.conf file
(as can be verified by the (EE) message).

The bahaviour changed now!

Now the screen come on but whenever you 
press Ctrl+Alt+F1 to switch to a console, the 
screen backlight dies in the same manner that it
died spontaneously before.
Comment 6 Linus Walleij 2008-03-11 09:02:29 EDT
No, wait the behaviour does not change. I should be VERY
clear of how the problem manifests:

The FIRST TIME an X server starts up, backlight is on. If
you stop the X server and then starts another one, it goes
off. If you start an X server and tries to switch to a 
console, it goes off.

The reason I thought the behaviour changed was that I booted
the kernel into single-user mode and then started X with
"init 5". This way the initial RHGB X server is never run
(this normally works) so the first X server session started
is the one running GDM and the first login screen.

Fast-user-switch (which opens a secondary X server) also
kills the backlight.
Comment 7 Brad Walker 2008-03-14 16:42:09 EDT
Workaround (tested successfully on thinkpad x61s):

Boot into init 3 by appending '3' to the kernel grub line. Then login as root,
'modprobe video' and 'init 5' and the backlight should work as normal. For some
reason the 2.6.25 rawhide kernels don't autoload the 'video' kernel module like
the fc8 kernels.
Comment 8 Bill Nottingham 2008-03-17 11:33:56 EDT
*** Bug 437600 has been marked as a duplicate of this bug. ***
Comment 9 Matěj Cepl 2008-03-17 13:37:45 EDT
*** Bug 437518 has been marked as a duplicate of this bug. ***
Comment 10 jmccann 2008-03-18 13:37:04 EDT
I can confirm that the workaround in comment #7 works for me on a T61.
Comment 11 Axel Thimm 2008-03-20 14:50:07 EDT
*** Bug 436636 has been marked as a duplicate of this bug. ***
Comment 12 Axel Thimm 2008-03-20 14:51:26 EDT
This is probably related to the upstream bug

http://bugs.freedesktop.org/show_bug.cgi?id=13743

Comment 13 Matěj Cepl 2008-03-20 16:52:39 EDT
There are some patches attached to bug 436636
Comment 14 Brad Walker 2008-03-25 13:00:37 EDT
xorg-x11-drv-i810-2.2.1-15.fc9 fixed this on my machine.
Comment 15 Linus Walleij 2008-03-26 04:40:58 EDT
xorg-x11-drv-i810-2.2.1-15.fc9 works for me too.

GOOD WORK!
Comment 16 jmccann 2008-03-26 23:40:43 EDT
*** Bug 439063 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.