Bug 436702 - gnome-settings-daemon crash with i915.modeset=1
gnome-settings-daemon crash with i915.modeset=1
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: gnome-desktop (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Søren Sandmann Pedersen
Fedora Extras Quality Assurance
:
: 437185 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-03-09 13:46 EDT by Charles R. Anderson
Modified: 2014-06-18 05:10 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-03-20 10:48:17 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
run through strace and gdb with backtrace (165.06 KB, text/plain)
2008-03-09 13:46 EDT, Charles R. Anderson
no flags Details

  None (edit)
Description Charles R. Anderson 2008-03-09 13:46:17 EDT
Description of problem:

Booting the new kernel with "i915.modeset=1" causes gnome-settings-daemon to
crash after logging in.

From kernel changelog:

* Thu Mar 06 2008 Dave Airlie <airlied@redhat.com>
- Add initial i915 drm modesetting tree - needs i915.modeset=1 on command
  line + new libdrm + new intel driver to actually be useful

Version-Release number of selected component (if applicable):

gnome-settings-daemon-2.21.92-2.fc9.x86_64
kernel-2.6.25-0.101.rc4.git3.fc9.x86_64
libdrm-2.4.0-0.9.fc9.i386
libdrm-2.4.0-0.9.fc9.x86_64
xorg-x11-drv-evdev-1.99.1-0.1.fc9.x86_64
xorg-x11-drv-i810-2.2.1-9.fc9.x86_64
xorg-x11-server-Xorg-1.4.99.901-1.20080307.fc9.x86_64

How reproducible:

always

Steps to Reproduce:
1. boot above kernel version with i915.modeset=1 command line
2. log into GNOME, note dialog about gnome-settings-daemon failing to start
3. try running "/usr/libexec/gnome-settings-daemon" manually
  
Actual results:

> /usr/libexec/gnome-settings-daemon 
** (gnome-settings-daemon:3497): DEBUG: Successfully connected to D-Bus
** (gnome-settings-daemon:3497): DEBUG: Starting settings manager
** (gnome-settings-daemon:3497): DEBUG: Loading settings plugins from dir:
/usr/lib64/gnome-settings-daemon-2.0/
** (gnome-settings-daemon:3497): DEBUG: Loading plugin:
/usr/lib64/gnome-settings-daemon-2.0/sound.gnome-settings-plugin
** (gnome-settings-daemon:3497): DEBUG: Monitoring dir
/apps/gnome_settings_daemon/plugins/sound for changes
** (gnome-settings-daemon:3497): DEBUG: Loading plugin:
/usr/lib64/gnome-settings-daemon-2.0/clipboard.gnome-settings-plugin
** (gnome-settings-daemon:3497): DEBUG: Monitoring dir
/apps/gnome_settings_daemon/plugins/clipboard for changes
** (gnome-settings-daemon:3497): DEBUG: Loading plugin:
/usr/lib64/gnome-settings-daemon-2.0/media-keys.gnome-settings-plugin
** (gnome-settings-daemon:3497): DEBUG: Monitoring dir
/apps/gnome_settings_daemon/plugins/media-keys for changes
** (gnome-settings-daemon:3497): DEBUG: Loading plugin:
/usr/lib64/gnome-settings-daemon-2.0/xrandr.gnome-settings-plugin
** (gnome-settings-daemon:3497): DEBUG: Monitoring dir
/apps/gnome_settings_daemon/plugins/xrandr for changes
** (gnome-settings-daemon:3497): DEBUG: Loading plugin:
/usr/lib64/gnome-settings-daemon-2.0/xrdb.gnome-settings-plugin
** (gnome-settings-daemon:3497): DEBUG: Monitoring dir
/apps/gnome_settings_daemon/plugins/xrdb for changes
** (gnome-settings-daemon:3497): DEBUG: Loading plugin:
/usr/lib64/gnome-settings-daemon-2.0/font.gnome-settings-plugin
** (gnome-settings-daemon:3497): DEBUG: Monitoring dir
/apps/gnome_settings_daemon/plugins/font for changes
** (gnome-settings-daemon:3497): DEBUG: Loading plugin:
/usr/lib64/gnome-settings-daemon-2.0/typing-break.gnome-settings-plugin
** (gnome-settings-daemon:3497): DEBUG: Monitoring dir
/apps/gnome_settings_daemon/plugins/typing-break for changes
** (gnome-settings-daemon:3497): DEBUG: Loading plugin:
/usr/lib64/gnome-settings-daemon-2.0/xsettings.gnome-settings-plugin
** (gnome-settings-daemon:3497): DEBUG: Monitoring dir
/apps/gnome_settings_daemon/plugins/xsettings for changes
** (gnome-settings-daemon:3497): DEBUG: Loading plugin:
/usr/lib64/gnome-settings-daemon-2.0/keybindings.gnome-settings-plugin
** (gnome-settings-daemon:3497): DEBUG: Monitoring dir
/apps/gnome_settings_daemon/plugins/keybindings for changes
** (gnome-settings-daemon:3497): DEBUG: Loading plugin:
/usr/lib64/gnome-settings-daemon-2.0/dummy.gnome-settings-plugin
** (gnome-settings-daemon:3497): DEBUG: Monitoring dir
/apps/gnome_settings_daemon/plugins/dummy for changes
** (gnome-settings-daemon:3497): DEBUG: Loading plugin:
/usr/lib64/gnome-settings-daemon-2.0/mouse.gnome-settings-plugin
** (gnome-settings-daemon:3497): DEBUG: Monitoring dir
/apps/gnome_settings_daemon/plugins/mouse for changes
** (gnome-settings-daemon:3497): DEBUG: Loading plugin:
/usr/lib64/gnome-settings-daemon-2.0/keyboard.gnome-settings-plugin
** (gnome-settings-daemon:3497): DEBUG: Monitoring dir
/apps/gnome_settings_daemon/plugins/keyboard for changes
** (gnome-settings-daemon:3497): DEBUG: Loading plugin:
/usr/lib64/gnome-settings-daemon-2.0/screensaver.gnome-settings-plugin
** (gnome-settings-daemon:3497): DEBUG: Monitoring dir
/apps/gnome_settings_daemon/plugins/screensaver for changes
** (gnome-settings-daemon:3497): DEBUG: Loading plugin:
/usr/lib64/gnome-settings-daemon-2.0/background.gnome-settings-plugin
** (gnome-settings-daemon:3497): DEBUG: Monitoring dir
/apps/gnome_settings_daemon/plugins/background for changes
** (gnome-settings-daemon:3497): DEBUG: Loading plugin:
/usr/lib64/gnome-settings-daemon-2.0/a11y-keyboard.gnome-settings-plugin
** (gnome-settings-daemon:3497): DEBUG: Monitoring dir
/apps/gnome_settings_daemon/plugins/a11y-keyboard for changes
** (gnome-settings-daemon:3497): DEBUG: GnomeSettingsModule 0x122e8f0 initialising
** (gnome-settings-daemon:3497): DEBUG: Loading
/usr/lib64/gnome-settings-daemon-2.0/libxrandr.so
** (gnome-settings-daemon:3497): DEBUG: Registering GsdXrandrPlugin
** (gnome-settings-daemon:3497): DEBUG: Creating object of type GsdXrandrPlugin
** (gnome-settings-daemon:3497): DEBUG: GsdXrandrPlugin initializing
Resource Timestamp: 63841
Resource Configuration Timestamp: 63841
CRTC 39 Timestamp: 63841
CRTC 3a Timestamp: 63841
Output 3b Timestamp: 63841

> ps auxw | grep gnome-settings-daemon

(nothing returned)

Expected results:

gnome-settings-daemon shouldn't crash

Additional info:

See attached run through strace and gdb.
Comment 1 Charles R. Anderson 2008-03-09 13:46:17 EDT
Created attachment 297368 [details]
run through strace and gdb with backtrace
Comment 2 Bastien Nocera 2008-03-12 16:52:56 EDT
*** Bug 437185 has been marked as a duplicate of this bug. ***
Comment 3 Charles R. Anderson 2008-03-13 18:07:46 EDT
Still happens on these versions:

gnome-settings-daemon-2.22.0-1.fc9.x86_64
kernel-2.6.25-0.113.rc5.git2.fc9.x86_64
libdrm-2.4.0-0.9.fc9.i386
libdrm-2.4.0-0.9.fc9.x86_64
xorg-x11-drv-evdev-1.99.1-0.4.fc9.x86_64
xorg-x11-drv-i810-2.2.1-10.fc9.x86_64
xorg-x11-server-Xorg-1.4.99.901-5.20080310.fc9.x86_64
Comment 4 Tore H. Larsen 2008-03-13 19:42:15 EDT
Is it related to .gnome2/monitors.xml ?  What does such a file look like?

open("/home/torel/.gnome2/monitors.xml", O_RDONLY) = -1 ENOENT (No such file or 
directory)
fstat(1, {st_mode=S_IFCHR|0620, st_rdev=makedev(136, 0), ...}) = 0
mmap(NULL, 4096, PROT_READ|PROT_WRITE, MAP_PRIVATE|MAP_ANONYMOUS, -1, 0) = 
0x7f2247615000
write(1, "parse error\n", 12parse error
)           = 12

Comment 5 Tore H. Larsen 2008-03-13 19:48:28 EDT
Btw, I have FX 570M gfx and using nv driver. Trying to compile latest nvidia 
driver, but there are some changes to kernel. So I think this is more general 
that i915. Maybe Xinerama related? It do not crash if I turn of xinerama.
Comment 6 Jeff Schroeder 2008-03-19 09:19:54 EDT
Ubuntu has a similar bug with a patch that fixes it.

Maybe it would be worth looking into:
https://bugs.launchpad.net/ubuntu/+source/gnome-desktop/+bug/198951/comments/44
Comment 7 Dominik Sandjaja 2008-03-19 22:37:45 EDT
I just applied the patch mentioned in #6 and recompiled gnome-desktop, not it
WFM. No idea how to make patches, this is my first miserable try ...

(/home/ds)$ diff -n rpmbuild/SOURCES/add-randr-12.patch
rpmbuild/SOURCES/add-randr-12.patch.new
--- rpmbuild/SOURCES/add-randr-12.patch	2008-03-02 22:18:50.000000000 +0000
+++ rpmbuild/SOURCES/add-randr-12.patch.new	2008-03-20 02:23:33.000000000 +0000
@@ -2535,10 +2535,10 @@
 +    a = g_ptr_array_new ();
 +    for (i = 0; i < info->nclone; ++i)
 +    {
-+	RWOutput *output = rw_output_by_id (output->info, info->clones[i]);
++	RWOutput *rwoutput = rw_output_by_id (output->info, info->clones[i]);
 +	
-+	if (output)
-+	    g_ptr_array_add (a, output);
++	if (rwoutput)
++	    g_ptr_array_add (a, rwoutput);
 +    }
 +    g_ptr_array_add (a, NULL);
 +    output->clones = (RWOutput **)g_ptr_array_free (a, FALSE);
Comment 8 Søren Sandmann Pedersen 2008-03-20 10:48:17 EDT
I hope this is fixed in gnome-desktop 2.22.0-2 which should appear in rawhide
soon. Feel free to reopen if it isn't.

Note You need to log in before you can comment on or make changes to this bug.