Bug 437185 - gnome-display-properties crashes
gnome-display-properties crashes
Status: CLOSED DUPLICATE of bug 436702
Product: Fedora
Classification: Fedora
Component: control-center (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Control Center Maintainer
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-03-12 15:19 EDT by Bill Nottingham
Modified: 2014-03-16 23:12 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-03-12 16:52:54 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bill Nottingham 2008-03-12 15:19:31 EDT
Description of problem:

Resource Timestamp: 409552
Resource Configuration Timestamp: 409552
CRTC 39 Timestamp: 409552
CRTC 3a Timestamp: 409552
Output 3b Timestamp: 409552

Program received signal SIGSEGV, Segmentation fault.
[Switching to Thread 0x7f6e9071f7b0 (LWP 3600)]
screen_info_new (screen=<value optimized out>) at randrwrap.c:122
122	    for (output = info->outputs; *output; ++output)
(gdb) bt
#0  screen_info_new (screen=<value optimized out>) at randrwrap.c:122
#1  0x00000034fee1a522 in rw_screen_new (gdk_screen=<value optimized out>, 
    callback=<value optimized out>, data=<value optimized out>) at randrwrap.c:391
#2  0x00000000004058b1 in main (argc=1, argv=0x7fff98755e68) at xrandr-capplet.c:880
(gdb) 

Version-Release number of selected component (if applicable):

control-center-2.22.0-1.fc9.x86_64
xorg-x11-server-Xorg-1.4.99.901-4.20080310.fc9.x86_64
xorg-x11-drv-i810-2.2.1-11.fc9.x86_64

How reproducible:

Every time

Steps to Reproduce:
1. Run it
Comment 1 Bill Nottingham 2008-03-12 16:09:32 EDT
This seems to be confined to when i915 modesetting is active (when i915 is
loaded with modeset=1)
Comment 2 Ray Strode [halfline] 2008-03-12 16:23:35 EDT
Søren, any ideas?

Presumably info or output is NULL.
Comment 3 Bastien Nocera 2008-03-12 16:52:54 EDT
Looks like a dupe of Soeren's fault :)

*** This bug has been marked as a duplicate of 436702 ***
Comment 4 Joel Andres Granados 2008-12-09 07:42:53 EST
*** Bug 475386 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.