Bug 436733 - libvirt 0.4.1 fails to start network right
libvirt 0.4.1 fails to start network right
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: libvirt (Show other bugs)
8
All Linux
low Severity low
: ---
: ---
Assigned To: Daniel Veillard
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-03-09 23:18 EDT by Kevin Fenzi
Modified: 2008-03-31 17:39 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-03-13 17:37:19 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Kevin Fenzi 2008-03-09 23:18:23 EDT
libvirt 0.4.1 from updates-testing seems to fail to start in a normal manner. 

I get: 

# service libvirtd start
Starting libvirtd daemon: Shutting down network 'default'iptables: No
chain/target/match by that name
iptables: Bad rule (does a matching rule exist in that chain?)
iptables: Bad rule (does a matching rule exist in that chain?)
iptables: Bad rule (does a matching rule exist in that chain?)
iptables: No chain/target/match by that name
iptables: No chain/target/match by that name
iptables: Bad rule (does a matching rule exist in that chain?)
iptables: Bad rule (does a matching rule exist in that chain?)
iptables: Bad rule (does a matching rule exist in that chain?)
iptables: Bad rule (does a matching rule exist in that chain?)
Failed to bring down bridge 'virbr0' : No such device
Failed to delete bridge 'virbr0' : No such device or address
                                                           [  OK  ]

If I run 'libvirtd -v' manually everything seems to come up fine. 

dmesg has: 

RTNL: assertion failed at net/core/fib_rules.c (627)
Pid: 10778, comm: libvirtd Not tainted 2.6.24.3-21.fc8 #1

Call Trace:
 [<ffffffff8120743d>] fib_rules_event+0x4e/0x119
 [<ffffffff8126b3ad>] notifier_call_chain+0x29/0x4c
 [<ffffffff811fa464>] dev_set_mac_address+0x4b/0x52
 [<ffffffff8850f653>] :tun:tun_chr_ioctl+0x451/0x50a
 [<ffffffff810fa199>] file_has_perm+0x94/0xa3
 [<ffffffff810ac039>] do_ioctl+0x55/0x6b
 [<ffffffff810ac292>] vfs_ioctl+0x243/0x25c
 [<ffffffff810ac2fc>] sys_ioctl+0x51/0x71
 [<ffffffff8100c005>] tracesys+0xd5/0xda

RTNL: assertion failed at net/ipv4/devinet.c (1054)
Pid: 10778, comm: libvirtd Not tainted 2.6.24.3-21.fc8 #1

Call Trace:
 [<ffffffff8123f249>] inetdev_event+0x59/0x46a
 [<ffffffff8126948f>] _spin_lock_bh+0x9/0x19
 [<ffffffff8121693c>] rt_run_flush+0x7f/0xb7
 [<ffffffff8126b3ad>] notifier_call_chain+0x29/0x4c
 [<ffffffff811fa464>] dev_set_mac_address+0x4b/0x52
 [<ffffffff8850f653>] :tun:tun_chr_ioctl+0x451/0x50a
 [<ffffffff810fa199>] file_has_perm+0x94/0xa3
 [<ffffffff810ac039>] do_ioctl+0x55/0x6b
 [<ffffffff810ac292>] vfs_ioctl+0x243/0x25c
 [<ffffffff810ac2fc>] sys_ioctl+0x51/0x71
 [<ffffffff8100c005>] tracesys+0xd5/0xda

virbr0: Dropping NETIF_F_UFO since no NETIF_F_HW_CSUM feature.
virbr0: starting userspace STP failed, starting kernel STP

Happy to provide other info or do testing. 

0.4.0-4 works fine on the same machine.
Comment 1 Daniel Berrange 2008-03-09 23:52:23 EDT
Patch sent upstream

http://www.redhat.com/archives/libvir-list/2008-March/msg00088.html
Comment 2 Kevin Fenzi 2008-03-09 23:58:25 EDT
wow... thats service. You rock. ;) 
Comment 3 Daniel Berrange 2008-03-13 17:37:19 EDT
Fixed in libvirt-0.4.1-4.fc9
Comment 4 Carl Farrington 2008-03-31 16:57:51 EDT
I am seeing the same (similar?) problem on Fedora 8 after the virtualization
updates that came through over the last couple of days (March 29th/30th 2008).

Apparently I have libvirt-0.4.1-2.fc8

My XP virtual machine has basically no network connectivity, although it does
receive an IP address on the virtual network, eventually.

dmesg says:
virbr0: no IPv6 routers present
tun: Universal TUN/TAP device driver, 1.6
tun: (C) 1999-2004 Max Krasnyansky <maxk@qualcomm.com>
RTNL: assertion failed at net/core/fib_rules.c (627)
Pid: 2797, comm: libvirtd Tainted: P        2.6.24.3-50.fc8 #1

Call Trace:
 [<ffffffff812077e5>] fib_rules_event+0x4e/0x119
 [<ffffffff8126b75d>] notifier_call_chain+0x29/0x4c
 [<ffffffff811fa80c>] dev_set_mac_address+0x4b/0x52
 [<ffffffff88c61653>] :tun:tun_chr_ioctl+0x451/0x50a
 [<ffffffff810ac039>] do_ioctl+0x55/0x6b
 [<ffffffff810ac292>] vfs_ioctl+0x243/0x25c
 [<ffffffff810ac2fc>] sys_ioctl+0x51/0x71
 [<ffffffff8100c005>] tracesys+0xd5/0xda

RTNL: assertion failed at net/ipv4/devinet.c (1054)
Pid: 2797, comm: libvirtd Tainted: P        2.6.24.3-50.fc8 #1

Call Trace:
 [<ffffffff8123f5f1>] inetdev_event+0x59/0x46a
 [<ffffffff8126983f>] _spin_lock_bh+0x9/0x19
 [<ffffffff81216ce4>] rt_run_flush+0x7f/0xb7
 [<ffffffff8126b75d>] notifier_call_chain+0x29/0x4c
 [<ffffffff811fa80c>] dev_set_mac_address+0x4b/0x52
 [<ffffffff88c61653>] :tun:tun_chr_ioctl+0x451/0x50a
 [<ffffffff810ac039>] do_ioctl+0x55/0x6b
 [<ffffffff810ac292>] vfs_ioctl+0x243/0x25c
 [<ffffffff810ac2fc>] sys_ioctl+0x51/0x71
 [<ffffffff8100c005>] tracesys+0xd5/0xda

device vnet0 entered promiscuous mode
virbr0: port 1(vnet0) entering listening state
kvm: emulating exchange as write
vnet0: no IPv6 routers present
virbr0: port 1(vnet0) entering learning state
vnet0: received packet with  own address as source address
vnet0: received packet with  own address as source address
vnet0: received packet with  own address as source address
virbr0: topology change detected, propagating
virbr0: port 1(vnet0) entering forwarding state
vnet0: received packet with  own address as source address
vnet0: received packet with  own address as source address
vnet0: received packet with  own address as source address
vnet0: received packet with  own address as source address
vnet0: received packet with  own address as source address
vnet0: received packet with  own address as source address
vnet0: received packet with  own address as source address
vnet0: received packet with  own address as source address
vnet0: received packet with  own address as source address
vnet0: received packet with  own address as source address
vnet0: received packet with  own address as source address
printk: 3 messages suppressed.
vnet0: received packet with  own address as source address
printk: 12 messages suppressed.
vnet0: received packet with  own address as source address
printk: 17 messages suppressed.
vnet0: received packet with  own address as source address
printk: 6 messages suppressed.
vnet0: received packet with  own address as source address
printk: 10 messages suppressed.
vnet0: received packet with  own address as source address

Comment 5 Kevin Fenzi 2008-03-31 17:17:38 EDT
Carl: This bug is closed, but this looks like it might be bug #439715
Please add your comments over there?
Comment 6 Carl Farrington 2008-03-31 17:39:38 EDT
Thank you very much Kevin. You are right, it's that bug.
thanks again.

Note You need to log in before you can comment on or make changes to this bug.