Bug 436767 - General parse error after update to kernel-2.6.24.3-12.fc8
General parse error after update to kernel-2.6.24.3-12.fc8
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: lm_sensors (Show other bugs)
8
All Linux
high Severity high
: ---
: ---
Assigned To: Phil Knirsch
Fedora Extras Quality Assurance
: Regression
: 440225 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-03-10 07:38 EDT by David Kovalsky
Modified: 2015-03-04 20:19 EST (History)
5 users (show)

See Also:
Fixed In Version: 2.10.6-1.fc8
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-04-09 01:13:54 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
sensors.conf (83.18 KB, text/plain)
2008-03-10 07:38 EDT, David Kovalsky
no flags Details
strace sensors (8.51 KB, text/plain)
2008-03-12 10:58 EDT, David Kovalsky
no flags Details

  None (edit)
Description David Kovalsky 2008-03-10 07:38:04 EDT
After upgrading to kernel-2.6.24.3-12.fc8 running sensors throws general parse
error. My config attached. 

I've tried running sensors-detect do regenerate the config file, didn't help -
config stays the same.  

Fedora 8 i386 with latest and greatest updates.
kernel-2.6.24.3-12.fc8
lm_sensors-2.10.5-1.fc8

I'm using the coretemp module. 
...
Some CPUs or memory controllers may also contain embedded sensors.
Do you want to scan for them? (YES/no):
AMD K8 thermal sensors...                                   No
AMD K10 thermal sensors...                                  No
Intel Core family thermal sensor...                         Success!
    (driver `coretemp')
Intel AMB FB-DIMM thermal sensor...                         No
...

HW:
Lenovo T60 with Intel Core 2 Duo (T7200  @ 2.00GHz)

Let me know if you need more information to diagnose this properly.
Comment 1 David Kovalsky 2008-03-10 07:38:04 EDT
Created attachment 297416 [details]
sensors.conf
Comment 2 Hans de Goede 2008-03-11 06:37:42 EDT
David,

I'm afraid I'm clueless as to what the problem is (I co-maintain lm-sensors with
Phil as I'm an upstream lm_sensors contributer).

Can you please send a mail with your problem to the lm_sensors list:
lm-sensors@lm-sensors.org

I hope Jean and / or Mark, who are on that list, and are more familiar with the
libsensors code then me, can be of assistance.
Comment 3 David Kovalsky 2008-03-12 10:20:29 EDT
Ok, will do :-) I'll just add the need information listed at
http://www.lm-sensors.org/wiki/FAQ/Chapter4
to have all the pieces of the puzzle in one place.
Comment 4 David Kovalsky 2008-03-12 10:28:26 EDT
More information about the problem:

 * nothing relevant in dmesg/messafes
 * sensors-detect output
[root@kovinek ~]# sensors-detect
# sensors-detect revision 4966 (2007-10-20 01:41:53 -0700)

This program will help you determine which kernel modules you need
to load to use lm_sensors most effectively. It is generally safe
and recommended to accept the default answers to all questions,
unless you know what you're doing.

We can start with probing for (PCI) I2C or SMBus adapters.
Do you want to probe now? (YES/no):
Probing for PCI bus adapters...
Use driver `i2c-i801' for device 0000:00:1f.3: Intel 82801G ICH7

We will now try to load each adapter module in turn.
Module `i2c-i801' already loaded.
If you have undetectable or unsupported adapters, you can have them
scanned by manually loading the modules before running this script.

We are now going to do the I2C/SMBus adapter probings. Some chips may
be double detected; we choose the one with the highest confidence
value in that case.
If you found that the adapter hung after probing a certain address,
you can specify that address to remain unprobed.

Next adapter: SMBus I801 adapter at 18e0 (i2c-0)
Do you want to scan it? (YES/no/selectively):
Client found at address 0x44
Probing for `Maxim MAX6633/MAX6634/MAX6635'...              No

Some chips are also accessible through the ISA I/O ports. We have to
write to arbitrary I/O ports to probe them. This is usually safe though.
Yes, you do have ISA I/O ports even if you do not have any ISA slots!
Do you want to scan the ISA I/O ports? (YES/no):
Probing for `National Semiconductor LM78' at 0x290...       No
Probing for `National Semiconductor LM78-J' at 0x290...     No
Probing for `National Semiconductor LM79' at 0x290...       No
Probing for `Winbond W83781D' at 0x290...                   No
Probing for `Winbond W83782D' at 0x290...                   No
Probing for `Silicon Integrated Systems SIS5595'...         No
Probing for `VIA VT82C686 Integrated Sensors'...            No
Probing for `VIA VT8231 Integrated Sensors'...              No
Probing for `IPMI BMC KCS' at 0xca0...                      No
Probing for `IPMI BMC SMIC' at 0xca8...                     No

Some Super I/O chips may also contain sensors. We have to write to
standard I/O ports to probe them. This is usually safe.
Do you want to scan for Super I/O sensors? (YES/no):
Probing for Super-I/O at 0x2e/0x2f
Trying family `National Semiconductor'...                   Yes
Found unknown chip with ID 0xf411
Probing for Super-I/O at 0x4e/0x4f
Trying family `National Semiconductor'...                   No
Trying family `SMSC'...                                     No
Trying family `VIA/Winbond/Fintek'...                       No
Trying family `ITE'...                                      No

Some CPUs or memory controllers may also contain embedded sensors.
Do you want to scan for them? (YES/no):
AMD K8 thermal sensors...                                   No
AMD K10 thermal sensors...                                  No
Intel Core family thermal sensor...                         Success!
    (driver `coretemp')
Intel AMB FB-DIMM thermal sensor...                         No

Now follows a summary of the probes I have just done.
Just press ENTER to continue:

Driver `coretemp' (should be inserted):
  Detects correctly:
  * Chip `Intel Core family thermal sensor' (confidence: 9)

I will now generate the commands needed to load the required modules.
Just press ENTER to continue:

To load everything that is needed, add this to some /etc/rc* file:

#----cut here----
# Chip drivers
modprobe coretemp
# sleep 2 # optional
/usr/bin/sensors -s # recommended
#----cut here----

If you have some drivers built into your kernel, the list above will
contain too many modules. Skip the appropriate ones! You really
should try these commands right now to make sure everything is
working properly. Monitoring programs won't work until the needed
modules are loaded.

Do you want to overwrite /etc/sysconfig/lm_sensors? (YES/no):


 * lsmod
[root@kovinek ~]# lsmod | grep -v ^Module | sort
ac                      8005  0
acpi_cpufreq           12365  2
aes_generic            31361  0
aes_i586               36673  2
ahci                   25541  3
arc4                    5825  2
ata_piix               17861  0
battery                12997  0
blkcipher               9285  3 geode_aes,cbc,ecb
button                 10321  0
cbc                     7489  1
cdrom                  33761  1 sr_mod
cfg80211               23113  1 mac80211
coretemp                9281  0
cpufreq_ondemand       10317  1
crc_ccitt               5953  1 irda
dm_crypt               14405  1
dm_mirror              21441  0
dm_mod                 48773  12 dm_multipath,dm_crypt,dm_snapshot,dm_zero,dm_mirror
dm_multipath           18505  0
dm_snapshot            17765  0
dm_zero                 5697  0
e1000                 111493  0
ecb                     6593  2
ehci_hcd               32333  0
ext3                  111945  3
geode_aes               8777  0
hwmon                   6341  2 coretemp,thinkpad_acpi
i2c_core               21057  2 i2c_dev,i2c_i801
i2c_dev                 9285  0
i2c_i801               11985  0
iptable_filter          6337  1
ip_tables              14085  1 iptable_filter
ipt_REJECT              7361  2
ipv6                  228357  68
irda                  102521  0
iTCO_vendor_support     6981  1 iTCO_wdt
iTCO_wdt               13797  0
iwl3945               156981  0
jbd                    40533  1 ext3
joydev                 12545  0
kvm                    74869  1 kvm_intel
kvm_intel              22117  0
libata                128561  2 ata_piix,ahci
lockd                  58057  2 nfs
mac80211              161065  1 iwl3945
mbcache                10049  1 ext3
nf_conntrack           51713  2 nf_conntrack_ipv4,xt_state
nf_conntrack_ipv4      11589  2
nfs                   218957  1
nfs_acl                 6721  1 nfs
ohci_hcd               22725  0
output                  6721  1 video
pcspkr                  6465  0
scsi_mod              123341  4 sr_mod,sg,libata,sd_mod
sd_mod                 26689  4
sg                     32209  0
sha256_generic         15041  0
snd                    48453  14
snd_hda_intel,snd_seq_dummy,snd_seq_oss,snd_seq,snd_seq_device,snd_pcm_oss,snd_mixer_oss,snd_pcm,snd_timer,snd_hwdep
snd_hda_intel         297441  3
snd_hwdep              10693  1 snd_hda_intel
snd_mixer_oss          17217  1 snd_pcm_oss
snd_page_alloc         11593  2 snd_hda_intel,snd_pcm
snd_pcm                70981  3 snd_hda_intel,snd_pcm_oss
snd_pcm_oss            44353  0
snd_seq                48945  5 snd_seq_dummy,snd_seq_oss,snd_seq_midi_event
snd_seq_device         10317  3 snd_seq_dummy,snd_seq_oss,snd_seq
snd_seq_dummy           6725  0
snd_seq_midi_event      9665  1 snd_seq_oss
snd_seq_oss            31553  0
snd_timer              21317  3 snd_seq,snd_pcm
soundcore               9505  1 snd
sr_mod                 17381  0
sunrpc                149213  10 nfs,lockd,nfs_acl
thinkpad_acpi          47037  0
tun                    11585  0
uhci_hcd               23633  0
video                  20177  0
x_tables               14149  4 xt_state,xt_tcpudp,ipt_REJECT,ip_tables
xt_state                5953  2
xt_tcpudp               6849  4
Comment 5 David Kovalsky 2008-03-12 10:38:54 EDT
[root@kovinek ~]# i2cdetect 0
WARNING! This program can confuse your I2C bus, cause data loss and worse!
I will probe file /dev/i2c-0.
I will probe address range 0x03-0x77.
Continue? [Y/n] y
     0  1  2  3  4  5  6  7  8  9  a  b  c  d  e  f
00:          -- -- -- -- -- 08 -- -- -- -- -- -- --
10: -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- --
20: -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- --
30: -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- --
40: -- -- -- -- 44 -- -- -- -- -- -- -- -- -- -- --
50: -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- --
60: -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- --
70: -- -- -- -- -- -- -- --

i2cdump 0 0x08 -> all 'XX'


[root@kovinek ~]# i2cdump 0 0x44
No size specified (using byte-data access)
WARNING! This program can confuse your I2C bus, cause data loss and worse!
I will probe file /dev/i2c-0, address 0x44, mode byte
Continue? [Y/n] y
     0  1  2  3  4  5  6  7  8  9  a  b  c  d  e  f    0123456789abcdef
00: 00 00 00 04 00 80 00 00 00 00 00 00 00 00 00 00    ...?.?..........
10: 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00    ................
20: 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00    ................
30: 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00    ................
40: 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00    ................
50: 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00    ................
60: 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00    ................
70: 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00    ................
80: 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00    ................
90: 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00    ................
a0: 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00    ................
b0: 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00    ................
c0: 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00    ................
d0: 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00    ................
e0: 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00    ................
f0: 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00    ................

Comment 6 David Kovalsky 2008-03-12 10:58:24 EDT
Created attachment 297776 [details]
strace sensors
Comment 7 Jean Delvare 2008-03-12 11:23:01 EDT
From the strace output:
lstat64("/sys/class/hwmon/hwmon0", {st_mode=S_IFLNK|0777, st_size=0, ...}) = 0
readlink("/sys/class/hwmon/hwmon0",
"../../devices/platform/thinkpad_hwmon/hwmon/hwmon0", 256) = 50

This is the problem I think. libsensors 2.10.5 doesn't support platform devices
with no number. It wants "thinkpad_hwmon.0", not "thinkpad_hwmon". The "parse
error" should go away if you unload the thinkpad_acpi kernel module.

The thinkpad_acpi driver is not supported by lm-sensors 2.10.5 anyway, so
ignoring the device in question in libsensors would be enough. That is, backport
the following fix from lm-sensors 2.10.6:
http://www.lm-sensors.org/changeset/5086
Comment 8 David Kovalsky 2008-03-12 11:58:32 EDT
Indeed rmmod-ing thinkpad_acpi helps. Also upgrading to to 2.10.6 does the trick. 
Hans/Phil, can you spin the update from 2.10.5 to 2.10.6 for Fedoras?

Thanks all for the help!
Comment 9 Fedora Update System 2008-03-12 16:43:55 EDT
lm_sensors-2.10.6-1.fc8 has been submitted as an update for Fedora 8
Comment 10 Hans de Goede 2008-03-12 16:45:38 EDT
(In reply to comment #9)
> lm_sensors-2.10.6-1.fc8 has been submitted as an update for Fedora 8

I've send this to updates-testing first to make sure there are no problems with
it, please give it a thorough testing.

p.s.

Jean, thanks! Your fantastic (as always).
Comment 11 Fedora Update System 2008-03-13 03:41:05 EDT
lm_sensors-2.10.6-1.fc8 has been pushed to the Fedora 8 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update lm_sensors'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F8/FEDORA-2008-2391
Comment 12 David Kovalsky 2008-03-13 06:58:02 EDT
I'm running the new version from update testing and it seems to work as expected. 
Comment 13 Hans de Goede 2008-04-02 10:09:08 EDT
*** Bug 440225 has been marked as a duplicate of this bug. ***
Comment 14 Brian Long 2008-04-02 10:47:48 EDT
I can confirm that lm_sensors-2.10.6 from updates-testing fixes the problem.
Comment 15 Fedora Update System 2008-04-09 01:13:52 EDT
lm_sensors-2.10.6-1.fc8 has been pushed to the Fedora 8 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.