Bug 436838 - Missing perl dependency in rpm
Missing perl dependency in rpm
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: java-1.5.0-gcj (Show other bugs)
rawhide
i386 Linux
low Severity medium
: ---
: ---
Assigned To: Thomas Fitzsimmons
Fedora Extras Quality Assurance
:
: 437524 (view as bug list)
Depends On:
Blocks: F9Target
  Show dependency treegraph
 
Reported: 2008-03-10 14:53 EDT by Joe Nall
Modified: 2013-01-09 23:35 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-04-03 14:30:13 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
patch to add proper triggerin requires (2.12 KB, patch)
2008-03-19 18:58 EDT, Orion Poplawski
no flags Details | Diff

  None (edit)
Description Joe Nall 2008-03-10 14:53:15 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Macintosh; U; Intel Mac OS X; en-us) AppleWebKit/523.15.1 (KHTML, like Gecko) Version/3.0.4 Safari/523.15

Description of problem:
Note the use of perl before it is installed. Network install of current rawhide.

Installing java-1.5.0-gcj - 1.5.0.0-19.fc9.i386
/var/tmp/rpm-tmp.24790: line 11: /usr/bin/perl: No such file or directory
/var/tmp/rpm-tmp.24790: line 18: /usr/bin/perl: No such file or directory
/var/tmp/rpm-tmp.24790: line 24: /usr/bin/perl: No such file or directory
/var/tmp/rpm-tmp.24790: line 28: /usr/bin/perl: No such file or directory
Installing perl-version - 3:0.74-14.fc9.i386
Installing xml-commons-apis - 1.3.04-1jpp.1.fc9.i386
Installing tomcat5-servlet-2.4-api - 5.5.26-1jpp.2.fc9.i386
Installing eclipse-ecj - 1:3.3.1.1-14.fc9.i386
Installing xalan-j2 - 2.7.0-7jpp.2.fc9.i386
Installing gcc-java - 4.3.0-2.i386
Installing hsqldb - 1:1.8.0.9-2jpp.1.fc9.i386
Installing tomcat5-jsp-2.0-api - 5.5.26-1jpp.2.fc9.i386
Installing bsf - 2.3.0-12jpp.2.fc9.i386
Installing bsh - 1.3.0-12jpp.2.fc9.i386
Installing xml-commons-resolver - 1.1-1jpp.12.i386
Installing xerces-j2 - 2.7.1-10jpp.1.fc9.i386
Installing setools-libs-java - 3.3.2-2.fc9.i386
Installing sinjdoc - 0.5-6.fc9.i386
Installing java_cup - 1:0.10-0.k.6jpp.2.i386
Installing postgis - 1.3.2-3.fc9.1.i386
Installing coolkey - 1.1.0-6.fc9.i386
Installing java-1.5.0-gcj-devel - 1.5.0.0-19.fc9.i386
/var/tmp/rpm-tmp.8214: line 6: /usr/bin/perl: No such file or directory
/var/tmp/rpm-tmp.8214: line 16: /usr/bin/perl: No such file or directory
/var/tmp/rpm-tmp.8214: line 16: /usr/bin/perl: No such file or directory
/var/tmp/rpm-tmp.8214: line 24: /usr/bin/perl: No such file or directory
/var/tmp/rpm-tmp.8214: line 24: /usr/bin/perl: No such file or directory
Installing setools-devel - 3.3.2-2.fc9.i386
Installing ant - 1.7.0-1jpp.4.fc9.i386
Installing gnome-vfs2 - 2.21.90-1.fc9.i386
Installing hal - 0.5.11-0.git20080304.3.fc9.i386
Installing setroubleshoot-plugins - 2.0.4-1.fc9.noarch
Installing hal-info - 20080215-2.fc9.noarch
Installing setroubleshoot-server - 2.0.6-1.fc9.noarch
Installing fedora-screensaver-theme - 1.0.0-1.fc8.noarch
Installing fedorainfinity-gdm-theme - 8.0.1-1.fc8.noarch
Installing perl-libs - 4:5.10.0-14.fc9.i386
Installing perl - 4:5.10.0-14.fc9.i386



Version-Release number of selected component (if applicable):
java-1.5.0-gcj 

How reproducible:
Always


Steps to Reproduce:
Network kickstart install of rawhide

Actual Results:


Expected Results:


Additional info:
Comment 1 Jon Stanley 2008-03-14 22:40:00 EDT
*** Bug 437524 has been marked as a duplicate of this bug. ***
Comment 2 Orion Poplawski 2008-03-19 18:58:55 EDT
Created attachment 298606 [details]
patch to add proper triggerin requires
Comment 3 Thomas Fitzsimmons 2008-04-03 14:30:13 EDT
Added this extra requirement to the devel subpackage:

# triggerin requires gcj to retrieve gcj header file locations
Requires(triggerin): %{_bindir}/gcj%{gccsuffix}

and committed the patch, thanks.

Rebuilt in Rawhide as java-1.5.0-gcj-1.5.0.0-21.fc9.

Note You need to log in before you can comment on or make changes to this bug.