Bug 436936 - Reproducible crash after splitting table cell with complicated table in Writer
Reproducible crash after splitting table cell with complicated table in Writer
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: openoffice.org (Show other bugs)
8
All Linux
low Severity high
: ---
: ---
Assigned To: Caolan McNamara
Fedora Extras Quality Assurance
:
: 443393 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-03-11 05:25 EDT by Tim Jackson
Modified: 2008-05-20 16:03 EDT (History)
1 user (show)

See Also:
Fixed In Version: openoffice.org-writer-2.4.0-12.8.fc9
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-05-20 16:03:29 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Crash log (12.48 KB, text/plain)
2008-03-11 05:25 EDT, Tim Jackson
no flags Details
mapped stack (10.47 KB, text/plain)
2008-03-11 05:49 EDT, Caolan McNamara
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
OpenOffice.org 82698 None None None Never

  None (edit)
Description Tim Jackson 2008-03-11 05:25:52 EDT
Description of problem:
I have a particular OpenDocument document (written from scratch in OO Writer)
which now crashes OO every time I open it.
The crashes started happening shortly after I vertically split a table cell in a
complicated table and then started editing some text in one half of the
newly-split cell.

Attached is the crash log.

The document is unfortunately not publically distributable.

Version-Release number of selected component (if applicable):
openoffice.org-writer-2.3.0-6.11.fc8

How reproducible:
Every time, with this particular document.
Comment 1 Tim Jackson 2008-03-11 05:25:52 EDT
Created attachment 297586 [details]
Crash log
Comment 2 Caolan McNamara 2008-03-11 05:49:33 EDT
Created attachment 297589 [details]
mapped stack
Comment 3 Caolan McNamara 2008-03-11 05:55:16 EDT
Might be http://qa.openoffice.org/issues/show_bug.cgi?id=82698 which will be
fixed in 2.4.0, I'd need to have the doc to be sure. If you want you can mail it
to me personally and I can have a look.
Comment 4 Caolan McNamara 2008-04-08 09:57:59 EDT
Do you want to try and mail it directly to me and "trust me", otherwise I'll
assume that is is the same as the very similar looking
http://qa.openoffice.org/issues/show_bug.cgi?id=82698
Comment 5 Tim Jackson 2008-04-09 14:53:13 EDT
I can't really distribute it; however it does sound like the upstream issue.
I can't easily discern from the upstream bugtracker which (if any) released
version it has made it in to; if you can decipher this better than me and it's
made it into a Fedora package (albeit rawhide) then let me know and I'll give it
a shot.
Comment 6 Caolan McNamara 2008-04-18 09:06:24 EDT
Hmm, indeed. If its the same problem then it should work with 2.4.0 as found in
rawhide or the F-9 Beta
Comment 7 Caolan McNamara 2008-04-21 07:00:00 EDT
*** Bug 443393 has been marked as a duplicate of this bug. ***
Comment 8 Tim Jackson 2008-05-20 15:36:46 EDT
Confirmed fixed in openoffice.org-writer-2.4.0-12.8.fc9.i386

Note You need to log in before you can comment on or make changes to this bug.