Bug 437008 - fmtutil can easily loop upon a misconfiguration
fmtutil can easily loop upon a misconfiguration
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: texlive (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Jindrich Novy
Fedora Extras Quality Assurance
:
: 431516 (view as bug list)
Depends On:
Blocks: F9Beta
  Show dependency treegraph
 
Reported: 2008-03-11 12:43 EDT by Stepan Kasal
Modified: 2013-07-02 19:27 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-03-12 13:17:42 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
proposed patch (673 bytes, patch)
2008-03-11 12:43 EDT, Stepan Kasal
no flags Details | Diff

  None (edit)
Description Stepan Kasal 2008-03-11 12:43:45 EDT
Description of problem:
automatic format generation (mktexfmt, which is just a symlink to fmtutil these
days) can easily get into in infinite loop and fork new and new processes.
It should abort with an error.

Version-Release number of selected component (if applicable):
texlive-2007-16.fc9

To Reproduce:
# mv /usr/share/texmf/tex/latex/latexconfig/latex.ini{,.hide}
# rm /var/lib/texmf/web2c/pdftex/{xml,la}tex.fmt
# fmtutil-sys --byfmt xmltex 2>&1|less

The output looks like this:

fmtutil: running `pdftex -ini   -jobname=xmltex -progname=xmltex &latex
xmltex.ini' ...
This is pdfTeXk, Version 3.141592-1.40.3 (Web2C 7.5.6) (INITEX)
 %&-line parsing enabled.
kpathsea: Running mktexfmt latex.fmt
Sorry, I can't find the format `latex.fmt'; will try `xmltex.fmt'.
kpathsea: Running mktexfmt xmltex.fmt
fmtutil: running `pdftex -ini   -jobname=xmltex -progname=xmltex &latex
xmltex.ini' ...

Observe that the last verse of the song is exactly the same as the first one:
yes, we are there.

Expected results:
The script should display some politically ioncorrect sentences to express
clearly that it does not feel happy ... and then _quit_.
Comment 1 Stepan Kasal 2008-03-11 12:43:45 EDT
Created attachment 297639 [details]
proposed patch
Comment 2 Jindrich Novy 2008-03-12 13:17:42 EDT
Applied, thanks!
Comment 3 Jesse Keating 2008-03-12 14:31:45 EDT
Putting this on the beta tracker, just for keeping people on the same page. 
Requesting it goes in the beta.
Comment 4 Jindrich Novy 2008-03-12 14:38:20 EDT
*** Bug 431516 has been marked as a duplicate of this bug. ***
Comment 5 Stepan Kasal 2008-03-19 14:32:52 EDT
... and I can proudly announce that Karl Berry accepted this fix for the
upstream TeXlive.  :-)

Note You need to log in before you can comment on or make changes to this bug.