This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 437009 - Anaconda fails to properly create/destroy loop devices
Anaconda fails to properly create/destroy loop devices
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
:
Depends On:
Blocks: F9Beta
  Show dependency treegraph
 
Reported: 2008-03-11 12:49 EDT by Will Woods
Modified: 2008-03-17 17:50 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-03-17 17:50:23 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Will Woods 2008-03-11 12:49:28 EDT
(this started with bug 436855)

If loader fails to pull down .discinfo, it tries to unmount the stage2.img that
it found previously. When it attempts this, the following happens: 

INFO  : umounting loopback /mnt/runtime /dev/loop0
ERROR : LOOP_CLR_FD failed for /mnt/runtime /dev/loop0 (Device or resource busy)

So loop0 stays active. When you get the right URL, it will pull down stage2 and
try to mount it again, but since loop0 is active, it fails to mount with an
error about LOOP_SET_FD. And then you're stuck.

Since we have the normal mount binary, maybe we should let mount -o loop handle
creating/destroying loop devices?
Comment 1 Chris Lumens 2008-03-14 12:02:42 EDT
Okay, we're using mount -o loop=/dev/loopX now so this should be taken care of.
 You're still bound to see some similar looking error messages on hdiso installs
but that's only because it's attempting to mount images/stage2.img which is not
guaranteed to exist on every ISO image in a set.  In other words, they should be
harmless errors now.
Comment 2 Will Woods 2008-03-17 17:50:23 EDT
Everything seems to work as expected now. 

Note You need to log in before you can comment on or make changes to this bug.