Bug 437069 - Bug status is "no response pending" when I try to keep it as "pending on vendor respond"
Bug status is "no response pending" when I try to keep it as "pending on vend...
Status: CLOSED WONTFIX
Product: Red Hat Ready Certification Tests
Classification: Retired
Component: web site (Show other bugs)
2
All Linux
high Severity medium
: ---
: ---
Assigned To: eric_liu
Yu Shao
: Reopened
Depends On: 454593
Blocks:
  Show dependency treegraph
 
Reported: 2008-03-11 22:47 EDT by QinXie
Modified: 2008-07-15 13:38 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-07-15 13:38:17 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description QinXie 2008-03-11 22:47:49 EDT
Description of problem:
Bug status is "no response pending" when I try to keep it as "pending on vendor
response"

Version-Release number of selected component (if applicable):

Steps to Reproduce:
1. Open one bug;
2. Click status option and set it to be "Change status to pending on vendor",
and click "save changes" button;
3. Now bug status is "pending for vendor response", click status option and set
it to be  "Change status to pending on vendor", don't click "save changes" button;
4. Edit some comments in dialog: like "test"
5. Click option and set it to be "Leave as Pending for Vendor response", click
"save changes" button;


Actual results:
Status should be changed to be "pending for vendor response"

Expected results:
Status is changed to be "no response pending"
Comment 1 XINSUN 2008-03-20 06:51:40 EDT
Can not reproduce this bug with above steps. So close it with "not a bug". I and
cqin will still track and observe it from now on.
Comment 2 QinXie 2008-04-10 11:31:57 EDT
nicho, 

I met it 4 times today, twice this morning and twice tonight. I think it's the
time to reopen it :) 

In brief, if vendor or someone uploaded some packages with option "Leave as
Pending for Vendor response". Next time, when I(reviewer) try to add some
comment with opiton "Leave as Pending for Vendor response", status will be
changed to be "assigned". 

The bug I met tonight is bug 438346 and bug 433298. I will try to write down all
the steps I remember now. 
bug 438346: 
1. I set it to be pending on vendor;
2. vendor uploaded one package, but didn't change the status;
3. I opened the cert and saw the status is "pending on vendor", I add one
comment, and use the option “keep it pending on vendor” to keep the staus.
4. after submittion is finished, status changed to be " Leave as No Response
Pending  "

bug 433298

1. I set it to be pending on vendor;
2. peter(tam) uploaded one package, but didn't change the status;
3. I opened the cert and saw the status is "pending on vendor", I mark the
packages as reviewed, and use the option “keep it pending on vendor” to keep the
staus.
4. after submittion is finished, status still is “keep it pending on vendor”.
Next I add one comment, and use the option “keep it pending on vendor” to keep
the staus, but after sumittion, status changed to be " Leave as No Response
Pending  "

Wish the above info is useful to dig out the root cause.
Comment 3 QinXie 2008-04-10 11:35:06 EDT
nicho

maybe role is the key :)

qinxie
Comment 5 eric_liu 2008-07-08 16:53:06 EDT
Hello, Everyone:

I found this appearance is caused by a section code in process.cgi, as follow:

       # REDHAT start
        # Added to change bug status from NEEDINFO to ASSIGNED if comment was made
        # Will not change tho if user already changed the status to something
else themselves
        if ($col eq 'bug_status' && $old eq 'NEEDINFO' && $old eq $new &&
$::FORM{'comment'})
       {.......  }
        ............................
            # Change status to ASSIGNED if requestee
            if ($status_change) {
                SendSQL("UPDATE bugs SET bug_status = 'ASSIGNED' WHERE bug_id =
$id");
                $new = 'ASSIGNED';
                                }
        }

        # Old Style
        if ($col eq 'bug_status' && $old eq 'NEEDINFO_REPORTER'
            && $old eq $new && $::FORM{'comment'}) {
                               ..........................
                SendSQL("UPDATE bugs SET bug_status = 'ASSIGNED' WHERE bug_id =
$id");
                $new = 'ASSIGNED';                         
        }
        }
        # REDHAT end

       The status change to "ASSIGNED" from  "NEEDINFO" automaticly if someone
add any comments. The "ASSIGNED" status  is mapped on UI which is shown as "No
Pending Response " , as well as "NEEDINFO" status on UI is shown as "pending on
vendor".
       I discussed this problem with Noura.She is so kind and  explain to me the
basical behaviour in bugzilla is as the following:

      "if the bug in is NEEDINFO status ,, then if the user provides a comment
,the status automatically changes back to the status that was on the bug before
NEEDINFO so if you take a look for example at bug
https://bz-web1-test.devel.redhat.com/show_bug.cgi?id=440291 and then you see it
is marked as NEEDINFO requested from  anyone so if any one adds a comment and
then it will change back to ASSIGNED which was the previou status to NEEDINFO
basically if the status was NEEDINFO from reporter then it will only clear if:
       "1- the reporter added a comment 
      "or 
       "2- some one added a comment and they checked the box she is providing
the requested information for this bug. 
      "This is a code that they added to bugzilla , actually she added that code
with Dave lawrence's suggestion
      " And more  infomation 
       "We are going to be migrating from bugzilla 2.18 to bugzilla 3.2 as
expected on 26th July and the NEEDINFO status will be deleted completely and
replaced with the needinfo flag so all that code you emailed will not be there
in the new bugzilla version."


Thank you very much Noura!!!!!  :)

And I suggest we could fixed this appearance in the new version hwcert, because
we will have our new status machine by that time.

--Yours 
Eric Liu
09/07/2008 


Comment 6 eric_liu 2008-07-10 21:42:22 EDT
        This bug is depend on bug#454593 . It is related to NEEDINFO status
which will be replaced by needinfo flag in bz 3.2 version . 
       

Note You need to log in before you can comment on or make changes to this bug.