Bug 437085 - rt73usb: can scan, but cannot associate (Belkin 54g USB)
rt73usb: can scan, but cannot associate (Belkin 54g USB)
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: John W. Linville
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-03-12 06:44 EDT by Caolan McNamara
Modified: 2008-03-12 11:55 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-03-12 11:55:52 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
dmesg log (67.08 KB, text/plain)
2008-03-12 06:44 EDT, Caolan McNamara
no flags Details

  None (edit)
Description Caolan McNamara 2008-03-12 06:44:08 EDT
Description of problem:
NetworkManager lists results of a scan, but attempts to associate fail

Version-Release number of selected component (if applicable):
kernel-2.6.25-0.105.rc5.fc9.x86_64

How reproducible:
Always

Steps to Reproduce:
1. insert belkin 54g USB
  
Actual results:
scan results, but cannot wpa associate

Additional info:
I don't think this device has even worked for me in any kernel, so not a
regression in functionality.
Comment 1 Caolan McNamara 2008-03-12 06:44:08 EDT
Created attachment 297746 [details]
dmesg log
Comment 2 John W. Linville 2008-03-12 09:57:00 EDT
Can you replicate this with -0.113.rc5.git2.fc9?

   http://koji.fedoraproject.org/koji/buildinfo?buildID=42641

It specifically has an rt2x00-related locking fix that might be the culprit.
Comment 3 Caolan McNamara 2008-03-12 11:02:49 EDT
aha, indeed. Now it wpa associates and I've can a good few megs through it so
far successfully. 113 looks like a keeper.
Comment 4 John W. Linville 2008-03-12 11:55:52 EDT
Cool...any chance that helps w/ bug 473083?

Note You need to log in before you can comment on or make changes to this bug.