Bug 437144 - middle mouse button and right button have been interchanged
middle mouse button and right button have been interchanged
Status: CLOSED DUPLICATE of bug 436692
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-mouse (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: X/OpenGL Maintenance List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-03-12 12:31 EDT by ritz
Modified: 2008-03-12 15:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-03-12 15:37:27 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description ritz 2008-03-12 12:31:08 EDT
Description of problem:
middle mouse button and right button have been interchanged on my 3button mouse.
Using left-handed mouse.

Version-Release number of selected component (if applicable):
xorg-x11-drv-mouse-1.2.3-4.fc9.i386

How reproducible:
always

Steps to Reproduce:
1. Use right mouse button and it behaves as middle click ( paste)
2. middle mouse button behaves as right click
  
Actual results:

ButtonRelease event, serial 27, synthetic NO, window 0x4800001,
    root 0xa5, subw 0x4800002, time 27272545, (40,41), root:(41,563),
    state 0x110, button 1, same_screen YES
<---- This should be button 2

ButtonPress event, serial 27, synthetic NO, window 0x4800001,
    root 0xa5, subw 0x4800002, time 27276745, (40,41), root:(41,563),
    state 0x10, button 2, same_screen YES
<---- This should be button 1


Expected results:
button 1 and 2 should be mapped correctly

Additional info:
On touchpad, i see three buttons as agains 2 from previous release.
Comment 1 Will Woods 2008-03-12 15:37:27 EDT

*** This bug has been marked as a duplicate of 436692 ***

Note You need to log in before you can comment on or make changes to this bug.