Bug 437272 - padlock: No such device
padlock: No such device
Status: CLOSED DUPLICATE of bug 438288
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: cryptsetup-luks (Show other bugs)
All Linux
low Severity low
: rc
: ---
Assigned To: Milan Broz
Depends On:
  Show dependency treegraph
Reported: 2008-03-13 06:39 EDT by Matthew Booth
Modified: 2013-02-28 23:06 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2008-06-19 10:29:02 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Matthew Booth 2008-03-13 06:39:24 EDT
Description of problem:
Immediately after entering my first LUKS password (but not the second), I get a
warning something like:

modprobe: WARNING: Unable to load padlock (/lib/modules/..../padlock.ko): No
such device

This is displayed on the console every time, but I can't find it in a log file
anywhere. It doesn't appear to actually relate to any breakage, but it looks
scary. I suggest one of the following:

* It should be made to insert properly
* It should not probed if the hardware is not present
* The error message should be suppressed

Version-Release number of selected component (if applicable):
kernel 2.6.18-84.el5xen

How reproducible:
Comment 1 Bill Nottingham 2008-03-13 11:20:28 EDT
This is either cryptsetup-luks or dm-crypt.
Comment 2 Milan Broz 2008-03-13 11:33:08 EDT
(In reply to comment #1)
> This is either cryptsetup-luks or dm-crypt.

Neither. It's product of autodetection of kernel crypto module (AES), it just
use generic module later if hw is not detected - anyway, error message should be
probably suppressed.
Comment 3 Milan Broz 2008-06-19 10:29:02 EDT
Kernel padlock.ko issue, see https://bugzilla.redhat.com/show_bug.cgi?id=438288#c4

*** This bug has been marked as a duplicate of 438288 ***

Note You need to log in before you can comment on or make changes to this bug.