Bug 437283 - Cannot connect to libvirtd
Summary: Cannot connect to libvirtd
Status: CLOSED DUPLICATE of bug 436994
Alias: None
Product: Fedora
Classification: Fedora
Component: virt-manager   
(Show other bugs)
Version: rawhide
Hardware: All
OS: Linux
low
low
Target Milestone: ---
Assignee: Daniel Berrange
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-03-13 11:44 UTC by Adam Tkac
Modified: 2013-04-30 23:38 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-03-13 17:56:31 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Adam Tkac 2008-03-13 11:44:13 UTC
Description of problem:
I'm not able connect to libvirtd with latest virt-manager

Version-Release number of selected component (if applicable):
rpm -q virt-manager
virt-manager-0.5.4-1.fc9.i386

How reproducible:
always

Steps to Reproduce:
1. try connect to "localhost qemu"
  
Actual results:
traceback
Unable to open connection to hypervisor URI 'qemu:///system':
<class 'libvirt.libvirtError'> virConnectOpenAuth() failed Failed to collect
auth credentials
Traceback (most recent call last):
  File "/usr/share/virt-manager/virtManager/connection.py", line 427, in
_open_thread
    None], flags)
  File "/usr/lib/python2.5/site-packages/libvirt.py", line 94, in openAuth
    if ret is None:raise libvirtError('virConnectOpenAuth() failed')
libvirtError: virConnectOpenAuth() failed Failed to collect auth credentials

and message that libvirtd is not started (it is started)

Expected results:
successful connection

Additional info:
downgrade to virt-manager-0.5.3-2.fc9.i386 solves problem

Comment 1 Daniel Berrange 2008-03-13 17:56:31 UTC

*** This bug has been marked as a duplicate of 436994 ***


Note You need to log in before you can comment on or make changes to this bug.