Bug 437305 - ppc32 kexec-tools no longer understands 64-bit kernels
ppc32 kexec-tools no longer understands 64-bit kernels
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: kexec-tools (Show other bugs)
8
powerpc Linux
low Severity low
: ---
: ---
Assigned To: Neil Horman
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-03-13 10:34 EDT by Kazunori Asayama
Modified: 2008-03-16 15:29 EDT (History)
2 users (show)

See Also:
Fixed In Version: 1.102pre-7.fc8
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-03-16 15:29:48 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
use the same configuration as F7 (282 bytes, patch)
2008-03-14 01:44 EDT, Kazunori Asayama
no flags Details | Diff

  None (edit)
Description Kazunori Asayama 2008-03-13 10:34:57 EDT
+++ This bug was initially created as a clone of Bug #405341 +++

[root@ps3 boot]# kexec -f --command-line="root=/dev/VolGroup00/LogVol00
video=720p panic=30" --initrd=initrd-2.6.23.1-43.fc8.img vmlinuz-2.6.23.1-43.fc8 
Cannot determine the file type of vmlinuz-2.6.23.1-43.fc8


Additional info:

There is difference between F7's kexec-tools.spec and F8's kexec-tools.spec as
following:

---
 %ifarch ppc
-%define archdef ARCH=ppc64
+%define archdef ARCH=ppc
 %endif
---

I guess that this is the reason why ppc32 kexec can't handle 64-bit kernels.
Comment 1 Kazunori Asayama 2008-03-14 01:44:55 EDT
Created attachment 298016 [details]
use the same configuration as F7

I tried the change attached to use the same configuration as F7, 
and the ppc32 kexec could load 64-bit kernels correctly.
Comment 2 Fedora Update System 2008-03-14 10:01:54 EDT
kexec-tools-1.102pre-7.fc8 has been submitted as an update for Fedora 8
Comment 3 Neil Horman 2008-03-14 10:03:54 EDT
fixed in -7.fc8
Comment 4 Fedora Update System 2008-03-16 15:29:46 EDT
kexec-tools-1.102pre-7.fc8 has been pushed to the Fedora 8 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.