Bug 43740 - Unresolved dependencies when doing a full install
Unresolved dependencies when doing a full install
Status: CLOSED DUPLICATE of bug 36860
Product: Red Hat Linux
Classification: Retired
Component: basesystem (Show other bugs)
7.1
ia64 Linux
medium Severity low
: ---
: ---
Assigned To: Bill Nottingham
Aaron Brown
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-06-06 18:42 EDT by IBM Bug Proxy
Modified: 2014-03-16 22:21 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-06-06 18:42:23 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description IBM Bug Proxy 2001-06-06 18:42:21 EDT
LTC153
	
Hardware Environment:
Intel SDV IA-64
~1gig ram
18 gig scsi HD
b3 stepping Itanium

Software Environment:
Redhat 7.1 for IA-64 beta (may 29 beta)

Steps to Reproduce:
1. Select "Custom" installation option
2. Select install everything at the bottom of the screen that lets you
choose
what to install.
3. Watch it complain about a failed dependency in Canna-libs

Actual Results:
When you follow the steps above, the install program complains that the
package
Canna-devel requires Cann-lib to install and asks if you want to: 1.
Install
packages to resolve dependencies, 2. Do not install this package
(Canna-devel),
or 3. Ignore dependencies.  The first option is the default, and this will
cause
both of those packages to be installed, so the workaround is easy. 
However, in
the list of packages to install when "everything" is selected, Canna-lib
should
be included if Canna-devel is (shouldn't everything mean everything?).

Expected Results:
Installation should not return an error about failed dependencies.

Contact Information:
Paul Larson
plars@austin.ibm.com
(512) 838-9303

Additional Information:



------- Additional Comments From Khoa Huynh(khoa@us.ibm.com) 2001-06-04
13:57 -------

Paul, there is probably a reason for not including Canna-lib even when you
specified "everything" -- perhaps this Canna-lib is not needed in most
cases with Cana-dev and installing it would take too much disk space
(that's why there is option #3 where you can ignore the dependencies).
After all, you selected "Custom" installation so the system assumes that 
you know what you are doing.  However, this is a fair question to ask 
Red Hat....it may be an oversight....I don't know....
Comment 1 Bill Nottingham 2001-06-06 18:47:49 EDT
This is an old, fixed bug. the 0529 isos are somewhat bogus. (it's actually
the wolverine tree.)

*** This bug has been marked as a duplicate of 36860 ***

Note You need to log in before you can comment on or make changes to this bug.