Bug 437552 - traceback - ixf86configmodule.so: undefined symbol: xf86freeInputrefList
traceback - ixf86configmodule.so: undefined symbol: xf86freeInputrefList
Status: CLOSED DUPLICATE of bug 437236
Product: Fedora
Classification: Fedora
Component: pyxf86config (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Adam Jackson
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-03-14 16:44 EDT by Michael Schwendt
Modified: 2008-03-17 16:48 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-03-17 16:48:15 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michael Schwendt 2008-03-14 16:44:13 EDT
Recent updates in rawhide disabled my German keyboard
layout setting. Upon trying to run system-config-keyboard and
clicking OK, I see the following traceback:

Loading /lib/kbd/keymaps/i386/qwertz/de-latin1-nodeadkeys.map.gz
Traceback (most recent call last):
  File "/usr/share/system-config-keyboard/keyboard_gui.py", line 223, in _okClicked
    return self.apply(None, False)
  File "/usr/share/system-config-keyboard/keyboard_gui.py", line 117, in apply
    keyboardBackend.modifyXconfig(fullname, layout, model, variant, options)
  File "/usr/share/system-config-keyboard/keyboard_backend.py", line 32, in modifyXconfig
    import xf86config
  File "/usr/lib/python2.5/site-packages/xf86config.py", line 1, in <module>
    import ixf86config
ImportError: /usr/lib/python2.5/site-packages/ixf86configmodule.so: undefined sy

pyxf86config-0.3.36-1.fc9.i386
Comment 1 Michael Schwendt 2008-03-14 17:05:07 EDT
ImportError: /usr/lib/python2.5/site-packages/ixf86configmodule.so: undefined
symbol: xf86freeInputrefList

(AltGr has become Enter here, cursor keys are dead, so typing things in is hard)
Comment 2 Michael Schwendt 2008-03-17 16:48:15 EDT

*** This bug has been marked as a duplicate of 437236 ***

Note You need to log in before you can comment on or make changes to this bug.