Bug 437573 - loader segv after DHCP when using 'ip=dhcp ipv6=auto method=http://...'
loader segv after DHCP when using 'ip=dhcp ipv6=auto method=http://...'
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
i386 Linux
low Severity low
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-03-14 18:22 EDT by Will Woods
Modified: 2008-08-02 19:40 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-03-19 16:06:45 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Will Woods 2008-03-14 18:22:09 EDT
loader in today's rawhide (20080314, anaconda-11.4.0.52-1) will crash when
booted with the following commandline: 

  ip=dhcp ipv6=auto method=http://[url]

It gets a SIGSEGV right after attempting to fetch stage2.img. It works fine if
you're booting from boot.iso or other media, because then you have no need to
download stage2.img. 

It still fails if you use 'noipv6'. Manually configuring in the TUI works fine. 

There is no backtrace on tty1; tty4 has:
  loader[464]: segfault at 2fe5b101 ip 00123853 sp bfc93bf4 error 4 in
ld-linux.so.2[110000+1f000]

Interestingly I'm not able to reproduce this crash on x86_64.
Comment 1 Jeremy Katz 2008-03-14 18:58:38 EDT
I just tried that here and X started up fine (x86, inside of qemu)...  nothing
else on your command line?
Comment 2 Will Woods 2008-03-18 11:54:35 EDT
Nope, nothing else. See also bug 437909 - Jesse seems to have hit the same thing in qemu.
Comment 3 David Lehman 2008-03-18 13:56:08 EDT
I'm seeing a loader backtrace on tty1 when I try to use boot.iso from 2008-03-18
w/ http method and http updates.img. Nothing too interesting on tty3 or tty4.
Backtrace points to httpGetFileDesc in loader, then down into libc. This is bare
metal, fwiw.

FWIW, my cmdline is 'ip=dhcp ksdevice=xx:xx:xx:xx:xx:xx noipv6 lang=en_US.UTF-8
keymap=us method=http://192.168.1.100/install/rawhide/os
updates=http://192.168.1.100/install/rawhide/os/images/updates.img'
Comment 4 Will Woods 2008-03-19 16:06:45 EDT
clumens mentions that there was a fix for bug 437909 (ip=dhcp + updates) in
today's rawhide. Can you retest and confirm that bug?

This works fine for me with rawhide-20080319. But I'm not using updates.img.
Comment 5 David Lehman 2008-03-19 18:57:36 EDT
Yeah, it works for me today. Sorry for the delay.

Note You need to log in before you can comment on or make changes to this bug.