Bug 437595 - Cannot create xen rawhide instance
Cannot create xen rawhide instance
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: python-virtinst (Show other bugs)
5.2
All Linux
low Severity low
: ---
: ---
Assigned To: Cole Robinson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-03-14 22:45 EDT by John Poelstra
Modified: 2008-05-21 12:45 EDT (History)
4 users (show)

See Also:
Fixed In Version: RHEA-2008-0371
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-05-21 12:45:45 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Correctly detect rawhide/f9 distro trees (673 bytes, patch)
2008-03-17 09:54 EDT, Cole Robinson
no flags Details | Diff

  None (edit)
Description John Poelstra 2008-03-14 22:45:23 EDT
Description of problem:

Cannot create and install install xen rawhide instance.  Installing Fedora 8
works fine.


Version-Release number of selected component (if applicable):


How reproducible:
100%

Steps to Reproduce:
1. use virt-manager gui
2. setup http install pointing at rawhide tree
3. doesn't work


Additional info:


snake-tree info
http://download.fedora.redhat.com/pub/fedora/linux/development/i386/os
Name         : Fedora development i386 (20080314)
Arch         : i386
Id           : 1205481897.08
Version      : development
Family       : Fedora
Variant      : 
Time         : 2008-03-14 01:04 PDT
URI's        : 
Images       : i386 (kernel, family, timestamp, variant, boot.iso, initrd,
version, arch), xen (kernel, family, timestamp, variant, initrd, version, arch)


Unable to complete install 'exceptions.ValueError Could not find an installable
distribution at
'http://download.fedora.redhat.com/pub/fedora/linux/development/i386/os'
Traceback (most recent call last):
  File "/usr/share/virt-manager/virtManager/create.py", line 611, in do_install
    dom = guest.start_install(False, meter = meter)
  File "/usr/lib/python2.4/site-packages/virtinst/Guest.py", line 811, in
start_install
    self._prepare_install(meter)
  File "/usr/lib/python2.4/site-packages/virtinst/ParaVirtGuest.py", line 56, in
_prepare_install
    self._installer.prepare(guest = self, meter = meter)
  File "/usr/lib/python2.4/site-packages/virtinst/DistroManager.py", line 239,
in prepare
    self._prepare_kernel_and_initrd(guest, distro, meter)
  File "/usr/lib/python2.4/site-packages/virtinst/DistroManager.py", line 209,
in _prepare_kernel_and_initrd
    distro = distro)
  File "/usr/lib/python2.4/site-packages/virtinst/DistroManager.py", line 122,
in acquireKernel
    progresscb=progresscb, distro=distro, scratchdir=scratchdir)
  File "/usr/lib/python2.4/site-packages/virtinst/DistroManager.py", line 101,
in _storeForDistro
    raise ValueError, _("Could not find an installable distribution at '%s'" %
baseuri)
ValueError: Could not find an installable distribution at
'http://download.fedora.redhat.com/pub/fedora/linux/development/i386/os'
'
Comment 1 Jon Stanley 2008-03-14 22:53:41 EDT
reassigning to virt-manager for now...
Comment 2 John Poelstra 2008-03-15 01:49:22 EDT
Could it be that the rawhide tree itself is malformed or necessary files are
missing?  I believe there have been other problems like this.

More info: I'm running RHEL5.2 beta Dom0 and trying to install a xen rawhide
instance (failure described above).  Attempting an F8 (gold) xen install works fine.

Here is a listing of the RHEL5.2 packages for Dom0 (if that is applicable):

$ rpm -qa | egrep 'virt|xen' | sort
kernel-xen-2.6.18-83.el5
kernel-xen-2.6.18-85.el5
libvirt-0.3.3-5.el5
libvirt-python-0.3.3-5.el5
python-virtinst-0.300.2-5.el5
virt-manager-0.5.3-4.el5
virt-viewer-0.0.2-1.el5
xen-3.0.3-56.el5
xen-libs-3.0.3-56.el5
Comment 3 Eduardo Habkost 2008-03-15 09:35:35 EDT
Probably virt-manager is looking for a "Fedora" directory, but it was renamed 
to "Packages", like on bug #273781.
Comment 4 Daniel Berrange 2008-03-15 10:35:52 EDT
This is the same as F8 bug 437217
Comment 5 Daniel Berrange 2008-03-15 10:36:31 EDT
Removing F9 blocker bug, since this is a RHEL 5.2 bug, not a Fedora bug.
Comment 6 Cole Robinson 2008-03-17 09:54:55 EDT
Created attachment 298266 [details]
Correctly detect rawhide/f9 distro trees

Fixes distro detection for f9. Verified this doesn't affect installing f7 or f8
guests from a tree.
Comment 8 Cole Robinson 2008-03-17 10:09:38 EDT
This is a simple fix to enable installing rawhide and f9 guests, which if we
don't fix now we will definitely see a flood of bzs about later. I'm requesting
this as an exception for inclusion in 5.2.
Comment 9 Bill Burns 2008-03-17 10:14:11 EDT
Set dev ack for Cole.
Comment 10 Cole Robinson 2008-03-17 10:26:55 EDT
For further clarification, our package probes an install tree to try and verify
what distro it is, so we know where to look for virt install media. We do this
detection by looking for certain files (for fedora, we would use fedora.css).
Rawhide and eventually f9 no longer carry this fedora.css file, so detection and
installs were failing.

This patch just changes this check to also pass if we find a file .treeinfo,
which is intended to be present in all fedora trees for detections of this type
(so i've been told). The check will fall back to fedora.css if it can't find
treeinfo, so there should be no backwards compatibility issues (I verified this
for f7 and f8). 

For these reasons it is low risk, and any remaining risk would be offset by the
amount of time this would save us in future support. Not to mention it would
look bad if this went out the door without being able to create a rawhide guest :)
Comment 11 Bill Burns 2008-03-18 07:39:11 EDT
Restore flags cleared by mistake.
Comment 13 Cole Robinson 2008-03-18 15:50:34 EDT
Fix built in python-virtinst-0.300.2-7.el5:

Build                                     Tag                   Built by
----------------------------------------  --------------------  ----------------
python-virtinst-0.300.2-7.el5             dist-5E-qu-candidate  crobinso
Comment 16 errata-xmlrpc 2008-05-21 12:45:45 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHEA-2008-0371.html

Note You need to log in before you can comment on or make changes to this bug.