Bug 437804 - Module::CoreList does not support perl version 5.010000
Module::CoreList does not support perl version 5.010000
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: cpanspec (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Steven Pritchard
Fedora Extras Quality Assurance
:
Depends On: 437817
Blocks:
  Show dependency treegraph
 
Reported: 2008-03-17 10:47 EDT by Ralf Corsepius
Modified: 2008-05-13 11:21 EDT (History)
1 user (show)

See Also:
Fixed In Version: 1.75-1.fc9
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-05-13 11:21:11 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Ralf Corsepius 2008-03-17 10:47:00 EDT
Description of problem:
cpanspec is broken when being used with perl-5.10 (fc9)

# cpanspec --packager foo -o -s Test
Module::CoreList does not support perl version 5.010000!
Version-Release number of selected component (if applicable):


How reproducible:
Always.

Steps to Reproduce:
1. cf. above

Expected results:
function.

Additional info:
AFAIS, the culprit is http://rt.cpan.org/Public/Bug/Display.html?id=32047
i.e. Module::CoreList's silly versioning.

This breaks cpanspec's "$Module::CoreList::version{$]}" because
in cpanspec $] expands to 5.010000 (trailing zeros),
while the keys in CoreList are floats (They expect 5.01).

Cf. /usr/bin/corelist -v 's output:
$ corelist -v
...
5.01
...

Though I think, the actual bug to be in Module::CoreList, this hack below would
get cpanspec going again:

-- /usr/bin/cpanspec~      2008-03-17 15:43:41.000000000 +0100
+++ /usr/bin/cpanspec       2008-03-17 15:43:41.000000000 +0100
@@ -563,7 +563,7 @@
 }
 
 die "Module::CoreList does not support perl version $]!\n"
-    if (!exists($Module::CoreList::version{$]}));
+    if (!exists($Module::CoreList::version{$] + 0 }));
 
 my @args=@ARGV;
 my @processed=();
Comment 1 Steven Pritchard 2008-03-17 17:45:34 EDT
Fixed in cpanspec-1.74-3.fc9.
Comment 2 Fedora Update System 2008-05-06 09:44:03 EDT
cpanspec-1.75-1.fc9 has been submitted as an update for Fedora 9
Comment 3 Fedora Update System 2008-05-13 11:21:07 EDT
cpanspec-1.75-1.fc9 has been pushed to the Fedora 9 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.