Bug 437910 - anaconda graphical startup fails on thinkpad t61 with intel x3100
Summary: anaconda graphical startup fails on thinkpad t61 with intel x3100
Status: CLOSED DUPLICATE of bug 429183
Alias: None
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-i810   
(Show other bugs)
Version: rawhide
Hardware: x86_64
OS: Linux
low
high
Target Milestone: ---
Assignee: Adam Jackson
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-03-18 04:10 UTC by Paul Walmsley
Modified: 2018-04-11 18:06 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-03-26 15:53:55 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
X server startup log at anaconda start (16.58 KB, text/plain)
2008-03-18 20:05 UTC, Paul Walmsley
no flags Details
X server config used by anaconda (980 bytes, application/octet-stream)
2008-03-18 20:06 UTC, Paul Walmsley
no flags Details

Description Paul Walmsley 2008-03-18 04:10:00 UTC
Description of problem:
Fedora 9's graphical installer displays a garbled image upon startup on a new
Thinkpad T61 with Intel X3100 on-board graphics.  The X server starts in
low-resolution mode as expected; the X cursor is displayed correctly; but the
window and button display is completely garbled and unusable.

Version-Release number of selected component (if applicable):
Fedora 9

How reproducible:
Attempt to install Fedora 9 with the graphical installer.

Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:

Comment 1 Matěj Cepl 2008-03-18 13:42:19 UTC
There is no Fedora 9 released. So what excatly you are trying to install? Fedora
9 Alpha or the current Rawhide? What button display? Sorry, I really don't
understand what is the problem.

Please attach your X server config file (/etc/X11/xorg.conf) and X server log
file (/var/log/Xorg.*.log) to the bug report as individual uncompressed file
attachments using the bugzilla file attachment link below.

Could you please also try to run without any /etc/X11/xorg.conf whatsoever and
let X11 autodetect your display and video card? Attach to this bug
/var/log/Xorg.0.log from this attempt as well, please.

We will review this issue again once you've had a chance to attach this information.

Thanks in advance.

Comment 2 Paul Walmsley 2008-03-18 19:42:29 UTC
It's Fedora 9 alpha.  The "window and button display" simply refers to whatever
Anaconda displays after the X server launches.  Clicking in the region of the
buttons on the bottom-right corner of the screen changes the pattern on the
screen in a way that is clear that a window is being displayed, but whatever is
displayed in the window is illegible.  

It should be noted that after a text-mode install, when a user logged in via the
text console starts X with 'startx', X comes up perfectly via the Intel X
drivers.   So this is likely some sort of VESA fb driver issue.

This is, by the way, with the 1400x1050 14" screen on this model.

I will see if it is possible to obtain the log information you request; however,
it may not be possible due to the limited system environment present during
Anaconda startup.


Comment 3 Paul Walmsley 2008-03-18 20:05:45 UTC
Created attachment 298446 [details]
X server startup log at anaconda start

Comment 4 Paul Walmsley 2008-03-18 20:06:34 UTC
Created attachment 298447 [details]
X server config used by anaconda

Comment 5 Paul Walmsley 2008-03-18 20:10:05 UTC
The configuration file and log that you requested are now attached.  Note that
it is using the Intel X driver.

Comment 6 Joseph William Baker 2008-03-21 05:50:52 UTC
I have a similar problem on an MT6920 Gateway Notebook which also has the "Intel
Graphics Media Accelerator X3100".
I'm running the "Fedora 9-Alpha disc ALL" for X86-64 DVD image I downloaded
March 20, 2008.
I tried to run the validation test of the media and it stalled early on without
making progress.
Installing via text mode, then re-booting, yeilded a text only login prompt.




Comment 7 Paul Walmsley 2008-03-21 16:51:17 UTC
Joseph, you are describing a different problem - see bug 437911.  

Comment 8 Nicu Buculei 2008-03-26 14:40:42 UTC
It seems to be the same as #438969, #438952 and #436746 and it happens not only
on Anaconda but also on boot from Live CD.

Comment 9 Bill Nottingham 2008-03-26 15:53:55 UTC

*** This bug has been marked as a duplicate of 429183 ***


Note You need to log in before you can comment on or make changes to this bug.