Bug 429183 - (X320x200) i965 does not render correctly in anaconda/livecd
i965 does not render correctly in anaconda/livecd
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-i810 (Show other bugs)
9
All Linux
low Severity low
: ---
: ---
Assigned To: Adam Jackson
Fedora Extras Quality Assurance
:
: 436746 437910 438952 439149 439377 442940 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-01-17 15:00 EST by Bill Nottingham
Modified: 2014-03-16 23:11 EDT (History)
12 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-10-24 15:20:23 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
screenshot! (174.02 KB, image/jpeg)
2008-01-17 15:00 EST, Bill Nottingham
no flags Details
your standard anaconda X config (745 bytes, text/plain)
2008-01-17 15:02 EST, Bill Nottingham
no flags Details
log. neither big, nor heavy, nor wood (18.05 KB, text/plain)
2008-01-17 15:02 EST, Bill Nottingham
no flags Details
anaconda log (13.27 KB, text/plain)
2008-03-28 13:04 EDT, IBM Bug Proxy
no flags Details
syslog (391.72 KB, text/plain)
2008-03-28 13:04 EDT, IBM Bug Proxy
no flags Details
X server log (18.97 KB, text/plain)
2008-03-28 13:04 EDT, IBM Bug Proxy
no flags Details
Script to build a new F9 beta DVD ISO that works correctly with i965 gfx (3.60 KB, application/x-shellscript)
2008-04-03 14:11 EDT, Paul Walmsley
no flags Details
dmesg output (34.09 KB, text/plain)
2008-04-17 15:08 EDT, Adriano Del Vigna
no flags Details
Another X server log (19.63 KB, text/plain)
2008-04-17 15:09 EDT, Adriano Del Vigna
no flags Details
screenshot 1 (100.76 KB, image/png)
2008-04-18 10:42 EDT, Bill Nottingham
no flags Details
screenshot 2 (65.28 KB, image/png)
2008-04-18 10:43 EDT, Bill Nottingham
no flags Details
register dump when booted from grub (8.30 KB, text/plain)
2008-05-08 18:02 EDT, Bill Nottingham
no flags Details
register dump when booted from isolinux (8.30 KB, text/plain)
2008-05-08 18:02 EDT, Bill Nottingham
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
FreeDesktop.org 15012 None None None Never

  None (edit)
Description Bill Nottingham 2008-01-17 15:00:31 EST
Description of problem:

I booted today's rawhide. X is... weird.

Best description is as if the screen has been scaled to 320x200, no dithering.
It's actually running at the right resolution, though. Progress bars look
normal, but icons/images and fonts most assuredly do not.

i965, attached to Dell 2005FPW, via DVI.

Version-Release number of selected component (if applicable):

rawhide-20080117
Comment 1 Bill Nottingham 2008-01-17 15:00:31 EST
Created attachment 292055 [details]
screenshot!
Comment 2 Bill Nottingham 2008-01-17 15:02:14 EST
Created attachment 292056 [details]
your standard anaconda X config
Comment 3 Bill Nottingham 2008-01-17 15:02:58 EST
Created attachment 292057 [details]
log. neither big, nor heavy, nor wood
Comment 4 Bill Nottingham 2008-01-21 16:39:09 EST
Option "AccelMethod" "XAA" fixes it post-install. Presumably it would fix it
during install as well.
Comment 5 Bill Nottingham 2008-01-29 14:05:26 EST
In testing, this either requires (IIRC) EXA + DRI, or XAA + NoDRI, to work.
Comment 6 Bill Nottingham 2008-03-14 11:57:21 EDT
Still happens in rawhide-20080314.
Comment 7 Bill Nottingham 2008-03-26 11:53:57 EDT
*** Bug 437910 has been marked as a duplicate of this bug. ***
Comment 8 Bill Nottingham 2008-03-26 11:54:14 EDT
*** Bug 438952 has been marked as a duplicate of this bug. ***
Comment 9 Bill Nottingham 2008-03-26 11:54:40 EDT
*** Bug 436746 has been marked as a duplicate of this bug. ***
Comment 10 Matěj Cepl 2008-03-27 11:04:17 EDT
*** Bug 439149 has been marked as a duplicate of this bug. ***
Comment 11 Matěj Cepl 2008-03-27 11:07:31 EDT
*** Bug 439149 has been marked as a duplicate of this bug. ***
Comment 12 Matěj Cepl 2008-03-28 12:58:17 EDT
*** Bug 439377 has been marked as a duplicate of this bug. ***
Comment 13 IBM Bug Proxy 2008-03-28 13:04:30 EDT
=Comment: #0=================================================
Zhen Gang Li <lizg@cn.ibm.com> - 2008-03-26 22:19 EDT
Fedora 9 beta install DVD disc inserted to a Lenovo desktop. In the graphic
installer mode, the screen is white blank, with the cursor icon on it. All text
and graphics are not visible. Cursor icon is responsive to mouse movement.

Found only a Lenovo desktop with the following config:
Machine type: 8810-BK7
Cpu type: IA-32 (Intel Core 2 Duo 6300 1.86GHz)
System has an NTFS windows partition and a previous OpenSUSE 10.3 install on
two ext3 partition.

Is this reproducible?
Yes. But only on a desktop with the mentioned config.

Describe the steps:
1. Boot the Fedora 9 DVD disc, select the default install mode (not the text
mode)
2. Wait till the graphics installer starts
3. The screen will be white blank.

Is the system (not just the application) hung?
No, Cursor icon is responsive to mouse movement.

=Comment: #3=================================================
Cijurajan Kollanoor <cijurajan@in.ibm.com> - 2008-03-27 06:51 EDT
Zhen,
Had you seen the same problem in any of the previous Fedora versions?
Could you see any error messages in any of the console? If yes, please attach
it to the bugzilla report.
=Comment: #4=================================================
Zhen Gang Li <lizg@cn.ibm.com> - 2008-03-28 01:49 EDT
I inserted a Fedora 8 DVD install disc. It displays a correct welcome graphic
screen.
F9 install doesn't have any error log on the console screen. Because it's X
window related, I attached the /tmp/X.log together with syslog & anaconda.log here.
=Comment: #5=================================================
Zhen Gang Li <lizg@cn.ibm.com> - 2008-03-28 01:50 EDT

X server log

=Comment: #6=================================================
Zhen Gang Li <lizg@cn.ibm.com> - 2008-03-28 01:51 EDT

syslog

=Comment: #7=================================================
Zhen Gang Li <lizg@cn.ibm.com> - 2008-03-28 01:52 EDT

anaconda log

=Comment: #9=================================================
Zhen Gang Li <lizg@cn.ibm.com> - 2008-03-28 02:32 EDT
Yes. That's where I copied the log files (from Ctrl-Alt-F2 console). No extra
error messages.

*** This bug has been marked as a duplicate of 429183 ***
Comment 14 IBM Bug Proxy 2008-03-28 13:04:36 EDT
Created attachment 299495 [details]
anaconda log
Comment 15 IBM Bug Proxy 2008-03-28 13:04:39 EDT
Created attachment 299496 [details]
syslog
Comment 16 IBM Bug Proxy 2008-03-28 13:04:41 EDT
Created attachment 299497 [details]
X server log
Comment 17 Jacek Pliszka 2008-03-31 18:59:29 EDT
How could it have priority low?

With huge number of notebooks with X3100 on the market F9 should not be released
with this bug! A lot of users won't be able to install with GUI and will
switch to other distros.


Comment 18 Matěj Cepl 2008-04-01 18:04:52 EDT
*** Bug 440037 has been marked as a duplicate of this bug. ***
Comment 19 Paul Walmsley 2008-04-02 23:27:17 EDT
The same bug exists in Fedora 9 beta.
Comment 20 Matěj Cepl 2008-04-03 02:54:02 EDT
*** Bug 440186 has been marked as a duplicate of this bug. ***
Comment 21 Matěj Cepl 2008-04-03 02:56:00 EDT
Bug 440186 is from ATI, so I tend to blame the server itself. Reassigning.
Comment 22 Paul Walmsley 2008-04-03 11:15:49 EDT
Matej, bug 440186 looks like a very different bug.  440186 didn't occur during
Anaconda install; DRI loaded correctly; it's using XAA acceleration rather than
EXA; and it's not on an Intel chip, unlike all of the other bug reports.
Comment 23 Paul Walmsley 2008-04-03 14:11:20 EDT
Created attachment 300296 [details]
Script to build a new F9 beta DVD ISO that works correctly with i965 gfx
Comment 24 Paul Walmsley 2008-04-03 14:14:03 EDT
The attached f9fix.sh script will modify the F9 beta DVD ISO to add the
"AccelMethod XAA" directive to the X configuration file during Anaconda launch.
 This allows graphical installs to start successfully on my Thinkpad T61 8897
with i965/X3100 graphics.

The script has only been tested with the x86_64 ISO.  However, there is an
attempt in the code to make it work for 32-bit installs.  To run it, you will
need about 10GiB of free disk space to build the new ISO image.

The script is just a hack to get the installer working.  Based on the
information in this bug, it looks like the real fix is to modify the Intel X
driver to fall back to XAA if the DRI module doesn't load.   But, I am not so
masochistic as to try to set up a cross-compiled x86_64 X development
environment from scratch here.





Comment 25 Bill Nottingham 2008-04-08 17:12:26 EDT
This is actually much better with the current intel driver and EXA. 
Comment 26 IBM Bug Proxy 2008-04-11 02:49:07 EDT
------- Comment From lizg@cn.ibm.com 2008-04-11 02:47 EDT-------
Sorry, I don't have that much of free space on my workstations. Is there
anyway that can update the disk content without having regenerate the iso
itself. I was thinkin of changing the file after the iso is booted. But I
don't have a clue where to pause the norml start process.
Comment 27 Rex Dieter 2008-04-17 15:00:39 EDT
*** Bug 442940 has been marked as a duplicate of this bug. ***
Comment 28 Adriano Del Vigna 2008-04-17 15:07:12 EDT
I'm having the same problem. Just created 442940. I'll post my dmesg and Xorg
log trying to help guys.
Comment 29 Adriano Del Vigna 2008-04-17 15:08:29 EDT
Created attachment 302785 [details]
dmesg output

Another dmesg sample. Hope it helps somehow.
Comment 30 Adriano Del Vigna 2008-04-17 15:09:54 EDT
Created attachment 302786 [details]
Another X server log

One more X server log...
Comment 31 Bill Nottingham 2008-04-18 10:42:16 EDT
Rebuilding the current intel driver with EXA and rebuilding the installer image
yields the following.
Comment 32 Bill Nottingham 2008-04-18 10:42:46 EDT
Created attachment 302889 [details]
screenshot 1
Comment 33 Bill Nottingham 2008-04-18 10:43:11 EDT
Created attachment 302890 [details]
screenshot 2
Comment 34 Adriano Del Vigna 2008-04-18 13:02:09 EDT
Bill,

Definetly an improvement, nice work.

Googling around, look what I found:
http://cworth.org/tag/i965/

Perhaps a brief email to Carl Worth may help us? He does have a @redhat email...
Comment 35 Jeremy Katz 2008-04-29 16:23:22 EDT
Bill - how are things looking now?
Comment 36 Bill Nottingham 2008-04-30 11:20:11 EDT
Identical to comment #32/#33.
Comment 37 Bill Nottingham 2008-04-30 12:09:37 EDT
The liveCD is similar. The installation from the liveCD is normal. This is where
I'm confused.
Comment 38 Adriano Del Vigna 2008-04-30 15:54:23 EDT
Bill, I got the problem while running the installation from LiveCD. Check bug
#442940 for a report.
Comment 39 Bill Nottingham 2008-05-02 15:36:41 EDT
No, what I mean is *once you have finished installing* the system from the
liveCD, it's OK.

Given that, and that the display is navigable, I'm not considering this a
release blocking issue at this point. Moving to target.
Comment 40 Bill Nottingham 2008-05-07 17:34:23 EDT
However, just to document:

- the livecd renders in the way shown in the above graphics
- an install from such a livecd renders correctly

Comparing the Xorg.0.logs from the two cases shows *zero* differences.
Comment 41 Bill Nottingham 2008-05-07 17:45:50 EDT
Aaaaaaand for the clincher.

If the 'installed' system (which normally renders correctly) is booted from
isolinux instead of from grub, the rendering artifacts show up.

No, I do not know why.
Comment 42 Bill Nottingham 2008-05-08 11:59:59 EDT
If isolinux is booted without the VESA graphical menu, it also renders normally.
Comment 43 Bill Nottingham 2008-05-08 12:46:16 EDT
Jesse Barnes implies that even though this is triggered by the bootloader
change, it is still a driver issue, as it's not fully initializing the 3D state
needed for render accel, and is inheriting bad stuff from the BIOS. Back to the
driver.
Comment 44 Bill Nottingham 2008-05-08 18:02:27 EDT
Created attachment 304907 [details]
register dump when booted from grub

Here's the working register dump.
Comment 45 Bill Nottingham 2008-05-08 18:02:59 EDT
Created attachment 304908 [details]
register dump when booted from isolinux

Here's the register dump when it doesn't work.
Comment 46 Bug Zapper 2008-05-14 00:48:05 EDT
Changing version to '9' as part of upcoming Fedora 9 GA.
More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 47 Ignacio Vazquez-Abrams 2008-05-15 18:03:16 EDT
This can be resolved on a USB key with the following:
- Copy /usr/lib/syslinux/menu.c32 to syslinux/ on the key
- Make the following changes to syslinux/syslinux.cfg on the key:
 * Modify the line starting with "default" to read "default menu.c32"
 * Comment out or remove the line starting with "menu background"
Comment 48 William Lovaton 2008-05-19 09:53:34 EDT
Just wanted to say that I have the same problem with the final release.  I
tested the previuos beta releases and never saw this problem.

It's a relieve to know that it works fine after doing a final installation on
the hard drive.

For me lspci shows the following:
00:02.0 VGA compatible controller: Intel Corporation 82Q963/Q965 Integrated
Graphics Controller (rev 02)
Comment 49 Bill Nottingham 2008-10-24 15:20:23 EDT
This is fixed in F10. I don't recall *what* release of the driver fixed this, but it is fixed.

Note You need to log in before you can comment on or make changes to this bug.