Bug 437943 - Xserver fails to configure itself correctly for Tiger4 systems
Xserver fails to configure itself correctly for Tiger4 systems
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: xorg-x11-server (Show other bugs)
ia64 Linux
high Severity high
: rc
: ---
Assigned To: Dave Airlie
: Regression
: 439180 (view as bug list)
Depends On:
  Show dependency treegraph
Reported: 2008-03-18 07:12 EDT by Adam Stokes
Modified: 2010-10-22 19:19 EDT (History)
4 users (show)

See Also:
Fixed In Version: RHBA-2008-0446
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2008-05-21 12:56:45 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)
xorg errors (924 bytes, text/plain)
2008-03-18 07:12 EDT, Adam Stokes
no flags Details
xorg log (104.28 KB, text/plain)
2008-03-19 13:07 EDT, Adam Stokes
no flags Details
xorg logs from backed-out test (103.64 KB, text/plain)
2008-04-01 18:49 EDT, Gary Case
no flags Details
fix the rom reading code to fallback to the older methods. (1.44 KB, patch)
2008-04-01 21:51 EDT, Dave Airlie
no flags Details | Diff

  None (edit)
Description Adam Stokes 2008-03-18 07:12:30 EDT
Description of problem:
Unable to do graphic installations during 5.2 beta -- uses ATI Rage XL

Version-Release number of selected component (if applicable):
Problem in 20080313.1 tree.

How reproducible:

Steps to Reproduce:
1. Attempt to install system
Actual results:
What happens in the 5.2 betas is that the video image is small and dim on the
screen and rolls so fast you can't make out any of the text. It looks like it's
using the wrong resolution for this monitor (really old Tatung CM15UHE 15" tube

Expected results:
Able to see installer

Additional info:
Does not occur on 5.1
Comment 1 Adam Stokes 2008-03-18 07:12:30 EDT
Created attachment 298371 [details]
xorg errors
Comment 2 Matěj Cepl 2008-03-18 13:29:24 EDT
Could you please attach /var/log/anaconda.xlog please as an uncompressed
attachment to this bug?

Thank you.
Comment 3 Issue Tracker 2008-03-18 20:06:43 EDT
I don't have an anaconda.xlog on this system. I had to do the install in
text mode for it to work.

Internal Status set to 'Waiting on SEG'

This event sent from IssueTracker by gcase 
 issue 168997
Comment 4 Matěj Cepl 2008-03-19 11:42:19 EDT
Could you try to do login in graphical and let if fails before any actual
installation (and repartitioning and wiping up the drivers) actually happens?
Comment 6 Issue Tracker 2008-03-19 12:05:30 EDT
I can start a graphical installation or start X with 'init 5' or
'startx', but it doesn't display correctly. It's too garbled for me to
do anything. I'm attaching the Xorg.0.log file from a running X session,
in case that's helpful.

This event sent from IssueTracker by gcase 
 issue 168997
it_file 124481
Comment 7 Adam Stokes 2008-03-19 13:07:15 EDT
Created attachment 298541 [details]
xorg log
Comment 9 Dave Airlie 2008-03-31 21:55:13 EDT
dev_ack+, this could be an X server or kernel bug but needs investigation, lets
start with assuming the server broke.
Comment 10 Dave Airlie 2008-03-31 22:34:53 EDT
can we get an X.org log from 5.1 with this working if possible?

I'm trying to track down where it might have gone wrong.
Comment 13 Issue Tracker 2008-04-01 17:23:40 EDT
Here's the 5.1 working logs (in a sosreport).

This event sent from IssueTracker by gcase 
 issue 168997
it_file 126580
Comment 14 Issue Tracker 2008-04-01 17:29:32 EDT
Just to be safe, I've confirmed that 5.1 allows me to boot up in runlevel
5 as well as run 'startx'. I don't know why this wouldn't have worked,
I just wanted to test that too.

This event sent from IssueTracker by gcase 
 issue 168997
Comment 16 Gary Case 2008-04-01 18:49:56 EDT
Created attachment 299985 [details]
xorg logs from backed-out test
Comment 18 Dave Airlie 2008-04-01 21:40:12 EDT
*** Bug 439180 has been marked as a duplicate of this bug. ***
Comment 19 Dave Airlie 2008-04-01 21:51:05 EDT
Created attachment 300001 [details]
fix the rom reading code to fallback to the older methods.
Comment 20 Dave Airlie 2008-04-01 22:00:17 EDT
the latest scratch build from me in brew should have the fix, hopefully the
blocker person turns up so I can actually check this in.
Comment 27 Cameron Meadors 2008-04-16 14:25:09 EDT
Verified per comment #26
Comment 28 Keve Gabbert 2008-04-16 15:52:20 EDT
Dom0 startx still fails. 

info from Issue Tracker:
 Issue #168997 ([REGRESSION] RHEL5.2 installation and Dom0 can not startX in 
Tiger4 system.)[Intel]

Previous Events:
Posted 04-16-2008 09:26am by yongkang.you

How is this bug?
We test snapshot4 88.el5 in Tiger4. The install has graphic. But Dom0
startx still fail. 

I uploaded the Xorg log. 

Posted 04-16-2008 09:26am by yongkang.you
File uploaded: Xorg.0.log
Comment 29 Issue Tracker 2008-04-16 20:29:51 EDT
I just installed RHEL5.2 beta -88.el5 kernel and updated to snapshot 5
(-89.el5 kernel). Snapshot 5 isn't available due to an anaconda problem
that prevents installation, but snapshot 6 will be available soon. The
system did boot into runlevel 5 with the xen kernel on my tiger4 box, BUT
there was one modification I had to make:

When I installed, I did so in text mode. When the installation was
complete, I dropped to the console (ctrl-alt-F2), went into
/mnt/sysimage/boot/efi/efi/redhat and edited the elilo.conf file. I needed
to add "console=tty" to the "append" line for the xen kernel, otherwise
I got no console access at all when the system booted post-install. That
bug's being tracked here:


I'm going to install the same snapshot you used (I won't update this
time) and see what happens.

This event sent from IssueTracker by gcase 
 issue 168997
Comment 30 Issue Tracker 2008-04-16 20:57:13 EDT
I was able to do an installation of the -88.el5 kernel snapshot on my
tiger4 with only the "console=tty" change I mentioned earlier. Graphical
installation worked and so did booting into runlevel5 with the Xen kernel.

This event sent from IssueTracker by gcase 
 issue 168997
Comment 33 errata-xmlrpc 2008-05-21 12:56:45 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.


Note You need to log in before you can comment on or make changes to this bug.