Bug 437972 - Additional repository glitch
Additional repository glitch
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
9
All Linux
low Severity low
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
:
Depends On:
Blocks: F10Blocker/F10FinalBlocker
  Show dependency treegraph
 
Reported: 2008-03-18 10:26 EDT by Matthias Clasen
Modified: 2008-09-30 11:55 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-09-30 11:55:36 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Matthias Clasen 2008-03-18 10:26:23 EDT
When I open the "Edit Repository" dialog for "Additional Fedora Software", and
press OK, 

- it unnecessarily downloads stuff (I didn't make any changes in the dialog)

- I get a warning that says: "Unable to find a group file for
AdditionalFedoraSoftware. This will prevent manual selection of packages from
the repository from working.

Note the missing spaces in AddionalFedoraSoftware. Also, this warning should not
happen at all for a repository which is already in the screen when I first enter
it...
Comment 1 Chris Lumens 2008-03-24 14:46:35 EDT
I've committed some stuff that should help us be a little smarter about
downloading repo metadata.  However, a few things to note:  if you don't want it
to try downloading new metadata, click Cancel instead of OK.  On the other hand,
this stuff should be cached so it shouldn't be pulling down new metadata, only
checking to see if it needs to.  The warning is most likely due to the fact that
this is a test release and not a final release, so we can't get a valid
mirrorlist for it.
Comment 2 Jesse Keating 2008-04-03 15:11:41 EDT
Looks like this just needs a simple re-testing.
Comment 3 Jon Stanley 2008-04-14 12:39:48 EDT
Still downloads new metadata in this instance, and does not attempt to download
comps, resulting in the 'unable to find group file' message.

192.168.1.137 - - [14/Apr/2008:12:32:13 -0400] "GET
/fedora/development/i386/os/repodata/repomd.xml HTTP/1.1" 200 2424 "-"
"urlgrabber/3.0.0 yum/3.2.14"
192.168.1.137 - - [14/Apr/2008:12:32:13 -0400] "GET
/fedora/development/i386/os/repodata/primary.sqlite.bz2 HTTP/1.1" 200 6411510
"-" "urlgrabber/3.0.0 yum/3.2.14"
192.168.1.137 - - [14/Apr/2008:12:32:17 -0400] "GET
/fedora/development/i386/os/repodata/comps.xml.gz HTTP/1.1" 200 304708 "-"
"urlgrabber/3.0.0 yum/3.2.14"
----------- clicked modify then OK on Additional Fedora Software ------------
192.168.1.137 - - [14/Apr/2008:12:34:44 -0400] "GET
/fedora/development/i386/os/repodata/repomd.xml HTTP/1.1" 200 2424 "-"
"urlgrabber/3.0.0 yum/3.2.14"
192.168.1.137 - - [14/Apr/2008:12:34:44 -0400] "GET
/fedora/development/i386/os/repodata/primary.sqlite.bz2 HTTP/1.1" 200 6411510
"-" "urlgrabber/3.0.0 yum/3.2.14"
Comment 4 Jon Stanley 2008-04-14 12:43:11 EDT
I also really don't think that this is a blocker, since it's a use case that is
basically a mis-use of the UI that causes some undesired results.  Thoughts?
Comment 5 Matthias Clasen 2008-04-14 13:08:04 EDT
Mis-use of the ui ? I don't agree with that. 

But I'm fine with moving htis off the blocker list
Comment 6 Jon Stanley 2008-04-14 14:45:18 EDT
Moving to F10 so we don't forget.
Comment 7 Bug Zapper 2008-05-14 02:40:55 EDT
Changing version to '9' as part of upcoming Fedora 9 GA.
More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 8 Chris Lumens 2008-08-06 15:04:44 EDT
This is worth a re-test since much more work has gone on in this area yet again for F10.

Note You need to log in before you can comment on or make changes to this bug.