Bug 438074 - ext3->ext4 migration does not mount as ext4 at install time
ext3->ext4 migration does not mount as ext4 at install time
Status: CLOSED DUPLICATE of bug 440055
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
9
All Linux
low Severity low
: ---
: ---
Assigned To: Jeremy Katz
Fedora Extras Quality Assurance
:
Depends On:
Blocks: F10Blocker/F10FinalBlocker
  Show dependency treegraph
 
Reported: 2008-03-18 17:33 EDT by Eric Sandeen
Modified: 2008-05-28 16:25 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-05-28 16:25:49 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Eric Sandeen 2008-03-18 17:33:58 EDT
I looked at this just a bit myself but got lost in python.  :)

It looks like if I select an ext3->ext4 migration during an upgrade, the
filesystem gets properly flagged as test_fs, and the fstab gets set as ext4dev,
but the filesystem is still mounted as ext3 when the upgrade begins to install
packages.  It'll mount as ext4dev when I reboot, but all the new files will be
ext3-formatted.

This may be because blkid still reports it as ext3?  Since there is no
extent-based file on the system yet, it would, prior to any new write.

I couldn't tell for sure if there was a simple way on migration to specify that
it should be mounted as the new (migrated) fs type...

Or maybe I'll get tune2fs to set the extents flag so that blkid reports the
device as having ext4...
Comment 1 Jeremy Katz 2008-03-18 19:10:05 EDT
Hmmm, I thought I had fixed this up.  Will dig into it, but probably not tonight
Comment 2 Jeremy Katz 2008-04-01 12:24:25 EDT
Not doing migration to ext4 for F9 now
Comment 3 Bug Zapper 2008-05-14 02:42:30 EDT
Changing version to '9' as part of upcoming Fedora 9 GA.
More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 4 Jeremy Katz 2008-05-28 16:25:49 EDT

*** This bug has been marked as a duplicate of 440055 ***

Note You need to log in before you can comment on or make changes to this bug.