Bug 4383 - rpm needs to be recompiled with new file locking routines
rpm needs to be recompiled with new file locking routines
Status: CLOSED DUPLICATE of bug 4272
Product: Red Hat Linux
Classification: Retired
Component: rpm (Show other bugs)
6.0
All Linux
high Severity high
: ---
: ---
Assigned To: Jeff Johnson
:
: 4393 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 1999-08-05 17:21 EDT by tpavlic
Modified: 2008-05-01 11:37 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 1999-08-31 19:35:33 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description tpavlic 1999-08-05 17:21:03 EDT
rpm looks like it has been compiled with the old file
locking routines from the pre-2.1.x libraries. Because of
this, it cannot write to any of my NFS shares.

This is becoming a very tedious problem. This is the
*THIRD* program I've found in RH6.0 that has not been
compiled with the RH6.0 libraries! sendmail and elm are the
two other programs. I had to recompile them myself in order
to get them to work. (elm wouldn't work at all -- sendmail
would cause a lockd error every time it sent mail)

If you'd like an easy example of what I'm talking about,
using the elm that comes with RH6.0, on an RH6.0 system,
mount a spool directory via NFS. On the system on which the
NFS share is mounted, run elm. Elm will not be able to get
any locks. Recompile elm and it will be able to read mail
just fine.

Elm is not a big deal, but sendmail and rpm are. Please
release updates to all of your programs that are not
compiled with the new locking routines.
Comment 1 Jeff Johnson 1999-08-06 13:24:59 EDT
*** Bug 4393 has been marked as a duplicate of this bug. ***

In order for RPM to correctly read and write to and from
NFS shres, it needs to be recompiled. The 2.2.x kernel and
the newest libraries have done away with the old file
locking routines. Any program compiled with the old flock
emulation (which has been now COMPLETELY replaced by real
BSD file locking) needs to be recompiled with the new
libraries in order to do locking correclty on NFS shares.
Without recompiling those programs, they will not be able
to lock on an NFS share and usually won't be able to read
or write from or to them.

I've had this problem with elm and sendmail and now rpm.
(I've also had it with non-RedHat stuff like cucipop and
the FrontPage Server Extensions) Everything I recompiled
works fine now, but before I did, it was quite frustrating.

Take a look in the Linux source tree:

linux/Documentation/locks.txt

for information about the new locking scheme.

This is very important that you release updates to all
programs that have this problem. Professional organizations
use NFS often. It's quite tedious if we have to try and
recompile everything that needs it. (Especially in cases
like sendmail, where compiling requires configuration in
order to produce the appropriate binary that has the same
support as the one installed with the RPM)
Comment 2 Jeff Johnson 1999-08-31 19:35:59 EDT
This problem is the same as the sendmail/elm problems so it's going
there.

*** This bug has been marked as a duplicate of 4272 ***

Note You need to log in before you can comment on or make changes to this bug.