Bug 4393 - rpm needs to be recompiled to support new locking scheme -- does not work on NFS shares
rpm needs to be recompiled to support new locking scheme -- does not work on ...
Status: CLOSED DUPLICATE of bug 4383
Product: Red Hat Linux
Classification: Retired
Component: rpm (Show other bugs)
6.0
All Linux
high Severity high
: ---
: ---
Assigned To: Jeff Johnson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 1999-08-06 11:15 EDT by tpavlic
Modified: 2008-05-01 11:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 1999-08-06 13:24:54 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description tpavlic 1999-08-06 11:15:31 EDT
In order for RPM to correctly read and write to and from
NFS shres, it needs to be recompiled. The 2.2.x kernel and
the newest libraries have done away with the old file
locking routines. Any program compiled with the old flock
emulation (which has been now COMPLETELY replaced by real
BSD file locking) needs to be recompiled with the new
libraries in order to do locking correclty on NFS shares.
Without recompiling those programs, they will not be able
to lock on an NFS share and usually won't be able to read
or write from or to them.

I've had this problem with elm and sendmail and now rpm.
(I've also had it with non-RedHat stuff like cucipop and
the FrontPage Server Extensions) Everything I recompiled
works fine now, but before I did, it was quite frustrating.

Take a look in the Linux source tree:

linux/Documentation/locks.txt

for information about the new locking scheme.

This is very important that you release updates to all
programs that have this problem. Professional organizations
use NFS often. It's quite tedious if we have to try and
recompile everything that needs it. (Especially in cases
like sendmail, where compiling requires configuration in
order to produce the appropriate binary that has the same
support as the one installed with the RPM)
Comment 1 Jeff Johnson 1999-08-06 13:24:59 EDT
*** This bug has been marked as a duplicate of 4383 ***

Note You need to log in before you can comment on or make changes to this bug.