Bug 438448 - Sound not working on IBM ThinkPad T23
Sound not working on IBM ThinkPad T23
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
9
i386 Linux
low Severity low
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
: 448298 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-03-20 19:05 EDT by Joachim Frieben
Modified: 2008-08-08 09:02 EDT (History)
2 users (show)

See Also:
Fixed In Version: kernel-2.6.25.14-106.fc9
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-08-03 04:57:44 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
scsconfig.log for IBM ThinkPad T23 (41.65 KB, text/plain)
2008-03-20 19:05 EDT, Joachim Frieben
no flags Details
scsrun.log for IBM ThinkPad T23 (3.06 KB, text/plain)
2008-03-20 19:07 EDT, Joachim Frieben
no flags Details

  None (edit)
Description Joachim Frieben 2008-03-20 19:05:35 EDT
Description of problem:
After starting up an IBM ThinkPad T23 and logging in to a GNOME session,
sound is not working. However, /proc/asound etc. are present. Launching
alsamixer shows the <Master> channel at 86%.

Version-Release number of selected component (if applicable):
pulseaudio-0.9.8-11.fc9

How reproducible:
Always.

Steps to Reproduce:
1. Boot IBM ThinkPad T23.
2. Log in to GNOME session.
3. Enable sound events.
  
Actual results:
No sound.

Expected results:
System sounds are working.

Additional info:
Executing system-config-soundcard and playing the test sound not only
works but afterwards, the sound system as a whole also works until the
system is rebooted. Issue assigned to PulseAudio; it might rather be
an ALSA problem though.
Comment 1 Joachim Frieben 2008-03-20 19:05:35 EDT
Created attachment 298756 [details]
scsconfig.log for IBM ThinkPad T23
Comment 2 Joachim Frieben 2008-03-20 19:07:00 EDT
Created attachment 298757 [details]
scsrun.log for IBM ThinkPad T23
Comment 3 Lubomir Kundrak 2008-03-21 06:08:12 EDT
Is this helpful to you?
http://fedoraproject.org/wiki/LubomirKundrak/SoundTroubleshooting

1.) Does playback via ALSA work?
aplay -D hw:0 /usr/share/sounds/startup3.wav

2.) Does playback via PulseAudio work?
paplay /usr/share/sounds/startup3.wav

3.) What sound hardware do you have?
hal-find-by-capability --capability alsa
lsmod |grep snd
Comment 4 Bug Zapper 2008-05-14 02:46:46 EDT
Changing version to '9' as part of upcoming Fedora 9 GA.
More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 5 Lukáš Kotek 2008-05-21 08:37:41 EDT
I have absolutely the same problem with soudcard on my T23. Soundcard is
detected (at gnome-sound-properties), but there is no sound until I run
system-config-soundcard (from F8 package). After rebooting I have to do the same
procedure to make it work again.

1) I tried if ALSA work, but with no success.
2) The same result like in first case was.
3) hal-find-by-capability --capability alsa:
<pre>
/org/freedesktop/Hal/devices/computer_alsa_timer
/org/freedesktop/Hal/devices/computer_alsa_sequencer
/org/freedesktop/Hal/devices/pci_8086_2485_sound_card_0_alsa_capture_1
/org/freedesktop/Hal/devices/pci_8086_2485_sound_card_0_alsa_playback_0
/org/freedesktop/Hal/devices/pci_8086_2485_sound_card_0_alsa_capture_0
/org/freedesktop/Hal/devices/pci_8086_2485_sound_card_0_alsa_control__1
</pre>
lsmod |grep snd:
<pre>
snd_intel8x0           30492  1 
snd_ac97_codec         94368  1 snd_intel8x0
ac97_bus                5504  1 snd_ac97_codec
snd_seq_dummy           6660  0 
snd_seq_oss            30364  0 
snd_seq_midi_event      9600  1 snd_seq_oss
snd_seq                48448  5 snd_seq_dummy,snd_seq_oss,snd_seq_midi_event
snd_seq_device         10124  3 snd_seq_dummy,snd_seq_oss,snd_seq
snd_pcm_oss            42496  0 
snd_mixer_oss          16768  1 snd_pcm_oss
snd_pcm                67076  3 snd_intel8x0,snd_ac97_codec,snd_pcm_oss
snd_timer              21640  2 snd_seq,snd_pcm
snd                    48312  12
snd_intel8x0,snd_ac97_codec,snd_seq_dummy,snd_seq_oss,snd_seq,snd_seq_device,snd_pcm_oss,snd_mixer_oss,snd_pcm,snd_timer
soundcore               9288  1 snd
snd_page_alloc         11400  2 snd_intel8x0,snd_pcm
</pre>

I also tried  - modprobe snd_intel8x0 - but system-sonfig-soundcard seems to be
only solution.
Comment 6 Martin Stransky 2008-05-22 18:50:32 EDT
If you don't want to use PA for ALSA applications, remove the pulseaudio plugin
from /etc/alsa/alsa.conf (Section "pre-load the configuration files").
Comment 7 Lukáš Kotek 2008-05-24 11:14:55 EDT
I've removed that from alsa.conf, but the problem still persists.
Comment 8 Joachim Frieben 2008-05-30 10:31:00 EDT
Here is a workaround which might point to the root of the problem:

0. Log in to GNOME session - sound does not work.
1. Open gnome-volume-control.
2. Mute the PCM device by clicking the speaker symbol below the sliders.
3. Unmute the PCM device by clicking the speaker symbol again:
   sound works! Only now, 'aplay -D hw:0 /usr/share/sounds/startup3.wav'
   actually emits some hearable sound.

Now, log out from GNOME session and log in again: sound still works.
Reboot system and log in to GNOME session: sound does not work. Go
back to step 1 to make sound work.
Comment 9 Joachim Frieben 2008-06-13 13:36:36 EDT
To be more precise: one also has to modify the volume level of the master
channel either before or afterward to have the mute/unmute procedure take
effect.
Comment 10 Lennart Poettering 2008-06-13 19:30:48 EDT
This seems to be an alsa pronlem then, reassigning.
Comment 11 Joachim Kunze 2008-07-27 12:09:02 EDT
I do have the same issue with non-working sound and my T23 in combination with
XFCE in F9, but I have to perform the following steps:

1. Open volume control after login
2. Change volume of master channel
3. Change volume of PCM channel

Then sound is working perfectly fine until rebooting.

Issue remains with or without pulseaudio and configuration with
system-config-soundcard works flawlessly.
Comment 12 Joachim Frieben 2008-08-03 04:57:44 EDT
Issue has been fixed in some kernel > 2.6.25.11-97.fc9.
Comment 13 Bastien Nocera 2008-08-08 09:02:15 EDT
*** Bug 448298 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.