This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 438556 - RFE: update smartmontools to latest version (5.38?)
RFE: update smartmontools to latest version (5.38?)
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: smartmontools (Show other bugs)
5.1
All Linux
low Severity low
: rc
: ---
Assigned To: Tomas Smetana
: Rebase
: 445728 447978 457374 476137 (view as bug list)
Depends On:
Blocks: RHEL5u3_relnotes
  Show dependency treegraph
 
Reported: 2008-03-21 17:28 EDT by Aleksey Nogin
Modified: 2010-10-22 19:24 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Rebase: Bug Fixes and Enhancements
Doc Text:
smartmontools has been re-based to version 5.38. This update improves autodetection of hardware devices, improves support for CCISS RAID arrays, and features a larger database of supported devices. This update also fixes a bug wherein SELinux prevented smartmontools from monitoring 3ware RAID devices. smartmontools can now monitor such devices properly.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-01-20 15:52:39 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Aleksey Nogin 2008-03-21 17:28:13 EDT
Currently RHEL 5 comes with smartmontools 5.36, while the latest one (currently
5.38) appears to have a lot more entries in device database (183 vs 135) and
probably some useful bugfixes as well.
Comment 1 Aleksey Nogin 2008-03-21 17:39:08 EDT
P.S. Also, having to use an explicit "-d ata" is kind of annoying and it's nice
that 5.38 no longer requires that.
Comment 2 Tomas Smetana 2008-03-26 02:55:24 EDT
I'm not against the rebasing of smartmontools.  However this decision must be
approved by the product management.
Comment 3 RHEL Product and Program Management 2008-06-04 18:45:50 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.
Comment 5 Tomas Smetana 2008-07-04 03:23:30 EDT
*** Bug 445728 has been marked as a duplicate of this bug. ***
Comment 7 Tomas Smetana 2008-08-01 01:06:36 EDT
*** Bug 447978 has been marked as a duplicate of this bug. ***
Comment 8 Tomas Smetana 2008-08-01 01:06:44 EDT
*** Bug 457374 has been marked as a duplicate of this bug. ***
Comment 9 Tomas Smetana 2008-08-01 01:11:16 EDT
I have closed other asks for rebase (regarding the CCISS controllers) as
duplicates of this one.
Comment 10 Tomas Smetana 2008-08-01 01:14:10 EDT
The unofficial testing packages can be found here:

http://tsmetana.fedorapeople.org/smartmontools/
Comment 16 Tomas Smetana 2008-11-03 06:56:12 EST
Release note added. If any revisions are required, please set the 
"requires_release_notes" flag to "?" and edit the "Release Notes" field accordingly.
All revisions will be proofread by the Engineering Content Services team.

New Contents:
The smartmontools package has been upgraded to the version 5.38. The new version has a larger known devices database and improves device autodetection. The configuration files are compatible with the previous version.
Comment 17 Don Domingo 2008-11-13 20:49:40 EST
this bug fix is now documented in the RHEL5.3 release notes. please refer to the following link within the next 24 hours or so to view the most current build:
http://documentation-stage.bne.redhat.com/docs/en-US/Red_Hat_Enterprise_Linux/5.3/html-single/Release_Notes/
Comment 18 Don Domingo 2008-11-13 20:49:40 EST
Release note updated. If any revisions are required, please set the 
"requires_release_notes"  flag to "?" and edit the "Release Notes" field accordingly.
All revisions will be proofread by the Engineering Content Services team.

Diffed Contents:
@@ -1 +1,3 @@
-The smartmontools package has been upgraded to the version 5.38. The new version has a larger known devices database and improves device autodetection. The configuration files are compatible with the previous version.+smartmontools has been re-based to version 5.38. This update improves autodetection of hardware devices, improves support for CCISS RAID arrays, and features a larger database of supported devices.
+
+This update also fixes a bug wherein SELinux prevented smartmontools from monitoring 3ware RAID devices. smartmontools can now monitor such devices properly.
Comment 21 Michal Hlavinka 2008-12-12 02:48:27 EST
*** Bug 476137 has been marked as a duplicate of this bug. ***
Comment 24 errata-xmlrpc 2009-01-20 15:52:39 EST
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHEA-2009-0089.html

Note You need to log in before you can comment on or make changes to this bug.