Bug 457374 - "smartctl -d cciss" doesn't work with external array
"smartctl -d cciss" doesn't work with external array
Status: CLOSED DUPLICATE of bug 438556
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: smartmontools (Show other bugs)
5.2
i686 Linux
low Severity medium
: rc
: ---
Assigned To: Tomas Smetana
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-07-31 05:26 EDT by Stefano Biagiotti
Modified: 2008-08-01 01:06 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-08-01 01:06:44 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Stefano Biagiotti 2008-07-31 05:26:50 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; it; rv:1.8.0.12) Gecko/20070530 Fedora/1.5.0.12-1.fc5 Firefox/1.5.0.12

Description of problem:
"smartctl -i -d cciss,N /dev/cciss/c0d0" doesn't work for some disks of the external array.

Version-Release number of selected component (if applicable):
smartmontools-5.36-4.el5

How reproducible:
Always


Steps to Reproduce:
I have a Compaq Proliant server equipped with a Compaq Smart Array 5i controller.
The controller has 2 direct-attached disks and an external array with 4 disks.

Direct-attached disk #1 of 2.
 # /usr/sbin/smartctl -i -d cciss,0 /dev/cciss/c0d0
 smartctl version 5.36 [i686-redhat-linux-gnu] Copyright (C) 2002-6 Bruce Allen
 Home page is http://smartmontools.sourceforge.net/
 Device: COMPAQ   BD03664553       Version: 3B07
 Serial number: 3FD0WA5M000072388AUR
 Device type: disk
 Local Time is: Thu Jul 31 10:55:29 2008 CEST
 Device supports SMART and is Enabled
 Temperature Warning Enabled

Direct-attached disk #2 of 2.
 # /usr/sbin/smartctl -i -d cciss,1 /dev/cciss/c0d0
 smartctl version 5.36 [i686-redhat-linux-gnu] Copyright (C) 2002-6 Bruce Allen
 Home page is http://smartmontools.sourceforge.net/
 Device: COMPAQ   BD03664553       Version: 3B07
 Serial number: 3FD0V02P00002239DA6R
 Device type: disk
 Local Time is: Thu Jul 31 10:55:34 2008 CEST
 Device supports SMART and is Enabled
 Temperature Warning Enabled

External disk #3 of 4.
 /usr/sbin/smartctl -i -d cciss,2 /dev/cciss/c0d0
 smartctl version 5.36 [i686-redhat-linux-gnu] Copyright (C) 2002-6 Bruce Allen
 Home page is http://smartmontools.sourceforge.net/
 Device: COMPAQ   BD03664553       Version: 3B07
 Serial number: 3FD0WBKT000072388BS9
 Device type: disk
 Local Time is: Thu Jul 31 10:55:37 2008 CEST
 Device supports SMART and is Enabled
 Temperature Warning Enabled

External disk #4 of 4.
 # /usr/sbin/smartctl -i -d cciss,3 /dev/cciss/c0d0
 smartctl version 5.36 [i686-redhat-linux-gnu] Copyright (C) 2002-6 Bruce Allen
 Home page is http://smartmontools.sourceforge.net/ 
 Device: COMPAQ   BD03664553       Version: 3B07
 Serial number: 3FD0SA7K0000723879SU
 Device type: disk
 Local Time is: Thu Jul 31 10:55:41 2008 CEST
 Device supports SMART and is Enabled
 Temperature Warning Enabled

Any other "smartctl -d cciss,N" where N>3 gives no result.
 # /usr/sbin/smartctl -i -d cciss,4 /dev/cciss/c0d0
 smartctl version 5.36 [i686-redhat-linux-gnu] Copyright (C) 2002-6 Bruce Allen
 Home page is http://smartmontools.sourceforge.net/
 Device: COMPAQ   Smart Array 5i Version: 1.72
 >> Terminate command early due to bad response to IEC mode page
 A mandatory SMART command failed: exiting. To continue, add one or more '-T permissive' options.

Actual Results:
Can't use smartctl with disks 1 and 2 of the external array.

Expected Results:
I tried to download and compile smartmontools version 5.38 from http://smartmontools.sourceforge.net and it works fine.

Direct-attached disk 1 of 2.
 # /usr/local/sbin/smartctl -i -d cciss,0 /dev/cciss/c0d0
 smartctl version 5.38 [i686-pc-linux-gnu] Copyright (C) 2002-8 Bruce Allen
 Home page is http://smartmontools.sourceforge.net/
 Device: COMPAQ   BD03664553       Version: 3B07
 Serial number: 3FD0WA5M000072388AUR
 Device type: disk
 Local Time is: Thu Jul 31 11:06:36 2008 CEST
 Device supports SMART and is Enabled
 Temperature Warning Enabled

Direct-attached disk 2 of 2.
 # /usr/local/sbin/smartctl -i -d cciss,1 /dev/cciss/c0d0
 smartctl version 5.38 [i686-pc-linux-gnu] Copyright (C) 2002-8 Bruce Allen
 Home page is http://smartmontools.sourceforge.net/
 Device: COMPAQ   BD03664553       Version: 3B07
 Serial number: 3FD0V02P00002239DA6R
 Device type: disk
 Local Time is: Thu Jul 31 11:06:41 2008 CEST
 Device supports SMART and is Enabled
 Temperature Warning Enabled

External disk 1 of 4.
 # /usr/local/sbin/smartctl -i -d cciss,4 /dev/cciss/c0d0
 smartctl version 5.38 [i686-pc-linux-gnu] Copyright (C) 2002-8 Bruce Allen
 Home page is http://smartmontools.sourceforge.net/
 Device: COMPAQ   BD03664553       Version: 3B07
 Serial number: 3FD0VRX6000072382LR7
 Device type: disk
 Local Time is: Thu Jul 31 11:06:51 2008 CEST
 Device supports SMART and is Enabled
 Temperature Warning Enabled

External disk 2 of 4.
 # /usr/local/sbin/smartctl -i -d cciss,5 /dev/cciss/c0d0
 smartctl version 5.38 [i686-pc-linux-gnu] Copyright (C) 2002-8 Bruce Allen
 Home page is http://smartmontools.sourceforge.net/
 Device: SEAGATE  ST373207LC       Version: 7804
 Serial number: 3KT0DSPE000075330KKT
 Device type: disk
 Transport protocol: Parallel SCSI (SPI-4)
 Local Time is: Thu Jul 31 11:06:55 2008 CEST
 Device supports SMART and is Enabled
 Temperature Warning Disabled or Not Supported

External disk 3 of 4.
 /usr/local/sbin/smartctl -i -d cciss,6 /dev/cciss/c0d0
 smartctl version 5.38 [i686-pc-linux-gnu] Copyright (C) 2002-8 Bruce Allen
 Home page is http://smartmontools.sourceforge.net/
 Device: COMPAQ   BD03664553       Version: 3B07
 Serial number: 3FD0WBKT000072388BS9
 Device type: disk
 Local Time is: Thu Jul 31 11:06:58 2008 CEST
 Device supports SMART and is Enabled
 Temperature Warning Enabled

External disk 4 of 4.
 /usr/local/sbin/smartctl -i -d cciss,7 /dev/cciss/c0d0
 smartctl version 5.38 [i686-pc-linux-gnu] Copyright (C) 2002-8 Bruce Allen
 Home page is http://smartmontools.sourceforge.net/
 Device: COMPAQ   BD03664553       Version: 3B07
 Serial number: 3FD0SA7K0000723879SU
 Device type: disk
 Local Time is: Thu Jul 31 11:07:02 2008 CEST
 Device supports SMART and is Enabled
 Temperature Warning Enabled

Additional info:
Can you please update the smartmontool package to the last version 5.38?
Thank you in advance.
Comment 1 Tomas Smetana 2008-07-31 05:56:58 EDT
I don't have an appropriate hardware at hand right now.  However we are going to
replace smartmontools in RHEL-5.3 with the new version, which contains some
changes regarding also CCISS arrays AFAIK.  You may try to download packages from:

http://tsmetana.fedorapeople.org/smartmontools/

Also if the new version wouldn't work for you then the problem is very likely to
be present in the upstream version as well and I should start fixing it there first.

Please let me know if you can test the new packages and if it solves your
problem.  Thank you.
Comment 2 Stefano Biagiotti 2008-07-31 11:47:52 EDT
Your package solves the problem.
Thank you.
Comment 3 Tomas Smetana 2008-08-01 01:06:44 EDT

*** This bug has been marked as a duplicate of 438556 ***

Note You need to log in before you can comment on or make changes to this bug.