Bug 438592 - abnormal termination of installation - UnicodeDecodeError
abnormal termination of installation - UnicodeDecodeError
Status: CLOSED DUPLICATE of bug 437993
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
i686 Linux
low Severity high
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-03-22 11:37 EDT by xunilarodef
Modified: 2008-03-23 19:59 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-03-23 19:59:47 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description xunilarodef 2008-03-22 11:37:33 EDT
Description of problem: 
Attempted an install via pxeboot using the images available early on 03-22:
        initrd.img	21-Mar-2008 04:20 	9491648
        vmlinuz 	21-Mar-2008 04:20 	2132448
(timestamp shown from mirror's web directory).  Since " Unable to Start X
 X was unable to start on your machine", this turned into a text mode
install.  It fails with the traceback included below.

Version-Release number of selected component (if applicable):
anaconda 11.4.0.55

How reproducible:
  1 out of 1 attempts

Steps to Reproduce:
1. Boot the pxeboot images, involuntarily select Text Mode install.
2. Within a few minutes of progressing to "Install Starting", with the 
   progress bar over text such as "6 of 909 packages completed",
   rewarded with an exception. 

Actual results:  Install failed.

Expected results:  A successful installation.

Additional info:
Since the text "Save to Disk" appears on screen, but the associated
~checkbox is not selectable, you will have to settle for this manual
transcription (complete with the line breaks as displayed on screen):

 -- Exception Occurred --
anaconda 11.4.0.55 exception report
Traceback (most recent call first):
  File "/usr/lib/anaconda/yuminstall.py",
line 160, in callback
    s += (hdr['summary'] or "")
  File
"/usr/lib/python2.5/site-packages/yum/__in
it__.py", line 764, in runTransaction
    errors = self.ts.run(cb.callback, '')
  File "/usr/lib/anaconda/yuminstall.py",
line 698, in _run
    self.runTransaction(cb=cb)
  File "/usr/lib/anaconda/yuminstall.py",
line 682, in run
    if self._run(instLog, cb, intf) ==
DISPATCH_BACK;
  File "/usr/lib/anaconda/yuminstall.py",
line 1487, in doInstall
    rc = self.ayum.run(self.instLog, cb,
anaconda.intf, anaconda.id)
  File "/usr/lib/anaconda/backend.py",
line 209, in doInstall
    return
anaconda.backend.doInstall(anaconda)
  File "/usr/lib/anaconda/dispatch.py",
line 208, in moveStep
    rc = stepFunc(self.anaconda)
  File "/usr/lib/anaconda/dispatch.py",
line 131, in gotoNext
    self.moveStep()
  File "/usr/lib/anaconda/text.py",
line 701, in run
    anaconda.dispatch.gotoNext()
  File "/usr/bin/anaconda", line 1046, in
<module>
    anaconda.intf.run(anaconda)
UnicodeDecodeError: 'ascii' codec can't
decode byte 0xc2 in position 19: ordinal
not in range(128)
  OK  Save  Debug
Comment 1 xunilarodef 2008-03-22 14:12:46 EDT
(In reply to comment #0)
now 2 out of 2 attempts

  To slightly improve your chances of recreating this failure,
I thought I should try to gather a few clues for what repository
data was being fetched to install at the time of this traceback.
So I repeated the installation attempt (on the same day, before
any repo updates may render such clues less meaningful).

  As an aside, using the boot parameter "xdriver=vesa" did not spare
me the "Unable to Start X X was unable to start on your machine"
circumstance, so this was once again a text mode install.

  Watching carefully, I am certain that this traceback occurs at the
time "21 of 905 packages completed" is displayed.  No package name is
shown at that time. (I had deselected the "Office and Productivity"
~checkbox on the package selection screen with hopes of a faster
install, and a plan to install additional packages later.)  I am
moderately certain that the previous package was so small and
downloaded so quickly that neither "20" nor its name was ever
displayed.  I believe the package name "gnome-backgrounds" was on
screen concurrently with "19 of 905 packages completed".

  Additionally, through the vagaries of buffering, this time on the
virtual terminal accessible via Alt+F3, following the traceback quoted
above, there was an additional line:
 
 12:34:19 INFO   : in run, screen = <snack.SnackScreen instance at 0xb772198c>

It is likely that these remaining informational and warning messages
are not causative for this incident.  On the virtual terminal
accessible via Alt+F4, the following messages were displayed (dating
from the installation phase ~10 minutes prior to this traceback
failure, at the time the partitioning information was being written to
disk?):
 
<30>Mar 22 12:23:40 hald[1347]: 12:23:40.552 [I] osspec.c:288: /proc/mounts
tells, that the mount tree has changed 

<30>Mar 22 12:23:40 hald[1347]: 12:23:40.570 [I] osspec.c:241: SEQNUM=1115,
ACTION=remove, SUBSYSTEM=vc, DEVPATH=/sys/devices/virtual/vc/vcs5,
DEVNAME=/dev/vcs5, IFINDEX=0

<30>Mar 22 12:23:40 hald[1347]: 12:23:40.571 [I] device.c:4371: remove_dev:
subsys=vc sysfs_path=/sys/devices/virtual/vc/vcs5

<28>Mar 22 12:23:40 hald[1347]: 12:23:40.571 [W] device.c:4375: Error removing
device

<30>Mar 22 12:23:40 hald[1347]: 12:23:40.583 [I] osspec.c:241: SEQNUM=1116,
ACTION=remove, SUBSYSTEM=vc, DEVPATH=/sys/devices/virtual/vc/vcsa5,
DEVNAME=/dev/vcsa5, IFINDEX=0

<30>Mar 22 12:23:40 hald[1347]: 12:23:40.584 [I] device.c:4371: remove_dev:
subsys=vc sysfs_path=/sys/devices/virtual/vc/vcsa5

<28>Mar 22 12:23:40 hald[1347]: 12:23:40.585 [W] device.c:4375: Error removing
device
Comment 2 Jeremy Katz 2008-03-23 19:59:47 EDT

*** This bug has been marked as a duplicate of 437993 ***

Note You need to log in before you can comment on or make changes to this bug.