Bug 437993 - Anaconda crashes with UnicodeDecodeError on text install
Anaconda crashes with UnicodeDecodeError on text install
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
All Linux
low Severity high
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
:
: 438592 438797 438818 439611 439617 440233 440324 441558 441793 458605 (view as bug list)
Depends On:
Blocks: F9Blocker
  Show dependency treegraph
 
Reported: 2008-03-18 12:01 EDT by Orion Poplawski
Modified: 2008-08-11 10:32 EDT (History)
16 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-04-03 18:21:03 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
anaconda dump (784.46 KB, text/plain)
2008-03-18 12:01 EDT, Orion Poplawski
no flags Details
ppc64.img netboot log (8.67 KB, application/octet-stream)
2008-03-25 10:11 EDT, IBM Bug Proxy
no flags Details
anaconda dump log (343.62 KB, text/plain)
2008-03-25 10:12 EDT, IBM Bug Proxy
no flags Details

  None (edit)
Description Orion Poplawski 2008-03-18 12:01:47 EDT
anaconda 11.4.0.54 exception report
Traceback (most recent call first):
  File "/usr/lib/anaconda/yuminstall.py", line 160, in callback
    s += (hdr['summary'] or "")
  File "/usr/lib/python2.5/site-packages/yum/__init__.py", line 763, in
runTransaction
    errors = self.ts.run(cb.callback, '')
  File "/usr/lib/anaconda/yuminstall.py", line 698, in _run
    self.runTransaction(cb=cb)
  File "/usr/lib/anaconda/yuminstall.py", line 682, in run
    if self._run(instLog, cb, intf) == DISPATCH_BACK:
  File "/usr/lib/anaconda/yuminstall.py", line 1478, in doInstall
    rc = self.ayum.run(self.instLog, cb, anaconda.intf, anaconda.id)
  File "/usr/lib/anaconda/backend.py", line 209, in doInstall
    return anaconda.backend.doInstall(anaconda)
  File "/usr/lib/anaconda/dispatch.py", line 208, in moveStep
    rc = stepFunc(self.anaconda)
  File "/usr/lib/anaconda/dispatch.py", line 131, in gotoNext
    self.moveStep()
  File "/usr/lib/anaconda/text.py", line 701, in run
    anaconda.dispatch.gotoNext()
  File "/usr/bin/anaconda", line 1046, in <module>
    anaconda.intf.run(anaconda)
UnicodeDecodeError: 'ascii' codec can't decode byte 0xc2 in position 19: ordinal
not in range(128)

Local variables in innermost frame:
pkgStr: rt73usb-firmware-1.8-4.rt73usb-firmware
what: 4
hdr: <rpm.hdr object at 0xb64b5a70>
txmbrs: [<TransactionMember : rt73usb-firmware.noarch 0-1.8-4 - u (0x9eab84c)>]
h: (<rpm.hdr object at 0xb64b5a70>,
u'/mnt/sysimage/tmp/cache/anaconda-Fedora-200803180403.i386/packages/rt73usb-firmware-1.8-4.noarch.rpm')
self: <yuminstall.AnacondaCallback instance at 0xb6b218ec>
epoch: None
repo: anaconda-Fedora-200803180403.i386
rpmloc:
/mnt/sysimage/tmp/cache/anaconda-Fedora-200803180403.i386/packages/rt73usb-firmware-1.8-4.noarch.rpm
s: <b>Installing rt73usb-firmware-1.8-4.rt73usb-firmware</b> (4 KB)
Comment 1 Orion Poplawski 2008-03-18 12:01:47 EDT
Created attachment 298413 [details]
anaconda dump
Comment 2 Michal Schmidt 2008-03-20 12:04:45 EDT
Same problem here. Anaconda should expect UTF-8 in package summary like this 
one:
  Firmware for Ralink® RT2571W/RT2671 A/B/G network adaptors
Comment 3 Jeremy Katz 2008-03-23 19:59:48 EDT
*** Bug 438592 has been marked as a duplicate of this bug. ***
Comment 4 Jeremy Katz 2008-03-24 19:28:32 EDT
Fixed in git
Comment 5 Jeremy Katz 2008-03-25 09:18:11 EDT
*** Bug 438797 has been marked as a duplicate of this bug. ***
Comment 6 Jeremy Katz 2008-03-25 10:02:49 EDT
*** Bug 438818 has been marked as a duplicate of this bug. ***
Comment 7 IBM Bug Proxy 2008-03-25 10:11:53 EDT
=Comment: #0=================================================
Mohammed Omar <mohd.omar@in.ibm.com> - 2008-03-25 02:37 EDT
---Problem description:-----
Anaconda of F9 Beta generated a Trace Back error message at last stage of
installation (the time of retrieving and installing the selected Packages). I
used NFS server as a source,with default partitioning,selected manual package
selection option.

--------log-------------

Welcome to Fedora for ppc
┌────────────┤ Exception Occurred ├─────────────┐
│                                               │
│ anaconda 11.4.0.55 exception report         ↑ │
│ Traceback (most recent call first):         ▮ │
┌─────────│   File "/usr/lib/anaconda/yuminstall.py",   ▒ │ ────────┐
│         │ line 160, in callback                       ▒ │         │
│         │     s += (hdr['summary'] or "")             ▒ │         │
│         │   File                                      ▒ │         │
│         │ "/usr/lib/python2.5/site-packages/yum/__in  ▒ │         │
│         │ it__.py", line 763, in runTransaction       ▒ │         │
│         │     errors = self.ts.run(cb.callback, '')   ▒ │         │
│         │   File "/usr/lib/anaconda/yuminstall.py",   ▒ │         │
│         │ line 698, in _run                           ▒ │         │
│         │     self.runTransaction(cb=cb)              ↓ │         │
│         │                                               │         │
│         │    ┌────┐        ┌──────┐       ┌───────┐     │         │
└─────────│    │ OK │        │ Save │       │ Debug │     │ ────────┘
│    └────┘        └──────┘       └───────┘     │
│                                               │
│                                               │
└───────────────────────────────────────────────┘

--Hardware Environment---
Machine type (p650, x235, SF2, etc.): P550  (LPAR based)
Cpu type (Power4, Power5, IA-64, etc.): Power5

---Is this reproducible?--
Yes

---Describe the steps:--

Step1: Boot p550 with ppc64.img netboot image
Step2: give nfs server path for installation,with default partitioning
and manual package selection.
Step3: Encounters the problem while retrieving and installing the packages.

--Additional information:--
Attaching the complete log in next comment.
=Comment: #1=================================================
Mohammed Omar <mohd.omar@in.ibm.com> - 2008-03-25 02:39 EDT

anaconda dump log

=Comment: #2=================================================
Mohammed Omar <mohd.omar@in.ibm.com> - 2008-03-25 02:49 EDT

ppc64.img netboot log

*** This bug has been marked as a duplicate of 437993 ***
Comment 8 IBM Bug Proxy 2008-03-25 10:11:58 EDT
Created attachment 299028 [details]
ppc64.img netboot log
Comment 9 IBM Bug Proxy 2008-03-25 10:12:01 EDT
Created attachment 299029 [details]
anaconda dump log
Comment 10 Kazunori Asayama 2008-03-26 10:56:14 EDT
Here is workaround for F9 Beta. By disabling 'Hardware Support' in customizing
menu, I could avoid this error.
Comment 11 Chris Lumens 2008-03-29 18:50:59 EDT
*** Bug 439617 has been marked as a duplicate of this bug. ***
Comment 12 Chris Lumens 2008-03-29 18:51:05 EDT
*** Bug 439611 has been marked as a duplicate of this bug. ***
Comment 13 Michel Alexandre Salim 2008-03-29 19:05:03 EDT
Perhaps these kind of UnicodeDecodes should be try-catched by default? The cause
of the failure is trivial, but the resulting uncaught exception's effect is severe.
Comment 14 IBM Bug Proxy 2008-03-31 06:49:05 EDT
------- Comment From KRIECHBA@de.ibm.com 2008-03-31 06:46 EDT-------
F9-Beta installs without a problem when anaconda is replaced with the
version from the development branch (anaconda-11.4.0.61-1.ppc.rpm)
Comment 15 Carlo Wise 2008-04-02 11:33:58 EDT
I was getting the same error when trying to install on an HP 6910p laptop. It
wouldn't occur when installing Fedora 8...only version 9 (Beta) would generate
this error. I was able to get around the error by doing what Kazunori Asayama
suggested in comment #10.
Comment 16 Chris Lumens 2008-04-02 11:43:02 EDT
*** Bug 440233 has been marked as a duplicate of this bug. ***
Comment 17 Jeremy Katz 2008-04-02 23:10:46 EDT
*** Bug 440324 has been marked as a duplicate of this bug. ***
Comment 18 Orion Poplawski 2008-04-03 18:21:03 EDT
Confirm fixed in current rawhide.
Comment 19 Jeremy Katz 2008-04-08 15:22:09 EDT
*** Bug 441558 has been marked as a duplicate of this bug. ***
Comment 20 Chris Lumens 2008-04-10 05:02:02 EDT
*** Bug 441793 has been marked as a duplicate of this bug. ***
Comment 21 IBM Bug Proxy 2008-04-10 10:09:50 EDT
------- Comment From IndhuDurai@in.ibm.com 2008-04-10 10:00 EDT-------
hi,

As per comment 15, I replaced f9-beta's anaconda-11.4.0.55-1.ppc.rpm in NFS Repo
with anaconda-11.4.0.67-1.ppc.rpm(most recent one) and even after that i found
the issue reproduced.

As per the comment 12, when i disabled the hardware support, installation went
on fine.

regards,
Indhu D
Comment 22 Jeremy Katz 2008-04-17 00:00:30 EDT
*** Bug 442828 has been marked as a duplicate of this bug. ***
Comment 23 IBM Bug Proxy 2008-05-05 06:56:57 EDT
------- Comment From skannery@in.ibm.com 2008-05-05 06:52 EDT-------
Redhat Team,
Any updates here..
Thanks, Supriya
Comment 24 Chris Lumens 2008-08-11 10:32:03 EDT
*** Bug 458605 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.