Bug 438597 - alpine upstream available at 1.10
alpine upstream available at 1.10
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: alpine (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Rex Dieter
Fedora Extras Quality Assurance
:
Depends On:
Blocks: 438690 438692
  Show dependency treegraph
 
Reported: 2008-03-22 12:43 EDT by Ian Weller
Modified: 2008-03-24 14:02 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-03-24 14:02:51 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
patch for alpine specfile from 1.00-2 to 1.10-1 (729 bytes, patch)
2008-03-22 13:33 EDT, Ian Weller
no flags Details | Diff

  None (edit)
Description Ian Weller 2008-03-22 12:43:30 EDT
Alpine is available from upstream at version 1.10; version 1.00-2 is the current
version available from yum.

I'm wondering if there's a specific reason for this; if not, I'm willing to help
update it if the package owner(s) is/are busy.
Comment 1 Rex Dieter 2008-03-22 12:55:53 EDT
No specific reason, other than not being aware that a new release was available
(yet).  :)
Comment 2 Ian Weller 2008-03-22 12:59:41 EDT
I can upload a patch for the specfile for ya if you like, it's building on my
computer right now. (man it's intensive ;) )
Comment 3 Ian Weller 2008-03-22 13:33:40 EDT
Created attachment 298849 [details]
patch for alpine specfile from 1.00-2 to 1.10-1

It was a simple upgrade, I tested it on my computer and koji, and it was happy.


Out of habit I ran it through rpmlint just to be sure, and the license was bad,
so I changed it to the proper one.
Comment 4 Joshua Daniel Franklin 2008-03-22 18:43:38 EDT
There is a reason: the Fedora 9 freeze that I think just ended. I would also
like to add --without-debug (or similar) to the spec. It's also a holiday
weekend and I'm traveling, so if either co-maintainer has time before next
Tuesday feel free. :)
Comment 5 Rex Dieter 2008-03-24 07:41:20 EDT
I can crank this out (for rawhide at least).
Comment 6 Rex Dieter 2008-03-24 08:08:34 EDT
cvs/rawhide updated

* Mon Mar 24 2008 Rex Dieter <rdieter@fedoraproject.org> - 1.10-1
- alpine-1.10
- cosmetic (Build)Req cleanup 
Comment 7 Rex Dieter 2008-03-24 10:53:02 EDT
*** Bug 438690 has been marked as a duplicate of this bug. ***
Comment 8 Joshua Daniel Franklin 2008-03-24 11:02:22 EDT
Looks like the help output is wrong, you have to use "--enable-debug=no".
Comment 9 Ian Weller 2008-03-24 13:21:49 EDT
keep in mind the license is now incorrect, it should be changed to ASL 2.0 ...
Comment 10 Joshua Daniel Franklin 2008-03-24 14:02:51 EDT
Thanks, I changed the license string (note it's the same license as alpine has
always used).

This issue is resolved in this alpine build in testing:

http://koji.fedoraproject.org/koji/buildinfo?buildID=43664

You may download it there for early access, or wait for it to get pushed.

Note You need to log in before you can comment on or make changes to this bug.