Bug 438606 - at76 stops working with port to mac80211
at76 stops working with port to mac80211
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
8
i686 Linux
low Severity high
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
: Reopened
: 442277 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-03-22 15:16 EDT by Fred Odendaal
Modified: 2011-12-13 17:28 EST (History)
9 users (show)

See Also:
Fixed In Version: 2.6.26.6-79.fc9
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-10-23 12:39:17 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
/var/log/messages (48.18 KB, text/plain)
2008-03-26 21:04 EDT, Fred Odendaal
no flags Details
messages (11.64 KB, text/plain)
2008-03-27 21:55 EDT, Fred Odendaal
no flags Details
messages_good (11.28 KB, text/plain)
2008-03-27 21:56 EDT, Fred Odendaal
no flags Details

  None (edit)
Description Fred Odendaal 2008-03-22 15:16:05 EDT
Description of problem:
Wireless networking was working (with kernel 2.6.24.3-12.fc8.i686) but stopped
working with update to kernel 2.6.24.3-34.fc8.i686. All wireless networks
displayed with 0 signal strength and device appeared disconnected. I'm using a
Linksys WUSB11 v2.8 802.11b adapter, which uses the at76_usb driver.

Version-Release number of selected component (if applicable):
Working kernel -> 2.6.24.3-12.fc8.i686
Broken kernel -> 2.6.24.3-34.fc8.i686


How reproducible:

Try to use wireless networking with a Linksys WUSB11 v2.8 802.11b adapter.


Steps to Reproduce:
1. Login
2. Activate eth1 wireless device (I also have an unused eth0 wired device).
3. Note no signal strength and can't ping anything on WAN.
  
Actual results:
Output of /sbin/iwconfig when using broken kernel:
eth1      IEEE 802.11  ESSID:"fredo_wireless_network"  
          Mode:Managed  Frequency:2.447 GHz  Access Point: 00:06:25:9D:33:EC   
          Bit Rate=11 Mb/s   Tx-Power=0 dBm   
          Retry min limit:7   RTS thr:off   Fragment thr=2352 B   
          Link  min limit:7
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:0  Invalid misc:0   Missed beacon:0


Expected results:
Output of /sbin/iwconfig when using good kernel:
eth1      IEEE 802.11b  ESSID:"fredo_wireless_network"  
          Mode:Managed  Frequency:2.447 GHz  Access Point: 00:06:25:9D:33:EC   
          Bit Rate:11 Mb/s   Tx-Power=15 dBm   
          Retry limit:8   RTS thr=1536 B   Fragment thr=1536 B   
          Power Management:off
          Link Quality:87/100  Signal level:88/100  
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:0  Invalid misc:0   Missed beacon:0


Additional info:
Comment 1 Gianluca Varisco 2008-03-23 08:02:56 EDT
Hi Fred,

Do you have the time to try kernel-2.6.24.3-50.fc8 available in updates-testing
and check what happen? If yes, please do:

# yum update --enablerepo=updates-testing kernel
Comment 2 John W. Linville 2008-03-24 11:41:21 EDT
That is unlikely to help.  There are no recent changes to at76_usb.  This 
would seem to be the result of porting at76_usb to mac80211.

Can you attach the contents of /var/log/messages after trying to associate?  A 
wireshark capture taken from another station might be useful as well...thanks!
Comment 3 Fred Odendaal 2008-03-26 20:36:15 EDT
(In reply to comment #1)
> Hi Fred,
> 
> Do you have the time to try kernel-2.6.24.3-50.fc8 available in updates-testing
> and check what happen? If yes, please do:
> 
> # yum update --enablerepo=updates-testing kernel

(In reply to comment #1)
> Hi Fred,
> 
> Do you have the time to try kernel-2.6.24.3-50.fc8 available in updates-testing
> and check what happen? If yes, please do:
> 
> # yum update --enablerepo=updates-testing kernel

I was able to update to kernel-2.6.24.3-50.fc8 through the GUI using the
"Add/Remove Software application". It doesn't work either.
Comment 4 Fred Odendaal 2008-03-26 21:04:56 EDT
Created attachment 299251 [details]
/var/log/messages

Here is the output from /var/log/messages when booting with the 2.6.24.3-50.fc8
kernel.
Comment 5 Fred Odendaal 2008-03-26 21:11:12 EDT
(In reply to comment #2)
> That is unlikely to help.  There are no recent changes to at76_usb.  This 
> would seem to be the result of porting at76_usb to mac80211.
> 
> Can you attach the contents of /var/log/messages after trying to associate?  A 
> wireshark capture taken from another station might be useful as well...thanks!

It didn't totally help, but I can ping other devices on my lan - router,
printer, Windows computer. I still have no signal strength and can't access
anything over the wan with this kernel though. My networking comes up
automatically when I log in, so I wasn't sure when "trying to associate" occurs,
so I sent the /var/log/messages file from my last restart.

The only other computer I have on my wan is a Windows XP box. Can I run
wireshark or an equivalent from it?
Comment 6 John W. Linville 2008-03-27 10:45:37 EDT
The attached /var/log/messages certainly seems to indicate that things are 
working.  Is there some error later?  Or are you only concerned about the 
missing link quality number?
Comment 7 Fred Odendaal 2008-03-27 18:31:27 EDT
(In reply to comment #6)
> The attached /var/log/messages certainly seems to indicate that things are 
> working.  Is there some error later?  Or are you only concerned about the 
> missing link quality number?

Networking may appear to be working correctly, but it's not. The network monitor
in the desktop panel indicates that the status of the eth1 connection is
"disconnected". Also, the Network Manager Applet indicates that the 8 wireless
networks I can see have 0 signal strength. Also, I can't ping anything outside
my LAN (the WAN) and I can't connect to any websites with my browser or access
my email with thunderbird. All of these are working with 2.6.24.3-12.fc8.i686,
which I'm using to type this. I wouldn't be able to with 2.6.24.3-34.fc8.i686 or
2.6.24.3-50.fc8.i686.

One other thing that is different between a good kernel and a bad one is the
output of /sbin/ifconfig. As can be seen below there is a "MULTICAST"
configuration for eth1 in the bad ifconfig and an extra device called wmaster0.

Good:
eth0      Link encap:Ethernet  HWaddr 00:11:2F:31:02:2A  
          UP BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:0 (0.0 b)  TX bytes:0 (0.0 b)
          Interrupt:16 

eth1      Link encap:Ethernet  HWaddr 00:0F:66:10:86:DE  
          inet addr:192.168.1.100  Bcast:192.168.1.255  Mask:255.255.255.0
          inet6 addr: fe80::20f:66ff:fe10:86de/64 Scope:Link
          UP BROADCAST RUNNING  MTU:1500  Metric:1
          RX packets:1599 errors:0 dropped:0 overruns:0 frame:0
          TX packets:1378 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:1721139 (1.6 MiB)  TX bytes:177224 (173.0 KiB)

lo        Link encap:Local Loopback  
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:4271 errors:0 dropped:0 overruns:0 frame:0
          TX packets:4271 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0 
          RX bytes:2420872 (2.3 MiB)  TX bytes:2420872 (2.3 MiB)

Bad:
eth0      Link encap:Ethernet  HWaddr 00:11:2F:31:02:2A  
          UP BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:0 (0.0 b)  TX bytes:0 (0.0 b)
          Interrupt:16 

eth1      Link encap:Ethernet  HWaddr 00:0F:66:10:86:DE  
          inet addr:192.168.1.100  Bcast:192.168.1.255  Mask:255.255.255.0
          inet6 addr: fe80::20f:66ff:fe10:86de/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:92 errors:0 dropped:0 overruns:0 frame:0
          TX packets:95 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:10015 (9.7 KiB)  TX bytes:13625 (13.3 KiB)

lo        Link encap:Local Loopback  
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:3358 errors:0 dropped:0 overruns:0 frame:0
          TX packets:3358 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0 
          RX bytes:168511 (164.5 KiB)  TX bytes:168511 (164.5 KiB)

wmaster0  Link encap:UNSPEC  HWaddr 00-0F-66-10-86-DE-98-93-00-00-00-00-00-00-00
-00  
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:0 (0.0 b)  TX bytes:0 (0.0 b)

Comment 8 Fred Odendaal 2008-03-27 21:54:24 EDT
Some more info:

I did a tkdiff from where the Network Manager starts of the /var/log/messages
file between the broken and working kernels. I saved these files as messages and
messages_good. Then I inserted "---" dashed lines where there was information in
one file that was missing in the other to line everything up in tkdiff.

I've attached the 2 files as "messages" and "messages_good", but here is a
summary of the diffs:
GOOD: 
NetworkManager: <info>  eth1: driver does not support SSID scans (scan_capa 0x00).
BAD:
NetworkManager: <info>  eth1: driver supports SSID scans (scan_capa 0x01).

GOOD:
kernel: eth1: join_bss ssid 00:0c:41:7f:6f:d0 timed out
kernel: eth1: join_bss ssid 00:0c:41:7f:6f:d0 timed out
BAD - lines are missing

GOOD:
NetworkManager: <info>  (eth1) Supplicant interface state change: 2 -> 0
NetworkManager: <info>  (eth1) Supplicant interface state change: 0 -> 2
BAD:
NetworkManager: <info>  (eth1) Supplicant interface state change: 1 -> 2

GOOD - lines are missing
BAD:
dhclient: wmaster0: unknown hardware address type 801
dhclient: wmaster0: unknown hardware address type 801
avahi-daemon[1988]: Registering new address record for fe80::20f:66ff:fe10:86de
on eth1.*.
avahi-daemon[1988]: Withdrawing address record for fe80::20f:66ff:fe10:86de on eth1.
avahi-daemon[1988]: Joining mDNS multicast group on interface eth1.IPv4 with
address 192.168.1.100.
avahi-daemon[1988]: New relevant interface eth1.IPv4 for mDNS.
avahi-daemon[1988]: Registering new address record for 192.168.1.100 on eth1.IPv4.
avahi-daemon[1988]: Registering new address record for fe80::20f:66ff:fe10:86de
on eth1.*.
Comment 9 Fred Odendaal 2008-03-27 21:55:27 EDT
Created attachment 299424 [details]
messages
Comment 10 Fred Odendaal 2008-03-27 21:56:03 EDT
Created attachment 299425 [details]
messages_good
Comment 11 John W. Linville 2008-03-28 09:23:22 EDT
Adding the dash lines was very helpful -- thanks!  FWIW, most of the 
difference seems to be collateral to the mac80211 port (which explains the 
appearance of wmaster0 -- please ignore it).

Still, it seems that in both cases you successfully bring-up the interface and 
get a DHCP lease for 192.168.1.100.  And given your above messages about being 
able to ping stations on the LAN, this doesn't strike me as a driver problem.  
Are you able to ping your router, 192.168.1.1?

What is the output of 'netstat -r'?  Also, I'll CC the NetworkManager guy in 
case he has some insight...
Comment 12 Dan Williams 2008-03-28 13:15:17 EDT
If you see the zero-strength scanned networks, run an 'iwlist <iface> scan', and
if all the scanned APs report zero-strength from iwlist, then it's definitely a
driver issue.

Though John's right; I don't see anything in the "bad" log that would indicate
an error.  However, the driver might report scan results as zero-strength but NM
would still work.

Another possiblity is that everything is working, but that changes in mac80211
broke the NM strength calculation algorithm, which would still make me blame
mac80211 or at76_usb :)
Comment 13 Fred Odendaal 2008-03-28 21:16:56 EDT
Output from netstat -r was the same for both versions, but was immediate for 3-1
2, and took ~10s for 3-50. Here it is:
Kernel IP routing table
Destination     Gateway         Genmask         Flags   MSS Window  irtt Iface
192.168.1.0     *               255.255.255.0   U         0 0          0 eth1
default         192.168.1.1     0.0.0.0         UG        0 0          0 eth1

I can ping my router, but I get terrible round trip times and packet loss. Now
that I've spent more time pinging things on my lan I see that I consistently get
bad throughput and dropped packets pinging all devices.

Output from 'iwlist eth1 scan' was different. Here it is for 3-12:
eth1      Scan completed :
          Cell 01 - Address: 00:06:25:9D:33:EC
                    ESSID:"fredo_wireless_network"
                    Mode:Master
                    Channel:8
                    Encryption key:on
                    Signal level=100/100  
                    Bit Rates:1 Mb/s; 2 Mb/s; 5.5 Mb/s; 11 Mb/s
          Cell 02 - Address: 00:13:10:81:F5:6D
                    ESSID:"linksys"
                    Mode:Master
                    Channel:6
                    Encryption key:on
                    Signal level=66/100  
                    Bit Rates:1 Mb/s; 2 Mb/s; 5.5 Mb/s; 11 Mb/s; 18 Mb/s
                              24 Mb/s; 36 Mb/s; 54 Mb/s
          Cell 03 - Address: 00:0F:66:A7:97:83
                    ESSID:"hearn"
                    Mode:Master
                    Channel:6
                    Encryption key:on
                    Signal level=61/100  
                    Bit Rates:1 Mb/s; 2 Mb/s; 5.5 Mb/s; 11 Mb/s
          Cell 04 - Address: 00:13:10:9F:F8:63
                    ESSID:"RatNet"
                    Mode:Master
                    Channel:8
                    Encryption key:on
                    Signal level=57/100  
                    Bit Rates:1 Mb/s; 2 Mb/s; 5.5 Mb/s; 11 Mb/s; 18 Mb/s
                              24 Mb/s; 36 Mb/s; 54 Mb/s
          Cell 05 - Address: 00:1E:52:7A:08:78
                    ESSID:"AppleNet"
                    Mode:Master
                    Channel:9
                    Encryption key:on
                    Signal level=64/100  
                    Bit Rates:1 Mb/s; 2 Mb/s; 5.5 Mb/s; 11 Mb/s; 6 Mb/s
                              9 Mb/s; 12 Mb/s; 18 Mb/s

For 3-50 mostly I got: eth1      No scan results
but after may repeated tries I was able to get:
eth1      Scan completed :
          Cell 01 - Address: 00:06:25:9D:33:EC
                    ESSID:"fredo_wireless_network"
                    Mode:Master
                    Frequency:2.447 GHz (Channel 8)
                    Channel:8
                    Channel:8
                    Encryption key:on
                    Bit Rates:1 Mb/s; 2 Mb/s; 5.5 Mb/s; 11 Mb/s
                    Extra:tsf=0000007f9cd2f748
          Cell 02 - Address: 00:13:10:81:F5:6D
                    ESSID:"linksys"
                    Mode:Master
                    Frequency:2.437 GHz (Channel 6)
                    Channel:6
                    Channel:6
                    Encryption key:on
                    Bit Rates:1 Mb/s; 2 Mb/s; 5.5 Mb/s; 11 Mb/s; 18 Mb/s
                              24 Mb/s; 36 Mb/s; 54 Mb/s; 6 Mb/s; 9 Mb/s
                              12 Mb/s; 48 Mb/s
                    Extra:tsf=00000142f7eb67ff
          Cell 03 - Address: 00:17:3F:9E:4A:DA
                    ESSID:"McCormicks"
                    Mode:Master
                    Frequency:2.462 GHz (Channel 11)
                    Channel:11
                    Channel:11
                    Encryption key:on
                    IE: WPA Version 1
                        Group Cipher : TKIP
                        Pairwise Ciphers (1) : TKIP
                        Authentication Suites (1) : PSK
                    Bit Rates:1 Mb/s; 2 Mb/s; 5.5 Mb/s; 11 Mb/s; 6 Mb/s
                              9 Mb/s; 12 Mb/s; 18 Mb/s; 24 Mb/s; 36 Mb/s
                              48 Mb/s; 54 Mb/s
                    Extra:tsf=000002dbda307acb
          Cell 04 - Address: 00:13:10:9F:F8:63
                    ESSID:"RatNet"
                    Mode:Master
                    Frequency:2.447 GHz (Channel 8)
                    Channel:8
                    Channel:8
                    Encryption key:on
                    Bit Rates:1 Mb/s; 2 Mb/s; 5.5 Mb/s; 11 Mb/s; 18 Mb/s
                              24 Mb/s; 36 Mb/s; 54 Mb/s; 6 Mb/s; 9 Mb/s
                              12 Mb/s; 48 Mb/s
                    Extra:tsf=000002dbd9ae9d75
          Cell 05 - Address: 00:1E:52:7A:08:78
                    ESSID:"AppleNet"
                    Mode:Master
                    Frequency:2.452 GHz (Channel 9)
                    Channel:9
                    Channel:9
                    Encryption key:on
                    IE: WPA Version 1
                        Group Cipher : TKIP
                        Pairwise Ciphers (1) : TKIP
                        Authentication Suites (1) : PSK
                    IE: IEEE 802.11i/WPA2 Version 1
                        Group Cipher : TKIP
                        Pairwise Ciphers (2) : CCMP TKIP
                        Authentication Suites (1) : PSK
                    Bit Rates:1 Mb/s; 2 Mb/s; 5.5 Mb/s; 11 Mb/s
                    Extra:tsf=00000012a5e6208b
          Cell 06 - Address: 00:13:A3:06:00:DF
                    ESSID:"penner1net"
                    Mode:Master
                    Frequency:2.462 GHz (Channel 11)
                    Channel:11
                    Channel:11
                    Encryption key:on
                    Bit Rates:1 Mb/s; 2 Mb/s; 5.5 Mb/s; 11 Mb/s; 22 Mb/s
                              6 Mb/s; 9 Mb/s; 12 Mb/s; 18 Mb/s; 24 Mb/s
                              36 Mb/s; 48 Mb/s; 54 Mb/s
                    Extra:tsf=0000000496aba128

Comment 14 Bradley 2008-03-30 20:33:33 EDT
I have the same issue, using iwl4965. -12 works; newer versions don't. The newer
kernels *DO* work on a WPA1 network with a Cisco AP, but fails on WPA2 (at uni)
using both PSK and PEAP (two different APs/SSIDs - a legacy issue)

scan output from the working kernel:

wlan0     Scan completed :
          Cell 01 - Address: 00:1E:4A:32:98:10
                    ESSID:"uniwide"
                    Mode:Master
                    Frequency:2.412 GHz (Channel 1)
                    Channel:1
                    Quality=45/100  Signal level=-82 dBm  Noise level=-127 dBm
                    Encryption key:on
                    IE: WPA Version 1
                        Group Cipher : TKIP
                        Pairwise Ciphers (2) : TKIP CCMP
                        Authentication Suites (1) : 802.1x
                    IE: IEEE 802.11i/WPA2 Version 1
                        Group Cipher : TKIP
                        Pairwise Ciphers (2) : TKIP CCMP
                        Authentication Suites (1) : 802.1x
                    Bit Rates:1 Mb/s; 2 Mb/s; 5.5 Mb/s; 6 Mb/s; 9 Mb/s
                              11 Mb/s; 12 Mb/s; 18 Mb/s; 24 Mb/s; 36 Mb/s
                              48 Mb/s; 54 Mb/s
                    Extra:tsf=00000005bccba11d
          Cell 02 - Address: 00:1E:4A:32:98:11
                    ESSID:"uniwide_webauth"
                    Mode:Master
                    Frequency:2.412 GHz (Channel 1)
                    Channel:1
                    Quality=45/100  Signal level=-82 dBm  Noise level=-127 dBm
                    Encryption key:on
                    IE: WPA Version 1
                        Group Cipher : TKIP
                        Pairwise Ciphers (1) : TKIP
                        Authentication Suites (1) : PSK
                    Bit Rates:1 Mb/s; 2 Mb/s; 5.5 Mb/s; 6 Mb/s; 9 Mb/s
                              11 Mb/s; 12 Mb/s; 18 Mb/s; 24 Mb/s; 36 Mb/s
                              48 Mb/s; 54 Mb/s
                    Extra:tsf=00000005bccc68b0
          Cell 03 - Address: 00:1E:4A:32:98:15
                    ESSID:"AGSM2"
                    Mode:Master
                    Frequency:2.412 GHz (Channel 1)
                    Channel:1
                    Quality=43/100  Signal level=-83 dBm  Noise level=-127 dBm
                    Encryption key:on
                    IE: WPA Version 1
                        Group Cipher : TKIP
                        Pairwise Ciphers (1) : TKIP
                        Authentication Suites (1) : PSK
                    Bit Rates:1 Mb/s; 2 Mb/s; 5.5 Mb/s; 6 Mb/s; 9 Mb/s
                              11 Mb/s; 12 Mb/s; 18 Mb/s; 24 Mb/s; 36 Mb/s
                              48 Mb/s; 54 Mb/s
                    Extra:tsf=00000005bccc9f8c
          Cell 04 - Address: 00:19:07:8F:4A:C1
                    ESSID:"uniwide_webauth"
                    Mode:Master
                    Frequency:2.437 GHz (Channel 6)
                    Channel:6
                    Quality=65/100  Signal level=-68 dBm  Noise level=-127 dBm
                    Encryption key:on
                    IE: WPA Version 1
                        Group Cipher : TKIP
                        Pairwise Ciphers (1) : TKIP
                        Authentication Suites (1) : PSK
                    Bit Rates:1 Mb/s; 2 Mb/s; 5.5 Mb/s; 6 Mb/s; 9 Mb/s
                              11 Mb/s; 12 Mb/s; 18 Mb/s; 24 Mb/s; 36 Mb/s
                              48 Mb/s; 54 Mb/s
                    Extra:tsf=00000293a97873f1
          Cell 05 - Address: 00:19:07:8F:4A:C0
                    ESSID:"uniwide"
                    Mode:Master
                    Frequency:2.437 GHz (Channel 6)
                    Channel:6
                    Quality=66/100  Signal level=-67 dBm  Noise level=-127 dBm
                    Encryption key:on
                    IE: WPA Version 1
                        Group Cipher : TKIP
                        Pairwise Ciphers (2) : TKIP CCMP
                        Authentication Suites (1) : 802.1x
                    IE: IEEE 802.11i/WPA2 Version 1
                        Group Cipher : TKIP
                        Pairwise Ciphers (2) : TKIP CCMP
                        Authentication Suites (1) : 802.1x
                    Bit Rates:1 Mb/s; 2 Mb/s; 5.5 Mb/s; 6 Mb/s; 9 Mb/s
                              11 Mb/s; 12 Mb/s; 18 Mb/s; 24 Mb/s; 36 Mb/s
                              48 Mb/s; 54 Mb/s
                    Extra:tsf=00000293a977ac67
          Cell 06 - Address: 00:19:07:8F:4A:C5
                    ESSID:"AGSM2"
                    Mode:Master
                    Frequency:2.437 GHz (Channel 6)
                    Channel:6
                    Quality=68/100  Signal level=-65 dBm  Noise level=-127 dBm
                    Encryption key:on
                    IE: WPA Version 1
                        Group Cipher : TKIP
                        Pairwise Ciphers (1) : TKIP
                        Authentication Suites (1) : PSK
                    Bit Rates:1 Mb/s; 2 Mb/s; 5.5 Mb/s; 6 Mb/s; 9 Mb/s
                              11 Mb/s; 12 Mb/s; 18 Mb/s; 24 Mb/s; 36 Mb/s
                              48 Mb/s; 54 Mb/s
                    Extra:tsf=00000293a978aac4
          Cell 07 - Address: 00:19:07:8E:1A:51
                    ESSID:"uniwide_webauth"
                    Mode:Master
                    Frequency:2.462 GHz (Channel 11)
                    Channel:11
                    Quality=83/100  Signal level=-51 dBm  Noise level=-127 dBm
                    Encryption key:on
                    IE: WPA Version 1
                        Group Cipher : TKIP
                        Pairwise Ciphers (1) : TKIP
                        Authentication Suites (1) : PSK
                    Bit Rates:1 Mb/s; 2 Mb/s; 5.5 Mb/s; 6 Mb/s; 9 Mb/s
                              11 Mb/s; 12 Mb/s; 18 Mb/s; 24 Mb/s; 36 Mb/s
                              48 Mb/s; 54 Mb/s
                    Extra:tsf=00000293aa3fbbac
          Cell 08 - Address: 00:19:07:8E:1A:55
                    ESSID:"AGSM2"
                    Mode:Master
                    Frequency:2.462 GHz (Channel 11)
                    Channel:11
                    Quality=84/100  Signal level=-49 dBm  Noise level=-127 dBm
                    Encryption key:on
                    IE: WPA Version 1
                        Group Cipher : TKIP
                        Pairwise Ciphers (1) : TKIP
                        Authentication Suites (1) : PSK
                    Bit Rates:1 Mb/s; 2 Mb/s; 5.5 Mb/s; 6 Mb/s; 9 Mb/s
                              11 Mb/s; 12 Mb/s; 18 Mb/s; 24 Mb/s; 36 Mb/s
                              48 Mb/s; 54 Mb/s
                    Extra:tsf=00000293aa3ff28d
          Cell 09 - Address: 00:19:07:8E:1A:50
                    ESSID:"uniwide"
                    Mode:Master
                    Frequency:2.462 GHz (Channel 11)
                    Channel:11
                    Quality=84/100  Signal level=-49 dBm  Noise level=-127 dBm
                    Encryption key:on
                    IE: WPA Version 1
                        Group Cipher : TKIP
                        Pairwise Ciphers (2) : TKIP CCMP
                        Authentication Suites (1) : 802.1x
                    IE: IEEE 802.11i/WPA2 Version 1
                        Group Cipher : TKIP
                        Pairwise Ciphers (2) : TKIP CCMP
                        Authentication Suites (1) : 802.1x
                    Bit Rates:1 Mb/s; 2 Mb/s; 5.5 Mb/s; 6 Mb/s; 9 Mb/s
                              11 Mb/s; 12 Mb/s; 18 Mb/s; 24 Mb/s; 36 Mb/s
                              48 Mb/s; 54 Mb/s
                    Extra:tsf=00000293aa3eeca3
          Cell 10 - Address: 00:19:07:8E:1A:5E
                    ESSID:"uniwide_webauth"
                    Mode:Master
                    Frequency:5.2 GHz
                    Channel:40
                    Quality=72/100  Signal level=-62 dBm  Noise level=-127 dBm
                    Encryption key:on
                    IE: WPA Version 1
                        Group Cipher : TKIP
                        Pairwise Ciphers (1) : TKIP
                        Authentication Suites (1) : PSK
                    Bit Rates:6 Mb/s; 9 Mb/s; 12 Mb/s; 18 Mb/s; 24 Mb/s
                              36 Mb/s; 48 Mb/s; 54 Mb/s
                    Extra:tsf=00000293aa461044
          Cell 11 - Address: 00:19:07:8E:1A:5F
                    ESSID:"uniwide"
                    Mode:Master
                    Frequency:5.2 GHz
                    Channel:40
                    Quality=72/100  Signal level=-62 dBm  Noise level=-127 dBm
                    Encryption key:on
                    IE: WPA Version 1
                        Group Cipher : TKIP
                        Pairwise Ciphers (2) : TKIP CCMP
                        Authentication Suites (1) : 802.1x
                    IE: IEEE 802.11i/WPA2 Version 1
                        Group Cipher : TKIP
                        Pairwise Ciphers (2) : TKIP CCMP
                        Authentication Suites (1) : 802.1x
                    Bit Rates:6 Mb/s; 9 Mb/s; 12 Mb/s; 18 Mb/s; 24 Mb/s
                              36 Mb/s; 48 Mb/s; 54 Mb/s
                    Extra:tsf=00000293aa448044
          Cell 12 - Address: 00:19:07:8E:1A:5A
                    ESSID:"AGSM2"
                    Mode:Master
                    Frequency:5.2 GHz
                    Channel:40
                    Quality=72/100  Signal level=-62 dBm  Noise level=-127 dBm
                    Encryption key:on
                    IE: WPA Version 1
                        Group Cipher : TKIP
                        Pairwise Ciphers (1) : TKIP
                        Authentication Suites (1) : PSK
                    Bit Rates:6 Mb/s; 9 Mb/s; 12 Mb/s; 18 Mb/s; 24 Mb/s
                              36 Mb/s; 48 Mb/s; 54 Mb/s
                    Extra:tsf=00000293aa461044
          Cell 13 - Address: 00:19:07:8F:4A:CF
                    ESSID:"uniwide"
                    Mode:Master
                    Frequency:5.805 GHz (Channel 161)
                    Channel:161
                    Quality=33/100  Signal level=-89 dBm  Noise level=-127 dBm
                    Encryption key:on
                    IE: WPA Version 1
                        Group Cipher : TKIP
                        Pairwise Ciphers (2) : TKIP CCMP
                        Authentication Suites (1) : 802.1x
                    IE: IEEE 802.11i/WPA2 Version 1
                        Group Cipher : TKIP
                        Pairwise Ciphers (2) : TKIP CCMP
                        Authentication Suites (1) : 802.1x
                    Bit Rates:6 Mb/s; 9 Mb/s; 12 Mb/s; 18 Mb/s; 24 Mb/s
                              36 Mb/s; 48 Mb/s; 54 Mb/s
                    Extra:tsf=00000293a99ee043

Comment 15 John W. Linville 2008-03-31 09:39:20 EDT
Bradley, honestly I don't think the issue you describe is at all related.  
Please open a separate bug for that issue.

It seems that the at76 port to mac80211 has introduced a bug probably related 
to transmission power or signal strength reporting.  I'll contact the driver 
authors.
Comment 16 Fred Odendaal 2008-04-11 23:08:33 EDT
It's still broken in the 2.6.24.4-64.fc8 kernel.
Comment 17 John W. Linville 2008-04-15 10:45:36 EDT
*** Bug 442277 has been marked as a duplicate of this bug. ***
Comment 18 Alan Macdonald 2008-04-28 14:10:51 EDT
I'm also experiencing this problem with my actiontec USB wireless adapter.  It
works on kernel 2.6.23.1-42.fc8 but after update to 2.6.24.4-64.fc8 fails.  I
have dmesg outputs after cold boots but I see from above that /var/log/messages
is meant to be more useful.  Does anyone need more files to try and pin the
problem down?  If so I can try and provide.

I downloaded the Fedora 9 KDE live cd preview a couple of weeks ago and could
not get wireless working on that either.  If you would prefer outputs from the
F9 preview I can provide as well.
Comment 19 Fred Odendaal 2008-05-08 23:00:10 EDT
Still broken in 2.6.24.5-85.fc8

I downloaded compat-wireless-2008-05-06 - had to hack the Makefile because
rtx200 was broken. I set DBG_DEFAULTS to 1 in at76_usb,c, which I think should
have turned debugging on. However, I don't see anything extra in any of the
files in /var/log/, but I'm not sure where kprint is going to output to.

Oh yeah, there were some warnings when I compiled at76_usb.c, while most of the
other modules compiled clean. Also, the at76_usb driver is missing from the list
of drivers in the README file.
Comment 20 Fred Odendaal 2008-05-20 22:24:19 EDT
Still broken in 2.6.24.7-92.fc8

I would suggest reverting this driver back to the version before the port to
mac80211 until it can be thoroughly tested. From reading email threads on
at76c503a-develop@lists.berlios.de it seems the driver was released before it
was  ready. Perhaps it should be deprecated before there are too many kernel
versions with the broken driver. 
Comment 21 John W. Linville 2008-05-30 14:35:10 EDT
I just sent an email to the main contributors for this driver.  Hopefully they
can suggest a fix or two. :-)
Comment 22 George Greer 2008-06-22 15:27:51 EDT
I have a:

   ID 077b:2219 Linksys WUSB11 V2.6 802.11b Adapter

The in-kernel driver hasn't worked for a while now (ever? I forget), and I'm
currently running 2.6.25.6-55.fc9.i686.  What does work is the version of the
at76_usb in the (abandoned) CVS repository:

File: at76_usb.c        Status: Up-to-date
   Working revision:    1.9
   Repository revision: 1.9     /cvsroot/at76c503a/at76c503a/at76_usb.c,v

If I run the kernel RPM version, I get:

INFO: task at76_usb:1427 blocked for more than 120 seconds.
"echo 0 > /proc/sys/kernel/hung_task_timeout_secs" disables this message.
at76_usb      D c079123c     0  1427      2
       f6ab0ed4 00000046 f782ce70 c079123c c0794280 c0794280 c0794280 f6b12e70
       f6b130b8 c1c0e280 00000000 c1c0e280 dc4e9b3e 0000000c 0147a000 f6b130b8
       c041d16d f782ce70 f782ce70 00000001 00000082 f6ab0ee8 c042035f f6b78e80
Call Trace:
 [<c041d16d>] ? check_preempt_wakeup+0x7e/0xc2
 [<c042035f>] ? try_to_wake_up+0x193/0x19d
 [<c0629edf>] __mutex_lock_slowpath+0x51/0x7f
 [<c0629db5>] mutex_lock+0x29/0x2d
 [<c0617c2c>] ? wireless_send_event+0x297/0x29f
 [<f892fa0c>] at76_config+0x96/0xee [at76_usb]
 [<f89650d2>] ieee80211_hw_config+0x4e/0x51 [mac80211]
 [<f896d86e>] ieee80211_scan_completed+0x57/0x1f0 [mac80211]
 [<f89312a8>] at76_dwork_hw_scan+0x8d/0xd8 [at76_usb]
 [<f892f5ca>] ? at76_set_mib+0x2d/0x59 [at76_usb]
 [<f893121b>] ? at76_dwork_hw_scan+0x0/0xd8 [at76_usb]
 [<c0434dd1>] run_workqueue+0x7c/0xfb
 [<c0434f06>] worker_thread+0xb6/0xc2
 [<c0437b0f>] ? autoremove_wake_function+0x0/0x33
 [<c0434e50>] ? worker_thread+0x0/0xc2
 [<c04378ad>] kthread+0x3b/0x61
 [<c0437872>] ? kthread+0x0/0x61
 [<c0406833>] kernel_thread_helper+0x7/0x10
 =======================

and quickly all network access stalls on a lock, for example:

INFO: task ntpd:2761 blocked for more than 120 seconds.
"echo 0 > /proc/sys/kernel/hung_task_timeout_secs" disables this message.
ntpd          D c079123c     0  2761      1
       f59dfe88 00200086 f7802500 c079123c c0794280 c0794280 c0794280 f2d0ce70
       f2d0d0b8 c1c0e280 00000000 c1c0e280 c0841a30 00100000 f2d0ce70 f2d0d0b8
       00012ec1 c04cdc0b f59dff08 ffffffff 00000000 00000000 00000000 c07309fc
Call Trace:
 [<c04cdc0b>] ? avc_has_perm_noaudit+0x1ee/0x366
 [<c0629edf>] __mutex_lock_slowpath+0x51/0x7f
 [<c0629db5>] mutex_lock+0x29/0x2d
 [<c05c176e>] rtnl_lock+0xd/0xf
 [<c05bad6e>] dev_ioctl+0x22/0x5d3
 [<c04d27c7>] ? selinux_d_instantiate+0x12/0x14
 [<c05f08a1>] ? udp_ioctl+0x0/0x62
 [<c05f732d>] ? inet_ioctl+0xa3/0xa8
 [<c05aeb59>] sock_ioctl+0x1c5/0x1d1
 [<c05ae994>] ? sock_ioctl+0x0/0x1d1
 [<c048c546>] vfs_ioctl+0x22/0x69
 [<c048c7c6>] do_vfs_ioctl+0x239/0x24c
 [<c04d009b>] ? selinux_file_ioctl+0xa8/0xab
 [<c048c819>] sys_ioctl+0x40/0x5b
 [<c0405bf2>] syscall_call+0x7/0xb
 =======================

and:

INFO: task nmbd:3029 blocked for more than 120 seconds.
"echo 0 > /proc/sys/kernel/hung_task_timeout_secs" disables this message.
nmbd          D c079123c     0  3029      1
       f2d3ed24 00200086 00400000 c079123c c0794280 c0794280 c0794280 f4bcae70
       f4bcb0b8 c1c0e280 00000000 c1c0e280 ffffffff 00000000 ffffffff f4bcb0b8
       0000bf46 f49879e0 f2d3ed58 ffffffff 00000000 00000000 00000000 c07309fc
Call Trace:
 [<c0629edf>] __mutex_lock_slowpath+0x51/0x7f
 [<c0629db5>] mutex_lock+0x29/0x2d
 [<c05c1780>] rtnetlink_rcv+0x10/0x24
 [<c05ce2c4>] netlink_unicast+0x1b1/0x20f
 [<c05ce577>] netlink_sendmsg+0x255/0x262
 [<c05af3f0>] sock_sendmsg+0xde/0xf9
 [<c0437b0f>] ? autoremove_wake_function+0x0/0x33
 [<c04ce6c7>] ? avc_has_perm+0x39/0x43
 [<c05afc84>] sys_sendto+0xa4/0xc3
 [<c05afe09>] ? move_addr_to_user+0x56/0x6e
 [<c05b013f>] ? sys_getsockname+0x59/0x76
 [<c04d27c7>] ? selinux_d_instantiate+0x12/0x14
 [<c04cbcb0>] ? security_d_instantiate+0x1c/0x1e
 [<c05af078>] ? sock_attach_fd+0x6c/0x9a
 [<c05b03cb>] sys_socketcall+0xfb/0x188
 [<c0405bf2>] syscall_call+0x7/0xb
 =======================

With CVS driver:

usb 3-2: new full speed USB device using uhci_hcd and address 2
usb 3-2: configuration #1 chosen from 1 choice
usb 3-2: New USB device found, idVendor=077b, idProduct=2219
usb 3-2: New USB device strings: Mfr=0, Product=0, SerialNumber=0
usb 3-2: using firmware atmel_at76c503-rfmd.bin (version 1.101.0-84)
wlan0: USB 3-2:1.0, MAC 00:06:25:0f:02:94, firmware 1.101.4-84

With Fedora kernel driver:

usb 3-2: new full speed USB device using uhci_hcd and address 2
usb 3-2: configuration #1 chosen from 1 choice
usb 3-2: New USB device found, idVendor=077b, idProduct=2219
usb 3-2: New USB device strings: Mfr=0, Product=0, SerialNumber=0
usb 3-2: reset full speed USB device using uhci_hcd and address 2
usb 3-2: device firmware changed
usb 3-2: USB disconnect, address 2
usb 3-2: new full speed USB device using uhci_hcd and address 3
usb 3-2: configuration #1 chosen from 1 choice
usb 3-2: New USB device found, idVendor=077b, idProduct=2219
usb 3-2: New USB device strings: Mfr=0, Product=0, SerialNumber=0
phy0: USB 3-2:1.0, MAC 00:06:25:0f:02:94, firmware 1.101.4-84

Other information:

00:00.0 Host bridge: VIA Technologies, Inc. VT8377 [KT400/KT600 AGP] Host Bridge
00:01.0 PCI bridge: VIA Technologies, Inc. VT8235 PCI Bridge
00:0c.0 Mass storage controller: Promise Technology, Inc. PDC40718 (SATA 300
TX4) (rev 02)
00:0d.0 Ethernet controller: Digital Equipment Corporation DECchip 21140
[FasterNet] (rev 22)
00:10.0 USB Controller: VIA Technologies, Inc. VT82xxxxx UHCI USB 1.1 Controller
(rev 80)
00:10.1 USB Controller: VIA Technologies, Inc. VT82xxxxx UHCI USB 1.1 Controller
(rev 80)
00:10.2 USB Controller: VIA Technologies, Inc. VT82xxxxx UHCI USB 1.1 Controller
(rev 80)
00:10.3 USB Controller: VIA Technologies, Inc. USB 2.0 (rev 82)
00:11.0 ISA bridge: VIA Technologies, Inc. VT8235 ISA Bridge
00:11.1 IDE interface: VIA Technologies, Inc.
VT82C586A/B/VT82C686/A/B/VT823x/A/C PIPC Bus Master IDE (rev 06)
00:12.0 Ethernet controller: VIA Technologies, Inc. VT6102 [Rhine-II] (rev 74)
01:00.0 VGA compatible controller: nVidia Corporation NV18 [GeForce4 MX 440 AGP
8x] (rev a2)

Bus 001 Device 003: ID 09cc:2106 Workbit Corp.
Bus 001 Device 002: ID 13b1:0029 Linksys
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 003 Device 002: ID 077b:2219 Linksys WUSB11 V2.6 802.11b Adapter
Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub

(The "13b1:0029" is a WUSB300N that is currently unused for different
bug-related reasons.)
Comment 23 Fred Odendaal 2008-07-13 12:05:54 EDT
Still broken in 2.6.25.9-40.fc8.

I'd really like to upgrade to fc9, but am afraid to because I don't want to lose
networking. Perhaps I'll see if I can get the Berlios driver working like George
did, and like I used to have to.

John, I haven't heard anything from the driver contributors. I'm available for
any testing they'd like me to do. I'm fairly computer literate as I've
contributed a SANE driver of my own for Lexmark scanners. So, I'd feel
comfortable with compiling and testing debug loads of the at76_usb driver.



Comment 24 Lars Bjorndal 2008-07-15 17:33:17 EDT
I can confirm that the bug exists also for the F9 kernels up to now.
Comment 25 Fred Odendaal 2008-07-26 23:59:16 EDT
Still broken in 2.6.25.11-60.fc8.
Comment 26 John W. Linville 2008-08-01 17:05:47 EDT
Fred, I'm sorry I made you wait so long.  It sounds like the at76 developers
just won't be working on this for a while longer.

I have reverted to a version of at76_usb from just before the botched mac80211
port.  Please confirm that this version is working:

F8:

   http://koji.fedoraproject.org/koji/buildinfo?buildID=58276

F9:

   http://koji.fedoraproject.org/koji/buildinfo?buildID=58278

Does that make things better?
Comment 27 Fred Odendaal 2008-08-12 20:48:08 EDT
It's fixed in 2.6.25.14-69.fc8!
Comment 28 Fred Odendaal 2008-09-14 21:16:45 EDT
Broken again in 2.6.26.3-14.fc8 -looks like the reverted version change wasn't permanent!
Comment 29 Allen Halsey 2008-09-25 01:23:17 EDT
I just wanted to document which kernels worked with my atmel-based Linksys WUSB11 v2.6. I installed Fedora 9 using the Fedora Unity 20080718 respin, which gave me kernel-2.6.25.10-86.fc9.i686, so I'll start there:

  kernel             at76_usb worked?  Depends on mac80211
  -----------------  ----------------  -------------------
  2.6.25.10-86.fc9            No       Yes
  2.6.25.14-108.fc9           Yes      No
  2.6.26.3-29.fc9             No       Yes
  2.6.26.5-39.fc9             No       Yes
  2.6.27-0.329.rc6.git2.fc10  Yes      No
  
The "Depends on mac80211" column was determined by:

  modprobe --show-depends at76_usb
  
Basically, at this time, you want to use a kernel that does not contain the at76_usb's port to mac80211.

If you just installed F9 and you are trying to get your wireless working, you can download the 2.6.25.14-108.fc9 kernel rpm from:

  http://koji.fedoraproject.org/koji/buildinfo?buildID=58531

I downloaded it on another computer and transferred it to my Fedora 9 box using a flash drive. I also had to download *iwl4965-firmware-228.57.2.21-1.noarch.rpm*, to satisfy a dependency. I installed them using:



 # rpm -Uvh iwl4965-firmware-228.57.2.21-1.noarch.rpm



 # yum --disablerepo=* localinstall kernel-2.6.25.14-108.fc9.i686.rpm



Note: I disabled all repos, otherwise yum will fail when trying to access the network (unless, of course, you have a wired ethernet connection working).



I used yum to install the kernel because it updates grub.conf so that the newly installed kernel will show up on the Grub menu.



I did get a SE LINUX error:



  SELinux is preventing restorecon (setfiles_t) "read" to

  /var/lib/dhclient/dhclient-wlan0.leases (dhcpc_state_t).



but my connection worked anyway. I followed the instructions in the SELinux error message to prevent the error from re-occurring.

I am currently running the rawhide kernel, which I easily installed using:

  # yum --enablerepo=rawhide install kernel
Comment 30 John W. Linville 2008-09-25 15:34:23 EDT
Hmmm...so you are saying the mac80211-based version came back in the 2.6.26 kernels?  But it is gone again in rawhide?  I'll have to investigate that...
Comment 31 John W. Linville 2008-09-25 15:41:23 EDT
Looks like Chuck un-did my revert of the at76 mac80211 bits, but I don't see any indication in the changelog as to why.  I'll have to defer to him for an explanation/resolution.
Comment 32 Chuck Ebbert 2008-10-03 23:55:14 EDT
(In reply to comment #31)
> Looks like Chuck un-did my revert of the at76 mac80211 bits, but I don't see
> any indication in the changelog as to why.  I'll have to defer to him for an
> explanation/resolution.

As part of updating to 2.6.26, I copied what was in the rawhide 2.6.26 kernel into the F9 and F8 kernels. What was I supposed to do??
Comment 33 John W. Linville 2008-10-06 11:28:01 EDT
Well, we might have been the victims of some poor timing... :-)

I have re-reverted the at76 mac80211 change in F-8 and F-9 -- it will take some time to get those kernels built and released as updates.
Comment 34 John W. Linville 2008-10-06 19:41:13 EDT
Kernels available in Koji...

F-9:

   http://koji.fedoraproject.org/koji/buildinfo?buildID=65490

F-8:

   http://koji.fedoraproject.org/koji/buildinfo?buildID=65454
Comment 35 Fedora Update System 2008-10-14 15:51:07 EDT
kernel-2.6.26.6-46.fc8 has been submitted as an update for Fedora 8.
http://admin.fedoraproject.org/updates/kernel-2.6.26.6-46.fc8
Comment 36 Fedora Update System 2008-10-14 16:02:29 EDT
kernel-2.6.26.6-71.fc9 has been submitted as an update for Fedora 9.
http://admin.fedoraproject.org/updates/kernel-2.6.26.6-71.fc9
Comment 37 Fedora Update System 2008-10-20 16:29:16 EDT
kernel-2.6.26.6-79.fc9 has been pushed to the Fedora 9 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update kernel'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F9/FEDORA-2008-8929
Comment 38 Fedora Update System 2008-10-23 12:38:45 EDT
kernel-2.6.26.6-79.fc9 has been pushed to the Fedora 9 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.