Bug 438633 - yum traceback when doing a search, after update to rawhide version on top of mostly F8
yum traceback when doing a search, after update to rawhide version on top of ...
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: yum (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Seth Vidal
Fedora Extras Quality Assurance
:
: 438849 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-03-23 12:06 EDT by Bill Crawford
Modified: 2014-01-21 18:02 EST (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-03-25 07:48:56 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
UnicodeEncodeError: 'ascii' codec can't encode character u'\xae' in position 19: ordinal not in range(128) (9.79 KB, text/plain)
2008-04-11 06:44 EDT, David Timms
no flags Details

  None (edit)
Description Bill Crawford 2008-03-23 12:06:15 EDT
Description of problem:
[root@pikachu ~]# yum search xaos

Traceback (most recent call last):
  File "/usr/bin/yum", line 29, in <module>
    yummain.user_main(sys.argv[1:], exit_code=True)
  File "/usr/share/yum-cli/yummain.py", line 236, in user_main
    errcode = main(args)
  File "/usr/share/yum-cli/yummain.py", line 111, in main
    result, resultmsgs = base.doCommands()
  File "/usr/share/yum-cli/cli.py", line 309, in doCommands
    return self.yum_cli_commands[self.basecmd].doCommand(self, self.basecmd, 
self.extcmds)
  File "/usr/share/yum-cli/yumcommands.py", line 498, in doCommand
    return base.search(extcmds)
  File "/usr/share/yum-cli/cli.py", line 687, in search
    for (po, matched_value) in matching:
  File "/usr/lib/python2.5/site-packages/yum/__init__.py", line 1495, in 
searchGenerator
    value = unicode(value,'unicode-escape')
UnicodeDecodeError: 'unicodeescape' codec can't decode bytes in position 
131-133: truncated \uXXXX escape

Version-Release number of selected component (if applicable):
3.2.12-4.fc9.noarch

How reproducible:
yum search xaos

Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
I've updated glibc / libstdc++, Xorg stack, python, rpm, yum and a handful of 
odd things like xscreensaver to rawhide versions. There was no problem with 
yum (F8 version) after updating most of the other components, so I'm presuming 
this is a problem specific to rawhide yum run on not-rawhide (but might well 
turn out to be some overlooked python module I need to install or update).

What do you need to help debug this?
Comment 1 Bill Crawford 2008-03-24 06:53:54 EDT
value: This package contains support for using UTF-8 as input encoding in
LaTeX documents.
The simplest use of this package is to add
    \usepackage{ucs}
    \usepackage[utf8]{inputenc}
to your header. You may even omit the first line in many cases.

Traceback (most recent call last):
  File "/usr/bin/yum", line 29, in <module>
    yummain.user_main(sys.argv[1:], exit_code=True)
  File "/usr/share/yum-cli/yummain.py", line 236, in user_main
    errcode = main(args)
  File "/usr/share/yum-cli/yummain.py", line 111, in main
    result, resultmsgs = base.doCommands()
  File "/usr/share/yum-cli/cli.py", line 309, in doCommands
    return self.yum_cli_commands[self.basecmd].doCommand(self, self.basecmd, 
self.extcmds)
  File "/usr/share/yum-cli/yumcommands.py", line 498, in doCommand
    return base.search(extcmds)
  File "/usr/share/yum-cli/cli.py", line 687, in search
    for (po, matched_value) in matching:
  File "/usr/lib/python2.5/site-packages/yum/__init__.py", line 1496, in 
searchGenerator
    value = unicode(value,'unicode-escape')
UnicodeDecodeError: 'unicodeescape' codec can't decode bytes in position 
131-133: truncated \uXXXX escape
Comment 2 Tim Lauridsen 2008-03-25 07:23:35 EDT
The problem is that the description contains a '\u' this is parsed as a Unicode
control char when converting the description to unicode :(
I will need to make some ugly hack to avoid this :(
Comment 3 Tim Lauridsen 2008-03-25 07:35:06 EDT
the package causing the issue is tetex-unicode in development, but the strange
stuff, is that i can't reproduce the error.
'yum search xeos' dont give me any errors, running current yum head.

what is your locale ?
Comment 4 Tim Lauridsen 2008-03-25 07:48:56 EDT
OK, i managed to reproduce it, tetex-unicode need to be installed to get the error.
I have fixed it upstream, without doing ugly hacks :)
Comment 5 Tim Lauridsen 2008-03-25 12:37:08 EDT
*** Bug 438849 has been marked as a duplicate of this bug. ***
Comment 6 Charles R. Anderson 2008-03-30 10:37:55 EDT
Same issue in yum-3.2.13-1.fc9.noarch.
Comment 7 David Timms 2008-04-11 06:44:00 EDT
Created attachment 302102 [details]
UnicodeEncodeError: 'ascii' codec can't encode character u'\xae' in position 19: ordinal not in range(128)

The above occurred with yum-3.2.14-2.fc9.noarch.rpm running: yum search *usb*
Updating to koji:
http://koji.fedoraproject.org/packages/yum/3.2.14/5.fc9/noarch/yum-3.2.14-5.fc9.noarch.rpm
see { bug 441659 }
, solves it for the same test command - it then gives addition answers:
multican.i386 : Remote control utility for Canon cameras
Matched from:
Multican is Canon EOS class USB remote control utility for 300D, 350D,
30D, 20D and 5D. It is possible to control more of Canon cameras in
the same time up to six cameras attached. Multican allows scripted
remote control of multiple cameras.

rt73usb-firmware.noarch : Firmware for Ralink® RT2571W/RT2671 A/B/G network
			: adaptors
Matched from:
rt73usb-firmware
This package contains the firmware required by the rt73usb driver for Linux.
Usage of the firmware is subject to the terms and conditions contained
inside the provided LICENSE.ralink-firmware.txt file.
Please read it carefully.

scanbuttond.i386 : Scanner Button tools to SANE
Matched from:
Modern scanners usually have several front panel buttons which are intended to
trigger certain actions like copying, faxing or mailing the scanned document.
This daemon monitors the scanner's buttons and runs a shell script whenever one

of these buttons has been pressed. Because it is accessing the scanner directly

via libusb, there should be no conflicts with SANE or other scanner drivers:
scanbuttond simply won't touch the scanner hardware while you are using SANE.

Note You need to log in before you can comment on or make changes to this bug.