Bug 438641 - yum-changelog plugin causes yum backtrace - ImportError: No module named dateutil.parser
yum-changelog plugin causes yum backtrace - ImportError: No module named date...
Status: CLOSED DUPLICATE of bug 438585
Product: Fedora
Classification: Fedora
Component: yum-utils (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Seth Vidal
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-03-23 15:16 EDT by Reindl Harald
Modified: 2014-01-21 18:02 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-03-23 17:49:12 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Reindl Harald 2008-03-23 15:16:10 EDT
[root@fedora-test:~]$ yum
Traceback (most recent call last):
  File "/usr/bin/yum", line 29, in <module>
    yummain.user_main(sys.argv[1:], exit_code=True)
  File "/usr/share/yum-cli/yummain.py", line 236, in user_main
    errcode = main(args)
  File "/usr/share/yum-cli/yummain.py", line 91, in main
    base.getOptionsConfig(args)
  File "/usr/share/yum-cli/cli.py", line 180, in getOptionsConfig
    disabled_plugins=self.optparser._splitArg(opts.disableplugins))
  File "/usr/lib/python2.5/site-packages/yum/__init__.py", line 168, in _getConfig
    startupconf.pluginconfpath,disabled_plugins)
  File "/usr/lib/python2.5/site-packages/yum/__init__.py", line 335, in
doPluginSetup
    plugin_types, confpath, disabled_plugins)
  File "/usr/lib/python2.5/site-packages/yum/plugins.py", line 149, in __init__
    self._importplugins(types)
  File "/usr/lib/python2.5/site-packages/yum/plugins.py", line 191, in
_importplugins
    self._loadplugin(modulefile, types)
  File "/usr/lib/python2.5/site-packages/yum/plugins.py", line 224, in _loadplugin
    module = imp.load_module(modname, fp, pathname, description)
  File "/usr/lib/yum-plugins/changelog.py", line 29, in <module>
    import dateutil.parser
ImportError: No module named dateutil.parser
_____________

[root@fedora-test:~]$ cat /var/log/messages | grep yum
Mar 23 12:58:42 fedora-test yum: Updated: newt-0.52.9-1.fc9.i386
Mar 23 12:58:49 fedora-test yum: Updated: gnokii-0.6.24-1.fc9.i386
Mar 23 12:58:58 fedora-test yum: Updated: gvfs-0.2.1-3.fc9.i386
Mar 23 12:59:01 fedora-test yum: Updated: cairomm-1.5.0-1.fc9.i386
Mar 23 12:59:02 fedora-test yum: Updated: newt-python-0.52.9-1.fc9.i386
Mar 23 12:59:02 fedora-test yum: Updated: dvipdfm-0.13.2d-28.fc9.i386
Mar 23 12:59:06 fedora-test yum: Updated: man-1.6f-2.fc9.i386
Mar 23 13:02:40 fedora-test yum: Installed: kernel-2.6.25-0.139.rc6.git5.fc9.i686
Mar 23 13:02:41 fedora-test yum: Updated: mendexk-2.6e-28.fc9.i386
Mar 23 13:02:47 fedora-test yum: Updated: selinux-policy-3.3.1-23.fc9.noarch
Mar 23 13:02:47 fedora-test yum: Updated: newt-devel-0.52.9-1.fc9.i386
Mar 23 13:02:47 fedora-test yum: Updated: yum-changelog-1.1.13-1.fc9.noarch
Mar 23 13:02:48 fedora-test yum: Updated: yum-protect-packages-1.1.13-1.fc9.noarch
Mar 23 13:04:16 fedora-test yum: Installed:
kernel-devel-2.6.25-0.139.rc6.git5.fc9.i686
Mar 23 13:05:49 fedora-test yum: Updated:
selinux-policy-targeted-3.3.1-23.fc9.noarch
Mar 23 13:06:34 fedora-test yum: Updated: fedora-logos-8.0.3-2.fc9.noarch
Mar 23 13:06:34 fedora-test yum: Updated: yum-fedorakmod-1.1.13-1.fc9.noarch
Mar 23 13:06:35 fedora-test yum: Updated: yum-security-1.1.13-1.fc9.noarch
Mar 23 13:06:45 fedora-test yum: Updated: firefox-3.0-0.46.cvs20080320.fc9.i386
Mar 23 13:06:46 fedora-test yum: Updated: yum-kernel-module-1.1.13-1.fc9.noarch
Mar 23 13:06:47 fedora-test yum: Updated: gnome-audio-2.22.0-1.noarch
Mar 23 13:06:47 fedora-test yum: Updated: yum-allowdowngrade-1.1.13-1.fc9.noarch
Mar 23 13:06:48 fedora-test yum: Updated: yum-utils-1.1.13-1.fc9.noarch
Mar 23 13:06:54 fedora-test yum: Updated:
kernel-headers-2.6.25-0.139.rc6.git5.fc9.i386
Mar 23 13:06:54 fedora-test yum: Updated: yum-fastestmirror-1.1.13-1.fc9.noarch
Mar 23 13:08:03 fedora-test yum: Installed: kernel-2.6.25-0.139.rc6.git5.fc9.i686
Comment 1 Jon Stanley 2008-03-23 16:09:38 EDT
Changing component to yum-utils.  This is caused by the yum-changelog plugin. 
Simply using --disableplugin=changelog is not enough to get around it, though. 
You need to use yum --noplugins or remove yum-changelog.
Comment 2 Reindl Harald 2008-03-23 16:27:01 EDT
Yes, i can confirm this
After a "rpm -e yum-changelog" it works again
thank you for the information
Comment 3 Adrian "Adi1981" P. 2008-03-23 16:38:48 EDT
Already solved upstream - see BZ #438585
Comment 4 Jon Stanley 2008-03-23 17:49:12 EDT

*** This bug has been marked as a duplicate of 438585 ***

Note You need to log in before you can comment on or make changes to this bug.