Bug 438585 - Yum-changelog plugin causes yum to crash.
Yum-changelog plugin causes yum to crash.
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: yum (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Seth Vidal
Fedora Extras Quality Assurance
:
: 438641 438684 438925 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-03-22 10:14 EDT by Adrian "Adi1981" P.
Modified: 2014-01-21 18:02 EST (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-03-22 10:46:20 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Adrian "Adi1981" P. 2008-03-22 10:14:52 EDT
Description of problem:
After updateing yum\* today, next try of "yum update/install" gives:

Traceback (most recent call last):
  File "/usr/bin/yum", line 29, in <module>
    yummain.user_main(sys.argv[1:], exit_code=True)
  File "/usr/share/yum-cli/yummain.py", line 236, in user_main
    errcode = main(args)
  File "/usr/share/yum-cli/yummain.py", line 91, in main
    base.getOptionsConfig(args)
  File "/usr/share/yum-cli/cli.py", line 180, in getOptionsConfig
    disabled_plugins=self.optparser._splitArg(opts.disableplugins))
  File "/usr/lib/python2.5/site-packages/yum/__init__.py", line 168, in _getConfig
    startupconf.pluginconfpath,disabled_plugins)
  File "/usr/lib/python2.5/site-packages/yum/__init__.py", line 335, in
doPluginSetup
    plugin_types, confpath, disabled_plugins)
  File "/usr/lib/python2.5/site-packages/yum/plugins.py", line 149, in __init__
    self._importplugins(types)
  File "/usr/lib/python2.5/site-packages/yum/plugins.py", line 191, in
_importplugins
    self._loadplugin(modulefile, types)
  File "/usr/lib/python2.5/site-packages/yum/plugins.py", line 224, in _loadplugin
    module = imp.load_module(modname, fp, pathname, description)
  File "/usr/lib/yum-plugins/changelog.py", line 29, in <module>
    import dateutil.parser
ImportError: No module named dateutil.parser

Disabling yum-changelog plugin helps.

Version-Release number of selected component (if applicable):
yum-changelog-1.1.13-1.fc9.noarch

How reproducible:
Always

Steps to Reproduce:
1. yum update yum-changelog
2. yum update / yum install / yum whatever 
  
Actual results:
Error listed above.
Comment 1 Seth Vidal 2008-03-22 10:46:20 EDT
yum --noplugins install python-dateutil will fix the above.

and I've updated the spec file. It will be fixed in the next build of yum-utils
for rawhide.

thank you.
Comment 2 Jon Stanley 2008-03-23 17:49:13 EDT
*** Bug 438641 has been marked as a duplicate of this bug. ***
Comment 3 Seth Vidal 2008-03-24 10:11:08 EDT
*** Bug 438684 has been marked as a duplicate of this bug. ***
Comment 4 James Antill 2008-03-25 21:14:34 EDT
*** Bug 438925 has been marked as a duplicate of this bug. ***
Comment 5 Fedora Update System 2008-05-21 08:43:10 EDT
yum-utils-1.1.14-1.fc9 has been submitted as an update for Fedora 9
Comment 6 Fedora Update System 2008-05-21 08:44:54 EDT
yum-utils-1.1.14-1.fc8 has been submitted as an update for Fedora 8

Note You need to log in before you can comment on or make changes to this bug.