Bug 438684 - yum-changelog 1.1.13 misses dependency on python-dateutil
yum-changelog 1.1.13 misses dependency on python-dateutil
Status: CLOSED DUPLICATE of bug 438585
Product: Fedora
Classification: Fedora
Component: yum (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Seth Vidal
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-03-24 09:55 EDT by Dominik Sandjaja
Modified: 2014-01-21 18:02 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-03-24 10:11:06 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dominik Sandjaja 2008-03-24 09:55:44 EDT
Description of problem:
yum cannot be used after updating yum-changelog to 1.1.13-1.fc9. Error:

[root@illuminati ~]# yum
Traceback (most recent call last):
  File "/usr/bin/yum", line 29, in <module>
    yummain.user_main(sys.argv[1:], exit_code=True)
  File "/usr/share/yum-cli/yummain.py", line 236, in user_main
    errcode = main(args)
  File "/usr/share/yum-cli/yummain.py", line 91, in main
    base.getOptionsConfig(args)
  File "/usr/share/yum-cli/cli.py", line 180, in getOptionsConfig
    disabled_plugins=self.optparser._splitArg(opts.disableplugins))
  File "/usr/lib/python2.5/site-packages/yum/__init__.py", line 168, in _getConfig
    startupconf.pluginconfpath,disabled_plugins)
  File "/usr/lib/python2.5/site-packages/yum/__init__.py", line 335, in
doPluginSetup
    plugin_types, confpath, disabled_plugins)
  File "/usr/lib/python2.5/site-packages/yum/plugins.py", line 149, in __init__
    self._importplugins(types)
  File "/usr/lib/python2.5/site-packages/yum/plugins.py", line 191, in
_importplugins
    self._loadplugin(modulefile, types)
  File "/usr/lib/python2.5/site-packages/yum/plugins.py", line 224, in _loadplugin
    module = imp.load_module(modname, fp, pathname, description)
  File "/usr/lib/yum-plugins/changelog.py", line 29, in <module>
    import dateutil.parser
ImportError: No module named dateutil.parser

Version-Release number of selected component (if applicable):
yum-3.2.13-1.fc9.noarch
yum-changelog-1.1.13-1.fc9.noarch

Additional info:
It helps to either install python-dateutil, use yum --noplugins or to remove
yum-changelog.

Adding python-dateutil to the dependencies of yum-changelog should help to solve
that problem.
Comment 1 Seth Vidal 2008-03-24 10:11:06 EDT

*** This bug has been marked as a duplicate of 438585 ***

Note You need to log in before you can comment on or make changes to this bug.