Bug 438765 - Cannot rescue a bad MBR with grub-install due to bad path to grub
Cannot rescue a bad MBR with grub-install due to bad path to grub
Status: CLOSED DUPLICATE of bug 422641
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: grub (Show other bugs)
All Linux
medium Severity medium
: rc
: ---
Assigned To: Václav Pavlín
Depends On:
  Show dependency treegraph
Reported: 2008-03-24 19:39 EDT by Don Dutile
Modified: 2013-01-14 09:55 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2013-01-14 09:55:49 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Don Dutile 2008-03-24 19:39:52 EDT
Description of problem:
When booting into rescue mode (linux rescue) from boot.iso,
once one gets to the system prompt and tries to execute 
'grub-install --root-directory=/mnt/sysimage /dev/sda'
it returns with a failure of 'can't find /sbin/grub' or 
'/sbin/grub not found', or some such.

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1. boot system into rescue mode (linux rescue from boot.iso prompt)
2. once to system prompt, enter 'grub-install --root-directory=/mnt/sysimage
Actual results:
/sbin/grub not found

Expected results:
grub-install fixes/sets up MBR for grub

Additional info:
If one symlinks /usr/sbin/grub to /sbin/grub, the above works.
So, either the path in grub-install needs to be changed to
/usr/sbin/grub, or $PWD/grub, or a symlink from /usr/sbin/grub to /sbin/grub
must be added, or the hard-path shouldn't be wired and let the PATH variable
resolve it.
Comment 1 Ed Avis 2009-08-16 11:08:01 EDT
I suggest marking this as a duplicate of #422641.
Comment 2 Václav Pavlín 2013-01-14 09:55:49 EST

*** This bug has been marked as a duplicate of bug 422641 ***

Note You need to log in before you can comment on or make changes to this bug.