Bug 438797 - UnicodeDecodeError: 'ascii' codec can't decode byte 0xc2 in position 19: ordinal not in range(128)
UnicodeDecodeError: 'ascii' codec can't decode byte 0xc2 in position 19: ordi...
Status: CLOSED DUPLICATE of bug 437993
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
powerpc Linux
low Severity medium
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-03-25 07:46 EDT by James Laska
Modified: 2013-09-02 02:24 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-03-25 09:18:10 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
anacdump.txt (462.09 KB, text/plain)
2008-03-25 07:46 EDT, James Laska
no flags Details

  None (edit)
Description James Laska 2008-03-25 07:46:13 EDT
Testing against rawhide (20080324), anaconda-11.4.0.55, observing a
UnicodeDecodeError during package installation.  I know there are several of
these floating around, so I'll be happy to dupe if needed.  They all seem to
surface at different spots during package install.

Welcome to Fedora for ppc
                                                                                
     ┌─────────────────────┤ Package Installation ├──────────────────────┐      
     │                                                                   │      
     │                                                                   │      
     │                                 1%                                │      
     │                                                                   │      
     │                   23 of 899 packages completed                    │      
     │                                                                   │      
     │                                                                   │      
     │                                                                   │      
     │                                                                   │      
     │                                                                   │      
     │                                                                   │      
     └───────────────────────────────────────────────────────────────────┘      
                                                                                
                                                                                
                                                                                
                                                                                

anaconda 11.4.0.55 exception report                                            
Traceback (most recent call first):
  File "/usr/lib/anaconda/yuminstall.py", line 160, in callback
    s += (hdr['summary'] or "")
  File "/usr/lib/python2.5/site-packages/yum/__init__.py", line 764, in
runTransaction
    errors = self.ts.run(cb.callback, '')
  File "/usr/lib/anaconda/yuminstall.py", line 698, in _run
    self.runTransaction(cb=cb)
  File "/usr/lib/anaconda/yuminstall.py", line 682, in run
    if self._run(instLog, cb, intf) == DISPATCH_BACK:
  File "/usr/lib/anaconda/yuminstall.py", line 1478, in doInstall
    rc = self.ayum.run(self.instLog, cb, anaconda.intf, anaconda.id)
  File "/usr/lib/anaconda/backend.py", line 209, in doInstall
    return anaconda.backend.doInstall(anaconda)
  File "/usr/lib/anaconda/dispatch.py", line 208, in moveStep
    rc = stepFunc(self.anaconda)
  File "/usr/lib/anaconda/dispatch.py", line 131, in gotoNext
    self.moveStep()
  File "/usr/lib/anaconda/text.py", line 701, in run
    anaconda.dispatch.gotoNext()
  File "/usr/bin/anaconda", line 1046, in <module>
    anaconda.intf.run(anaconda)
UnicodeDecodeError: 'ascii' codec can't decode byte 0xc2 in position 19: ordinal
not in range(128)


The package being installed is (or is right after): ql2100-firmware

sh-3.2# tail /mnt/sysimage/root/install.log
Installing xorg-x11-server-common-1.4.99.901-10.20080314.fc9.ppc
Installing texlive-texmf-errata-latex-2007-4.fc9.noarch
Installing tzdata-2007k-2.fc9.noarch
Installing mythes-en-3.0-1.fc9.noarch
Installing ncurses-base-5.6-16.20080301.fc9.ppc
Installing fedora-bookmarks-8-1.noarch
Installing baekmuk-ttf-fonts-common-2.2-7.fc9.noarch
Installing tzdata-java-2007k-2.fc9.noarch
Installing gnome-backgrounds-2.22.0-1.fc9.noarch
Installing ql2100-firmware-1.19.38-1.fc8.1.noarch
Comment 1 James Laska 2008-03-25 07:46:59 EDT
Created attachment 299008 [details]
anacdump.txt
Comment 2 Jeremy Katz 2008-03-25 09:18:10 EDT

*** This bug has been marked as a duplicate of 437993 ***

Note You need to log in before you can comment on or make changes to this bug.