Bug 438861 - ISE on scheduling deploying config files if the Enable Config option is not selected in the KS profile.
ISE on scheduling deploying config files if the Enable Config option is not s...
Status: CLOSED DUPLICATE of bug 437532
Product: Red Hat Satellite 5
Classification: Red Hat
Component: WebUI (Show other bugs)
510
All Linux
high Severity high
: ---
: ---
Assigned To: Partha Aji
Brandon Perkins
https://test10-64.rhndev.redhat.com/r...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-03-25 13:24 EDT by Preethi Thomas
Modified: 2008-04-25 17:09 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-04-24 11:56:43 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Preethi Thomas 2008-03-25 13:24:12 EDT
Description of problem:
ISE on scheduling deploying config files on a Kickstarted client if the Enable
Config option is not selected in the ks profile and

Version-Release number of selected component (if applicable):

 rhn-satellite-5.1.0-179-redhat-linux-as-i386-4-embedded-oracle.iso 

How reproducible:
always

Steps to Reproduce:
1. Register a client and enable provisioning.
2. Create a config channel and add a config file and subscribe it to the system
3. create an activation key and subscribe it to the config
channel.(Activationkey -> Configuration)
4. Create a KS profile. Do not enable configuration management.
5. Attach the activation key to the KS profile.
6. Schedule kickstart.
7. Once the ks is complete, schedule a config file deploy.
 SDC -> Configuration -> Deploy Files 
8. Click on schedule deploy.
  
Actual results:

 ISE
Expected results:
 User should not be able to get this far if the Enable Configuration Option is
not selected for KS profile.

Additional info:
Comment 1 Preethi Thomas 2008-03-25 13:37:56 EDT
trace back

- -------- Original Message --------
Subject: WEB TRACEBACK from test10-64.rhndev.redhat.com (3/25/08 1:00:20
PM EDT)
Date: Tue, 25 Mar 2008 13:00:20 -0400
From: Red Hat Network <dev-null@redhat.com>
To: bperkins@redhat.com

The following exception occurred while executing this request:
POST /rhn/systems/details/configuration/DeployFileConfirmSubmit.do

Date:3/25/08 1:00:20 PM EDT
Headers:
  host: test10-64.rhndev.redhat.com
  user-agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.0.10)
Gecko/20070312 Red Hat/1.5.0.10-2.el5 Firefox/1.5.0.10
  accept:
text/xml,application/xml,application/xhtml+xml,text/html;q=0.9,text/plain;q=0.8,image/png,*/*;q=0.5
  accept-language: en-us,ar;q=0.8,ja;q=0.5,ml;q=0.3
  accept-encoding: gzip,deflate
  accept-charset: ISO-8859-1,utf-8;q=0.7,*;q=0.7
  Keep-Alive: 300
  connection: keep-alive
  referer:
https://test10-64.rhndev.redhat.com/rhn/systems/details/configuration/DeployFileConfirm.do?sid=1000012033
  cookie: JSESSIONID=170A91D52F70946E3957F222982320E2;
s_vi=[CS]v1|46A7902F00005CEC-A160B3400002EA1[CE];
rh_omni_tc=natural_seo;
pxt-session-cookie=18899x1ae4cf4cc8575cc5b20c726b715808c1
  content-type: application/x-www-form-urlencoded
  content-length: 180

Request:
Local Name = test10-64.rhndev.redhat.com
Server Name = test10-64.rhndev.redhat.com
Requested Session Id came from Cookie
Requested Session Valid = true
Session =
org.apache.catalina.session.StandardSessionFacade@3a7cac83[session=StandardSession[170A91D52F70946E3957F222982320E2]]
Protocol = https
Request Locale = en_US
Request Character Encoding = UTF-8
Attribute Names = rhnActiveLang,
javax.servlet.jsp.jstl.fmt.timeZone.request, session, datePickerForm,
org.apache.struts.action.MODULE, org.apache.struts.action.MESSAGE,
__sitemesh__filterapplied, requestedUri,
org.apache.struts.action.mapping.instance,

Form Variables:
  date_year: 2008
  next_lower: 21
  sid: 1000012033
  last_lower: 1
  use_date: false
  first_lower: 1
  date_month: 2
  prev_lower: 1
  date_minute: 0
  date_day: 25
  date_hour: 1
  lower: 1
  dispatch: Schedule Deploy
  date_am_pm: 1


User Information:
User pthomas (id 45, org_id 30)

Exception:
javax.servlet.ServletException: Missing Client Capability ->
configfiles.deploy for the server
[com.redhat.rhn.domain.server.Server@1bde5896[id=1000012033,org=com.redhat.rhn.domain.org.OrgImpl@638d92d1[id=30,name=Preethi
Thomas],name=fjs-0-13.rhndev.redhat.com,description=Initial Registration
Parameters:
OS: redhat-release
Release: 4AS
CPU Arch: i686-redhat-linux]]. The server will be unable to deploy
config files until this capability is provided.
	at
org.apache.struts.action.RequestProcessor.processException(RequestProcessor.java:535)
	at
org.apache.struts.action.RequestProcessor.processActionPerform(RequestProcessor.java:433)
	at
org.apache.struts.action.RequestProcessor.process(RequestProcessor.java:236)
	at
com.redhat.rhn.frontend.struts.RhnRequestProcessor.process(RhnRequestProcessor.java:78)
	at org.apache.struts.action.ActionServlet.process(ActionServlet.java:1196)
	at org.apache.struts.action.ActionServlet.doPost(ActionServlet.java:432)
	at javax.servlet.http.HttpServlet.service(HttpServlet.java:763)
	at javax.servlet.http.HttpServlet.service(HttpServlet.java:856)
	at
org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:252)
	at
org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:173)
	at com.redhat.rhn.frontend.servlets.AuthFilter.doFilter(AuthFilter.java:69)
	at
org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:202)
	at
org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:173)
	at
com.opensymphony.module.sitemesh.filter.PageFilter.parsePage(PageFilter.java:142)
	at
com.opensymphony.module.sitemesh.filter.PageFilter.doFilter(PageFilter.java:58)
	at
org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:202)
	at
org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:173)
	at
com.redhat.rhn.frontend.servlets.LocalizedEnvironmentFilter.doFilter(LocalizedEnvironmentFilter.java:63)
	at
org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:202)
	at
org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:173)
	at
com.redhat.rhn.frontend.servlets.EnvironmentFilter.doFilter(EnvironmentFilter.java:103)
	at
org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:202)
	at
org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:173)
	at
com.redhat.rhn.frontend.servlets.SessionFilter.doFilter(SessionFilter.java:51)
	at
org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:202)
	at
org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:173)
	at
com.redhat.rhn.frontend.servlets.SetCharacterEncodingFilter.doFilter(SetCharacterEncodingFilter.java:93)
	at
org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:202)
	at
org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:173)
	at
org.apache.catalina.core.StandardWrapperValve.invoke(StandardWrapperValve.java:214)
	at
org.apache.catalina.core.StandardValveContext.invokeNext(StandardValveContext.java:104)
	at
org.apache.catalina.core.StandardPipeline.invoke(StandardPipeline.java:520)
	at
org.apache.catalina.core.StandardContextValve.invokeInternal(StandardContextValve.java:198)
	at
org.apache.catalina.core.StandardContextValve.invoke(StandardContextValve.java:152)
	at
org.apache.catalina.core.StandardValveContext.invokeNext(StandardValveContext.java:104)
	at
org.apache.catalina.core.StandardPipeline.invoke(StandardPipeline.java:520)
	at
org.apache.catalina.core.StandardHostValve.invoke(StandardHostValve.java:137)
	at
org.apache.catalina.core.StandardValveContext.invokeNext(StandardValveContext.java:104)
	at
org.apache.catalina.valves.ErrorReportValve.invoke(ErrorReportValve.java:118)
	at
org.apache.catalina.core.StandardValveContext.invokeNext(StandardValveContext.java:102)
	at
org.apache.catalina.core.StandardPipeline.invoke(StandardPipeline.java:520)
	at
org.apache.catalina.core.StandardEngineValve.invoke(StandardEngineValve.java:109)
	at
org.apache.catalina.core.StandardValveContext.invokeNext(StandardValveContext.java:104)
	at
org.apache.catalina.core.StandardPipeline.invoke(StandardPipeline.java:520)
	at org.apache.catalina.core.ContainerBase.invoke(ContainerBase.java:929)
	at org.apache.coyote.tomcat5.CoyoteAdapter.service(CoyoteAdapter.java:162)
	at org.apache.jk.server.JkCoyoteHandler.invoke(JkCoyoteHandler.java:300)
	at org.apache.jk.common.HandlerRequest.invoke(HandlerRequest.java:374)
	at org.apache.jk.common.ChannelSocket.invoke(ChannelSocket.java:743)
	at
org.apache.jk.common.ChannelSocket.processConnection(ChannelSocket.java:675)
	at org.apache.jk.common.SocketConnection.runIt(ChannelSocket.java:866)
	at
org.apache.tomcat.util.threads.ThreadPool$ControlRunnable.run(ThreadPool.java:684)
	at java.lang.Thread.run(Thread.java:595)
Caused by: com.redhat.rhn.manager.MissingCapabilityException: Missing
Client Capability -> configfiles.deploy for the server
[com.redhat.rhn.domain.server.Server@1bde5896[id=1000012033,org=com.redhat.rhn.domain.org.OrgImpl@638d92d1[id=30,name=Preethi
Thomas],name=fjs-0-13.rhndev.redhat.com,description=Initial Registration
Parameters:
OS: redhat-release
Release: 4AS
CPU Arch: i686-redhat-linux]]. The server will be unable to deploy
config files until this capability is provided.
	at
com.redhat.rhn.manager.action.ActionManager.createConfigActionForServers(ActionManager.java:387)
	at
com.redhat.rhn.manager.action.ActionManager.createConfigAction(ActionManager.java:426)
	at
com.redhat.rhn.frontend.action.configuration.sdc.FileListConfirmSubmitAction.createRevisionAction(FileListConfirmSubmitAction.java:167)
	at
com.redhat.rhn.frontend.action.configuration.sdc.FileListConfirmSubmitAction.deploy(FileListConfirmSubmitAction.java:128)
	at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
	at
sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
	at
sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
	at java.lang.reflect.Method.invoke(Method.java:585)
	at
org.apache.struts.actions.DispatchAction.dispatchMethod(DispatchAction.java:270)
	at
org.apache.struts.actions.DispatchAction.execute(DispatchAction.java:187)
	at
org.apache.struts.actions.LookupDispatchAction.execute(LookupDispatchAction.java:150)
	at
org.apache.struts.action.RequestProcessor.processActionPerform(RequestProcessor.java:431)
	... 51 more

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.5 (GNU/Linux)
Comment: Using GnuPG with Red Hat - http://enigmail.mozdev.org

iD8DBQFH6S/5hwQhj8l1t/cRAr5+AJsGukIi94TUNmOlMejdaGo77VyIpwCgieUM
7TB9DYptt9tN4dYnXjyZeAE=
=dMj/
-----END PGP SIGNATURE-----

Note You need to log in before you can comment on or make changes to this bug.