Bug 438925 - Yum and /etc/yum/pluginconf.d/changelog.conf -> Yum crash
Yum and /etc/yum/pluginconf.d/changelog.conf -> Yum crash
Status: CLOSED DUPLICATE of bug 438585
Product: Fedora
Classification: Fedora
Component: yum (Show other bugs)
rawhide
All Linux
low Severity high
: ---
: ---
Assigned To: Seth Vidal
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-03-25 20:10 EDT by Couret Charles-Antoine
Modified: 2014-01-21 18:02 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-03-25 21:14:33 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Couret Charles-Antoine 2008-03-25 20:10:10 EDT
Description of problem: After a yum update or install, the component who use Yum
crash and Yum is not functional.


Version-Release number of selected component (if applicable):


How reproducible: do a update or an install with a component who use Yum and try
again.


Steps to Reproduce:
1. Use Yum with a software (Yumex, PackageKit, Yum in TTY, etc.)
2. Do an update or install to software
3. Restart yum
  
Actual results:
The software crash with the error message 

« Traceback (most recent call last):
  File "/usr/bin/yum", line 29, in <module>
    yummain.user_main(sys.argv[1:], exit_code=True)
  File "/usr/share/yum-cli/yummain.py", line 236, in user_main
    errcode = main(args)
  File "/usr/share/yum-cli/yummain.py", line 91, in main
    base.getOptionsConfig(args)
  File "/usr/share/yum-cli/cli.py", line 180, in getOptionsConfig
    disabled_plugins=self.optparser._splitArg(opts.disableplugins))
  File "/usr/lib/python2.5/site-packages/yum/__init__.py", line 168, in _getConfig
    startupconf.pluginconfpath,disabled_plugins)
  File "/usr/lib/python2.5/site-packages/yum/__init__.py", line 335, in
doPluginSetup
    plugin_types, confpath, disabled_plugins)
  File "/usr/lib/python2.5/site-packages/yum/plugins.py", line 149, in __init__
    self._importplugins(types)
  File "/usr/lib/python2.5/site-packages/yum/plugins.py", line 191, in
_importplugins
    self._loadplugin(modulefile, types)
  File "/usr/lib/python2.5/site-packages/yum/plugins.py", line 224, in _loadplugin
    module = imp.load_module(modname, fp, pathname, description)
  File "/usr/lib/yum-plugins/changelog.py", line 29, in <module>
    import dateutil.parser
ImportError: No module named dateutil.parser »

Expected results:


Additional info: Move /etc/yum/pluginconf.d/changelog.conf to an other folder
stop the bug for an new update/install before the bug start again.
Comment 1 James Antill 2008-03-25 21:14:33 EDT

*** This bug has been marked as a duplicate of 438585 ***

Note You need to log in before you can comment on or make changes to this bug.