Bug 438981 - Installer hangs when formating LVM volume
Installer hangs when formating LVM volume
Status: CLOSED DUPLICATE of bug 439633
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-03-26 07:58 EDT by Robert Petranović
Modified: 2008-04-21 04:16 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-04-21 04:16:34 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
The error log after crash (33.82 KB, text/plain)
2008-03-26 08:00 EDT, Robert Petranović
no flags Details

  None (edit)
Description Robert Petranović 2008-03-26 07:58:59 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.9b5pre) Gecko/2008031714 Fedora/3.0-0.44.cvs20080315.fc9 Minefield/3.0b5pre

Description of problem:
I tied to install Fedora from LiveCD (using gnome). I've choosed the remove existing Linux partitions and install from the default layout. I've unchecked the option encrypt and checked the option review layout.

The default layout seemed ok to me: it was formating swap, boot and LVM partitions. I haven't changed anything there, and clicked next. The popup box appeared to confirm my actions. After clicking OK, another popup appeared saying that there was an error and showing a log file I'm sending in attachment.

Version-Release number of selected component (if applicable):
11.4.0.55-1

How reproducible:
Always


Steps to Reproduce:
1.Boot from LiveCD (gnome)
2. Running anaconda (clicking Install to Hard drive icon)
3. Choosing to remove existing Linux partitions and install using default layout 

Actual Results:
The popup window appered showing error log

Expected Results:
Format the partitions and continue installing

Additional info:
[root@localhost fedora]# /sbin/fdisk -l
Device Boot      Start         End      Blocks   Id  System
/dev/sda1               1       10443    83883366    7  HPFS/NTFS
/dev/sda2           20072       30515    83891430    f  W95 Ext'd (LBA)
/dev/sda3   *       10444       10468      200812+  83  Linux
/dev/sda4           10469       20071    77136097+  8e  Linux LVM
/dev/sda5           21385       30515    73344757+   7  HPFS/NTFS
/dev/sda6           20072       21384    10546609+   7  HPFS/NTFS

Volumegroup: /dev/VolGroup00
Devices: LogVol00 ext3
         LogVol01 swap
Comment 1 Robert Petranović 2008-03-26 08:00:57 EDT
Created attachment 299135 [details]
The error log after crash
Comment 2 Robert Petranović 2008-03-26 08:23:30 EDT
Note that I have mount /dev/VolGroup00/LogVol00 before running installer, I
tried to umount it but it haven't worked.
Comment 3 Jeremy Katz 2008-03-26 09:47:52 EDT
Did /dev/sda4 exist at that point?
Comment 4 Robert Petranović 2008-03-26 15:07:12 EDT
(In reply to comment #3)
> Did /dev/sda4 exist at that point?
No, and that was the problem... It seemed weird to me that vgscan and lvscan
commands output I have no LVM drives. I've managed to "get back" the drive,
activate it, and then anaconda worked. I still think this like a bug, because
you can't use the drive before installation.
I'll put severity to medium.

Comment 5 Jeremy Katz 2008-03-26 17:12:38 EDT
Okay, udev is dying sometimes.  Chris reproduced a little earlier.  We're not
quite sure why yet
Comment 6 Chris Lumens 2008-04-20 16:36:16 EDT
I haven't seen this in a little while now.  Is it still happening in the preview
release?
Comment 7 Chris Lumens 2008-04-21 04:16:34 EDT

*** This bug has been marked as a duplicate of 439633 ***

Note You need to log in before you can comment on or make changes to this bug.