Bug 439633 - (NoDevNode) F9-Beta anaconda crash with PVCreateError
F9-Beta anaconda crash with PVCreateError
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
x86_64 Linux
low Severity low
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
NeedsRetesting
: Reopened
: 438981 439034 443361 443729 443828 443979 444233 445493 446590 446782 (view as bug list)
Depends On:
Blocks: F9Blocker
  Show dependency treegraph
 
Reported: 2008-03-29 16:53 EDT by Konstantin Ryabitsev
Modified: 2008-05-15 22:04 EDT (History)
12 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-05-08 04:53:08 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Dump of anaconda crash. (35.69 KB, application/x-bzip)
2008-03-29 16:53 EDT, Konstantin Ryabitsev
no flags Details
text version of the anaconda traceback in comment #1 (1.07 KB, text/plain)
2008-04-23 12:05 EDT, Chuck Ebbert
no flags Details

  None (edit)
Description Konstantin Ryabitsev 2008-03-29 16:53:07 EDT
Installing F9 Beta on a Macbook was unsuccessful, both times while trying to
create encrypted partitions.

Setup:
This was supposed to be a dual-boot with Leopard. Before install, partition
configuration was as such:

/dev/sda1 - EFI
/dev/sda2 - hfs+

First try was to do "use free space to create default layout", which resulted in:

/dev/sda3 - Boot
/dev/sda4 - Encrypted LVM

During the first try, I edited the names and layout of the LVM, creating:

/dev/lucius_vg/swap_lv
/dev/lucius_vg/root_lv
/dev/lucius_vg/home_lv

Attempting to write this partition layout to disk resulted in a crash (dump
attached). I then tried another time, this time without editing LVM groups nor
adding a separate home partition, however anaconda seemed to have hung while
trying to write configuration to disk.

Hope this helps.
Comment 1 Konstantin Ryabitsev 2008-03-29 16:53:07 EDT
Created attachment 299593 [details]
Dump of anaconda crash.
Comment 2 Jeremy Katz 2008-03-30 12:41:37 EDT
Hmm, this looks like another of the cases where udev isn't creating device nodes
for us :-/

Comment 3 Chris Lumens 2008-04-21 04:16:35 EDT
*** Bug 438981 has been marked as a duplicate of this bug. ***
Comment 4 Chris Lumens 2008-04-21 04:16:44 EDT
*** Bug 439034 has been marked as a duplicate of this bug. ***
Comment 5 Chris Lumens 2008-04-21 04:16:53 EDT
*** Bug 443361 has been marked as a duplicate of this bug. ***
Comment 6 Jens Petersen 2008-04-21 20:27:45 EDT
Bug 443361 is under qemu/kvm BTW.

Should this not be on the blocker list?  Adding it for now anyway.
Comment 7 Jens Petersen 2008-04-22 01:00:59 EDT
This appears to be fixed finally with today's rawhide.
Comment 8 Jens Petersen 2008-04-22 01:23:09 EDT
Successfully installing rawhide on kvm with both F8 and F9 virt-manager.
Comment 9 Jens Petersen 2008-04-22 01:36:49 EDT
Sorry I was over-optimistic - backtrace still happens on F8 but not F9.
Comment 10 Chris Lumens 2008-04-22 04:14:27 EDT
Did you really mean that it still happens on F8 but not F9?  We don't really
care about F8 anaconda because we're not going to be releasing an update for it.
 However if it's still happening on F9 (which I'm sure it is - we don't know the
root cause here) then that is something we do care about.
Comment 11 Jens Petersen 2008-04-22 04:20:31 EDT
I meant "on" as in host not guest: see yes still happens for me on F8 host
but not F9 host when installing a rawhide guest.
Comment 12 Jeremy Katz 2008-04-22 15:38:34 EDT
Jens -- when the traceback occurs, can you look to see if the devices exist as
well as if udevd is still running?
Comment 13 Chuck Ebbert 2008-04-23 12:01:29 EDT
*** Bug 443729 has been marked as a duplicate of this bug. ***
Comment 14 Chuck Ebbert 2008-04-23 12:05:25 EDT
Created attachment 303522 [details]
text version of the anaconda traceback in comment #1
Comment 15 Jeremy Katz 2008-04-23 12:10:00 EDT
*** Bug 443828 has been marked as a duplicate of this bug. ***
Comment 16 Jeremy Katz 2008-04-24 10:56:58 EDT
*** Bug 443979 has been marked as a duplicate of this bug. ***
Comment 17 Doug Chapman 2008-04-24 12:05:20 EDT
(In reply to comment #12)
> Jens -- when the traceback occurs, can you look to see if the devices exist as
> well as if udevd is still running?

When I hit this on ia64 with our ia64-beta tree (which is really close to the
current x86 rawhide) I checked and the /dev/ entries were not there.  After I
rebooted back to the previously installed image (on a different drive) the /dev/
entries did exist.

So yes, it sounds like udev is not creating new /dev entries under anaconda.  I
am trying this again with the latest rawhide on x86_64 to see if the behavior is
the same there.  I will leave this in NEEDINFO until I verify that, or until
Jens has a chance to confirm what he is seeing.
Comment 18 Doug Chapman 2008-04-24 12:54:12 EDT
After a few additional tries on both x86_64 and ia64 I have not been able to
reproduce this again.  This includes trying the exact same bits and options
where I hit this earlier today.  So, kind of a tricky one to debug, I am willing
to try additional stuff if anybody has ideas but at this point I am stumped.
Comment 19 Chuck Ebbert 2008-04-24 21:05:53 EDT
I just hit this problem without LVM and it fails while trying to format the swap
partition.

1. Booted in rescue mode and ran these commands to wipe the partition tables:

  dd if=/dev/zero of=/dev/sda bs=32k count=1024
  dd if=/dev/zero of=/dev/sdb bs=32k count=1024

2. Rebooted to the installer and configured partitions with a custom layout (no
LVM.)

3. The log says:

 Running... ['mkswap', '-v1', '/dev/sdb5']
 /dev/sdb5: No such file or directory

4. /proc/partitions contains an entry for sdb5 but there is no /dev/sdb5 device
node.

5. udevd is NOT running at this point.
Comment 20 Bill Nottingham 2008-04-24 21:18:25 EDT
Is this consistent?
Comment 21 Jeremy Katz 2008-04-24 22:01:05 EDT
Okay, that matches what clumens saw the one time he was able to reproduce this.
 For some reason, udevd is dying.  The question is really now to "why" and "how
do we reliably make this happen" :-/
Comment 22 Chuck Ebbert 2008-04-24 22:02:35 EDT
I tried again and it failed the same way. I watched vt5 and the udevsettle
command  takes a long time to run before mkswap then runs and fails. Just like
before, udevd is not running, sdb5 is in /proc/partitions and there is no /dev/sdb5.

(removing NEEDINFO)
Comment 23 Jens Petersen 2008-04-25 01:38:56 EDT
(In reply to comment #12)
> Jens -- when the traceback occurs, can you look to see if the devices exist as
> well as if udevd is still running?

Sorry I shouldn't have rebooted the host I guess - can't reproduce anymore.
Comment 24 Jeremy Katz 2008-04-28 22:55:54 EDT
*** Bug 444233 has been marked as a duplicate of this bug. ***
Comment 25 Jeremy Katz 2008-04-29 18:20:45 EDT
(In reply to comment #22)
> I tried again and it failed the same way. I watched vt5 and the udevsettle
> command  takes a long time to run before mkswap then runs and fails. Just like
> before, udevd is not running, sdb5 is in /proc/partitions and there is no
/dev/sdb5.

udevsettle will wait until its timeout if udevd isn't running iirc.  If you can
still reproduce this, want to try
http://katzj.fedorapeople.org/updates-restartudev.cgz as an awful hack that
restarts udev when we save partitions?

I just spent the better part of an hour trying different partitioning schemes,
etc to get this to happen without any luck at all
Comment 26 Chuck Ebbert 2008-04-30 00:54:10 EDT
(In reply to comment #25)
> udevsettle will wait until its timeout if udevd isn't running iirc.  If you can
> still reproduce this, want to try
> http://katzj.fedorapeople.org/updates-restartudev.cgz as an awful hack that
> restarts udev when we save partitions?
> 

How do I try it?

> I just spent the better part of an hour trying different partitioning schemes,
> etc to get this to happen without any luck at all

Did you zero out the partition table before starting install?

Comment 27 Harald Hoyer 2008-04-30 04:33:56 EDT
if udevd is not running then udevsettle can wait until the end of the world :)

Please can anybody get a udevd coredump, so that we can analyze where and why it
crashes???
Comment 28 Jeremy Katz 2008-04-30 21:44:49 EDT
(In reply to comment #26)
> (In reply to comment #25)
> > udevsettle will wait until its timeout if udevd isn't running iirc.  If you can
> > still reproduce this, want to try
> > http://katzj.fedorapeople.org/updates-restartudev.cgz as an awful hack that
> > restarts udev when we save partitions?
> 
> How do I try it?

http://fedoraproject.org/wiki/Anaconda/Updates

> > I just spent the better part of an hour trying different partitioning schemes,
> > etc to get this to happen without any luck at all
> 
> Did you zero out the partition table before starting install?

Yep

(In reply to comment #27)
> if udevd is not running then udevsettle can wait until the end of the world :)

Well, we run it with --timeout :)

> Please can anybody get a udevd coredump, so that we can analyze where and why it
> crashes???

If I could reproduce it and find out _when_ it crashes, it'd start to be easier
to get a coredump.  Unfortunately, we start it from the loader's init so it's
still not going to be entirely easy to get a core :/
Comment 29 Chuck Ebbert 2008-05-01 01:42:54 EDT
It looks like udevd is already gone by the time anaconda starts.

With a small change, the ugly hack of restarting it works pretty well so we do
have a fallback now.
Comment 30 Jeremy Katz 2008-05-01 13:10:48 EDT
Hacky workaround (restarting udev) at
http://katzj.fedorapeople.org/updates-restartudev.cgz 

Information on updates.img at http://fedoraproject.org/wiki/Anaconda/Updates

If anyone who can actually hit this can verify this helps, I'll commit it.  It
works for me when I manually kill udevd at least :-) 
Comment 31 Jeremy Katz 2008-05-01 21:15:22 EDT
Committed the hack described in comment #30
Comment 32 Chuck Ebbert 2008-05-05 22:16:02 EDT
I'll retest next time I get some new install media.
Comment 33 Jeremy Katz 2008-05-07 11:35:36 EDT
*** Bug 445493 has been marked as a duplicate of this bug. ***
Comment 34 Chuck Ebbert 2008-05-08 04:53:08 EDT
Works with the latest RC compose.
Comment 35 Chris Lumens 2008-05-15 10:50:04 EDT
*** Bug 446590 has been marked as a duplicate of this bug. ***
Comment 36 Chris Lumens 2008-05-15 22:04:22 EDT
*** Bug 446782 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.